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Limitation of 

Responsibilities 

 Prota shall not be held responsible for any losses caused by 

documentation, software, or usage errors. 

In addition to Prota License Agreement Terms, it is the responsibility of 

the user 

• to check of results generated by documentation and software, 

• make sure that the users of the software and their supervisors 
have adequate technical capabilities, 

• make sure that the software is used correctly per the reference 
manual and documentation, 

 

Intellectual 

Property 

 ProtaStructure is a registered trademark of Prota Software Inc., and all 
intellectual property rights belong to Prota Software Inc. Documentation, 
training, and reference manuals. Any program component can not be 
copied, distributed, and used in violation of the license agreement. 

 

 

Trademarks  ProtaStructure®, ProtaDetails®, ProtaSteel® ve ProtaBIM® are registered 

trademarks of Prota Software Inc. Prota logo is a trademark of Prota 

Software Inc.  
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Introduction  

Thank you for choosing ProtaDetails – a revolutionary automated detailing, drawing management & 

structural component design program which enables you to:  

• Create automatic detail and general arrangement drawings from ProtaStructure models 

• Produce quantity take-off and reinforcement schedules 

• Sheet management using multiple files 

• Create and modify structural details rapidly with intelligent objects & templates 

• Run component design and detailing – such as Retaining wall, Pile cap, Stair, etc. 

• Output to latest versions of industry-standard CAD formats in DWG & DXF 

This Quick Start Guide aims to get you up and running quickly. The focus will be on creating automated 

member and plan drawings. You should be able to learn the fundamental features of ProtaDetails in 

around half an hour. 

Opening a ProtaDetails Project 

In ProtaStructure Quick Start Guide, we have analyzed and designed a simple model. We will open the 

same model in ProtaDetails to produce all the reinforcement details and general arrangement drawings.  

Launch ProtaDetails from ProtaStructure interface: 

➢ In ProtaStructure, ensure the sample basic training model is opened. 

➢ Go to the Drawings & Reports tab → Click ProtaDetails  

 
ProtaDetails will launch as a separate program. You may close ProtaStructure.  

Launch ProtaDetails directly from desktop 

➢ Launch ProtaDetails 2026 on your desktop 

The Open Project dialog will appear (This is identical to ProtaStructure open project dialog) 

 

➢ Under the Project Data Folder, pick Choose / Create Folder 
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➢ Select the same Data Folder where the ‘Quick_Start_Model…’ you have saved the model.  

➢ Select the project and click OK 

If you want to open the sample completed model, choose the default ProtaData2026 folder as a data 

folder and open “Quick_Start_Guide_Concrete_Complete”.  

 

User Interface 

The main components and toolbars of the ProtaDetails user interface are below. 

 

 

The shortcut toolbars are automatically laid out according to your screen size and resolution.  

• All commands can be run from the main drop-down menu. 

• Shortcut toolbars can be re-positions by simply clicking, drag & dock to the final position. 

• Right-clicking on any command will expose the toolbar’s choices (you can on / off). 

• You can type in the command directly in the command box at the bottom. Command 

shortcuts can be set via Settings → Settings and Parameters → ProtaDetails Environment → 

Options → Command Aliases 

Users are always encouraged to launch ProtaDetails from ProtaStructure, so the detail drawings will 

always be generated based on the latest design in ProtaStructure. 

Details 

and 

Drawings 

Macros 

Start Screen/ 

Drawing View 

Main Drop-Down Menu 
Horizontal Toolbars 

Command 

Lines 

Toggle Icons (on/ 

off) 

Right Click on any icons to 

expose the toolbar choices 

Vertical 

Toolbars 

Object Snap 

Unit & 

Scale 



Page - 7 

 

 

When a new project is opened, the Start Screen will appear with the following options:   

• Auto Generate Details (Detail Drawing Manager)  –  Automated batch generation of all 

reinforcement details of reinforced concrete members and general arrangement drawings 

• Start By Creating a New Drawing  –  Open up a new blank drawing with file name 

Drawing1.dwg 

• Open Project Drawing from the list  –  Open previously generated & saved project drawings 

Details Tab 

  

Drawings Tab 

 

 

 

 

• The Details tab lists & organizes all the possible structure details, 

e.g., Form Plans (layout) that can be produced.  

• Clicking on the triangle icon preceding the text will expand the list 

to expose more details.  

• ✓ A tick means that particular detail has been inserted in a 

drawing 

• Green colored member labels indicate the member is successfully 

designed (Red = Fail  &  Amber = Analysis out of date) 

• This allows you to easily keep track of and manage details in an 

efficient manner. 

 
• The Drawing tab list & organizes all drawings (dwg) files that has 

been created & what details the drawings contain.  

• Once a particular drawing has been created & details inserted, it 

will be added in the list. Clicking on the triangle icon preceding the 

main folder will expose more details.  

• This allows you to easily keep track of and manage drawings in an 

efficient manner. 

• If you right-click on a drawing detail, there is option to “Goto 

Detail” which will locate and zoom in to that detail.   
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Macro Tab 

 

 

 

Setting Tab 

Before creating any drawings, it is recommended that you review Settings (top menu) such as Layers 

first, as this directly affects the final output. The layers, materials, member settings are now inherited 

from the ProtaStructure model. 

Settings (top menu) → Options contains many other settings such as Display. 

 

 

 

 

 

• The Macros tab lists all the engineering design macros that have 

been used & created.  

• If you right-click on a macro, there are additional options to Edit, 

Delete, Goto Detail & Open Drawing directly.   
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Click on the triangle to expose more options. Click on Scales to examine all the default scales used. 

 

You may change any of the settings before creating the details. Settings saved in ProtaDetails will 

automatically apply to the same project in ProtaStructure  (as both share the same project files). 

Draw All Model Details 

The quickest way to create all the details in one go is to use the Auto Generate Details function in the 

Start Screen. 

➢ Alternatively, go to ProtaStructure (top menu) → Details Drawings Manager 

 

A dialog will appear, giving you options to include or exclude the various details. Each detail has 

further options when it is selected. 
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➢ Choose the details you want to produce by checking on the various options 

➢ Uncheck Draw on Separate Files (so all details are inserted into a single drawing file) 

➢ Click Draw & all the details, including the plan drawings, will be created 

 

➢ Close the drawing file by clicking on the x icon of the drawing 

 

➢ When prompted to save, pick NO 

While this method is the quickest way to insert all the details, it may not be suitable in an actual project 

to insert all the details into a single drawing. The following sections will insert various details into 

different drawing files to demonstrate how details and drawings can be managed systematically. 

Creating Plan/ Layout Detail 

We will now create the plan details of the project and insert them in a new drawing.  

➢ Go to File (top main menu) → New Drawing to start a new drawing. 

➢ Double-click on Detail Drawing Manager at the top of the Details tab. 

 

A dialog showing options to show slab reinforcement bars, member dimensions & hatching columns will 

be shown. Foundation plan showing raft, footing & pile caps (if any) will be shown in St:0  
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➢ Ensure that all Storeys & Form Plan are selected (deselect all other drawings) 

You can select or deselect multiple objects by holding down the CTRL key & left click 

continually.   

➢ Go to Options 2 & 3 tabs and review all the additional settings → Draw 

➢ Click anywhere in the drawing to insert the floor plan detail. 

 

➢ Go to File (top main menu) → Save Drawing As 

➢ Change the File Name to ‘Plan Layout’ and then click OK 

 

 

To insert the plan detail of a particular storey: 

 

 

Alternatively, form plans can be inserted by: 

➢ Right-click the Form Plans 

➢ Select Draw Form Plans 

 

 

The green tick  next to the storey indicates the detail has been inserted in a drawing. 2 nos. of 

green ticks indicate the detail has been inserted twice. 

➢ Expand the Form Plans by clicking on the 

triangle icon  

➢ Click St:1 to select it → Right-click to expose 

context menu → select Draw  

➢ Click on a location in the drawing to place it 
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RC Slab Cross Sections with Reinforcement Detailing 

A reinforced slab cross-section can be created with reinforcement detailing. In ProtaDetails, cut sections 

anywhere along the layout plan drawing and position them within the drawing sheet. 

➢ Firstly, the slab reinforcements must be shown on the plan layout.  

 

➢ Go to the Drawings & Reports tab  →  Launch ProtaDetails 

➢ In ProtaDetails, generate the Form Plan drawing ensuring options to Show Rebars are 

checked. 

 

 

➢ Go to Detail Library (top menu) → Pick Plan Sections   

➢ Alternatively, in the Command line at the bottom, type “FormSection.” 

➢ In the Section dialog, input/ select the preferred options 

➢ Draw a “section cut” line by clicking on 2 points on the plan view (refer to the steps shown in 

the figure below) 

 

➢ Click on the desired location to place the section detail  

 

Please ensure that all slabs reinforcement has been designed using slab strips in 

ProtaStructure. 

More slab detailing options are available in the Options 2 tab. 

Click  (orthogonal) icon at the bottom to ensure the line is exactly horizontal/vertical.    
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Creating Column & Wall Schedules 

We will now produce the column/ wall schedules in a new drawing.  

➢ Go to File (top main menu) → New Drawing to start a new drawing 

➢ Right-click Shear Wall Elevation Drawings at the top of the Details tab and select Draw Shear 

Wall Schedules 

  

➢ Pick Column Schedule → Filter tab dialog allows you to choose which columns/walls to be 

included.  

By default, all columns of all storeys are selected.  

➢ To re-choose particular columns/ walls, hold down the CTRL key and then pick individual 

columns & walls.   

➢ You can also hold down the SHIFT key → Pick the first element → Pick the last element → all 

elements in between will be selected.  

➢ Check Shearwalls to include shear walls too. 

➢ Go to the Options tab.  

The Options tab contains more settings that control the output & presentation of the 

drawing. The newer options are explained below: 

 

• Group Similar Columns – Columns with the same section size and rebars will be 

grouped together 

• Draw Bottom Section for Slanting Column – Adds additional bottom section cut for 

slanting column 

• Draw Outline of Change in Column Size – If the column changes sizes between 

storeys, the outline lower column will also be drawn. 
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➢ Click Draw & specify a point in the drawing to place it (as shown below). 

 

 

Creating Column Elevation Details 

We will now insert the column elevation details in the same drawing. 

➢ Double click on Detail Drawing Manager at the top of the Details tab. 

 

Alternative way to insert column schedule : 

In Details tab (left pane), double-click on Detail Drawing Manager at the top of the Details tab. The 

same column schedule tab will appear. 
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➢ Alternatively, right-click on Column Elevation Drawings → Draw Column Elevations 

   

➢ In the Column Elevation dialog, check only Column Elevation  

➢ Go to the Options tab to review more settings → Draw 

➢ Specify a point in the drawing to place the detail 

All the columns & wall elevation details and the quantity table will be created below. 

 

We will now insert the combined column elevation spanning multiple storeys. 

➢ Expand Column Elevation Drawings 

➢ Expand ST: 1 → Select 1C1 or GC1 

➢ Right-click → Draw Column Elevation (Through Storeys) 
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Note that individual column elevation and schedules options are available in the menu.  

➢ In the Select Storey dialog, ensure all Storeys is selected → OK 

➢ Specify a point in the drawing to place the detail. 

➢ Expand Shearwall Elevation Drawings  

➢ Expand ST: 1 → Select 1W1 or GW1 

➢ Repeat the same steps to insert the detail for the wall (as shown below) 

 

➢ Go to File (top main menu) → Save Drawing 

➢ Change the File Name to ‘Column Schedule & Elevation’ and then click OK 
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Creating Column Application Plans 

The column application plan shows the column reinforcement on the plan layout view. The columns 

will need to be drawn to a bigger scale than the plan view to show the reinforcement clearly.  

➢ Go to File (top main menu) → New Drawing to start a new drawing 

➢ Double-click on Detail Drawing Manager at the top of the Details tab  

➢ Alternatively, right-click on Column Application Plans → Draw Column Applications 

 

➢ Ensure that all storeys are selected → Pick Draw → Click a location to insert the details. 

The below shows an example of a column application plan. 

 

➢ Go to File (top main menu) → Save Drawing  

➢ Change the File Name to ‘Column Application Plan’ and then click OK  
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Creating Beam Elevation Details 

We will now insert the beam elevation details in a new drawing.  

➢ Go to File (top main menu) → New Drawing to start a new drawing 

  

➢ In the Details tab, → right-click on Storey Beam Elevation Drawings  

➢ Pick Draw All Beam Elevations (all Axes) 

 

➢ Check the option Insert Quantity Table to insert the rebar quantity table in detail.  

➢ Check Insert to Sheet → Pick Sheet → Choose ‘A0_Prota.dxf ‘in the Sheet list  

If you would like to insert column application plan of a particular storey: 

 

➢ Expand Column Application Plans 

➢ Select a particular Storey  

➢ Right click on the storey → Draw  
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➢ You can save your sheet in C:\Users\User]\Documents\ProtaLib\Sheets.  

By default, beams wider than the sheet will be auto truncated from the sheet border. 

➢ Go to the Options tab 

 

➢ Pick how to truncate under Beam Axes Wider Than Sheet by selecting from the drop-down:  

• Don’t Truncate – even if beams details are out of sheet border 

• Truncate from Sheet Border  

• Truncate The Closest Axes from Sheet Border – will ensure truncation only at axes  

➢ Check the option Insert Concrete Beam Schedule  

➢ Click Draw → Click a position in the drawing to insert all the beam elevation details 
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The Concrete Beam Schedule shows the beam reinforcement in tabular format (as below) 

 

➢ Save the drawing File as ‘Beam Elevations’ 

Inserting Beam Details by Axes 

If you only want to insert a particular beam axis:  

➢ Expand the Storey ST:1 

 
The beams will be listed along the design & detail axes, similar to how it is presented in 

ProtaStructure beam design. 

➢ Select any of the beams, e.g., 1B1-1B2 

➢ Right-click → Draw  

➢ Click the position to insert the detail in the drawing space. 

A green tick  will be displayed next to the beam axes to indicate the inserted beam detail. 
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Inserting Beam Details One by One 

To insert the beam details of all axes of a particular storey in a batch mode: 

 

➢ Select St:1 

➢ Right-click → Draw Beam Elevations (one by one) 

➢ Click the position to insert the 1st beam detail in the drawing space 

➢ Continue to click successively to position the other beams 

➢ Press Esc to end the process prematurely 

Search a Member Detail or Text 

The “Search” function enables you to find, filter quickly, and locate a member detail or text, such as 

beam 1B1. 

How To Use Search in the Tree view: 

 

➢ Go to the Details tab 

➢ Input a member label, e.g., 1B3, in the box 

Only the details with the exact name match will be located & displayed. You can then draw 

out this detail only. 

➢ Right-click → Draw 

➢ This feature is handy if you only want to draw out a particular detail, not all of them. 

After drawing details or objects, you can use the new text search function to locate them. 
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How To Use Text Search: 

 

➢ Go to Edit → Search Text (CommandLine: SearchText) 

➢ In the Search Text dialog, type the text, e.g., 1B3 → Enter 

➢ Double-Click on the found items & they will be located & zoomed into focus 

 You can also use this function to search for all texts in primitive entities and intelligent objects. 

Drawings 

The Drawings tab keeps track of various details that have been inserted and also the drawing files 

created. This feature will enable you to manage your project details and drawings systematically and 

efficiently. 

 

➢ Click on the Drawings tab to review all the drawing files saved and what the details they 

contain 

➢ Click on the triangle icon to expand or collapse the details 

➢ Verify that all details have been inserted  

To locate a member detail in a drawing:  

➢ Ensure that the drawing is opened 

➢ Locate the member by drilling down the triangle 

➢ Right-click → Goto Detail  
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The member detail will be located and zoomed into focus in the drawing.   

Drawing Management 

There are functions to draw and update the details which are accessible from ProtaStructure tools (top 

menu): 

 

• Update All Model Drawings  –  Updates all the model drawings without checking if anything has 

changed in the ProtaStructure model. This operation is a forced update. All the drawn items are 

forced to be regenerated.  

• Update Modified Members Only  –  Checks and summarizes all the members modified in 

ProtaStruture. If you choose to continue, you get only modified members to update. 

• Update All Plan Sections  –  Updates all the sections of the plan view that are manually created. 

• Drawing Summary – Creates a table of drawing file names and their respective detail 

components.  

• Model Info – Inserts a table showing project information summary such as materials & 

parameters. 

• Concrete Rebar Schedule  –  Inserts the concrete rebar schedule of a particular storey. 

• Column Link Details  –  Draws the link details for columns & the Quantity Table. 

• Column Rebar Details  –  Draws the main reinforcement column details & the Quantity Table. 

Dimension Styles Interface 

Dimension styles can be edited using this interface and can be saved along with the project 

➢ You can find it under Formats (top menu) → Dimension Styles  

➢ All the necessary dimension styles for detail generation will come predefined 

➢ Use “+” and “x” buttons to add/remove dimension styles 

➢ Edit them as you wish. When you click the “OK” button, they will be saved in the project data. 

There is no need to save the project or drawing explicitly. 
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Multiple Selection of Tables for Report Generation 

Any table drawn in ProtaDetails can be converted to a report and generated via the Report Manager. 

How To Use: 

➢ Select a table or multiple select tables (hold down CTRL) 

➢ Right-click → Add to Report 

➢ Give it a title →  OK 

➢ The report will be created 

 

This report will also be added in Design Report Manager under Quantity Take-Off Reports. 
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Creating Staircase Elevation Details 

We will now insert the staircase details in a new drawing.  

➢ Go to File (top main menu) → New Drawing to start a new drawing 

  

➢ In the Details tab, → right-click on Storey Staircase Drawings  

➢ Pick Draw Staircase Details  
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➢ Check the option Insert Quantity Table to insert the rebar quantity table in detail.  

➢ Check Insert to Sheet → Pick Sheet → Choose ‘A0_Prota.dxf ‘in the Sheet list  

➢ You can save your sheet in C:\Users\User]\Documents\ProtaLib\Sheets.  

➢ Click Draw → Click a position in the drawing to insert all the staircase details 
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Inserting Staircase Details One by One 

To insert the staircase details of all axes of a particular storey in a one by one: 

 

➢ Select St:1 

➢ Right-click → Draw Staircase Elevations (one by one) 

➢ Click the position to insert the 1st staircase detail in the drawing space 

➢ Continue to click successively to position the other beams 

➢ Press Esc to end the process prematurely 

Search a Member Detail or Text 

The “Search” function enables you to find, filter quickly, and locate a member detail or text, such as 

beam S101. 

How To Use Search in the Tree view: 

 

➢ Go to the Details tab 

➢ Input a member label, e.g., S101, in the box 

Only the details with the exact name match will be located & displayed. You can then draw 

out this detail only. 

➢ Right-click → Draw 

➢ This feature is handy if you only want to draw out a particular detail, not all of them. 
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After drawing details or objects, you can use the new text search function to locate them. 

Adding Complete Building Section to Formwork Plans 

By drawing a section line from any position in Prota Details, a complete section of that section can be 

obtained and placed in the desired position on the sheet.  

- Start ProtaDetails by going to the Drawings and Reports tab. 

- Create the formwork plan in Prota Details. 

 

➢ Check the Building Section option in  Drawing Library. Also, if you type “Building Section” in 

the command line and press the Enter button on your keyboard, the command becomes 

active. 
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➢ You can make the desired settings in the section dialog box and enter values for parameters 

such as slope ratio, excavation distance, etc. 

➢ Draw the section line by selecting two points in the direction you want the section to be 

taken and click where you want the section to be placed. 

 

 

 

Drawings 

The Drawings tab keeps track of various details that have been inserted and also the drawing files 

created. This feature will enable you to manage your project details and drawings systematically and 

efficiently. 

 

➢ Click on the Drawings tab to review all the drawing files saved and what the details they 

contain 

➢ Click on the triangle icon to expand or collapse the details 

  Horizontal or vertical sections can be easily created by turning on the Ortho command. You 

can also activate the Ortho command by pressing the F8 button on your keyboard. 
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➢ Verify that all details have been inserted  

To locate a member detail in a drawing:  

➢ Ensure that the drawing is opened 

➢ Locate the member by drilling down the triangle 

➢ Right-click → Goto Detail  

The member detail will be located and zoomed into focus in the drawing.   

Drawing Management 

There are functions to draw and update the details which are accessible from ProtaStructure tools (top 

menu): 

 

• Update All Model Drawings  –  Updates all the model drawings without checking if anything has 

changed in the ProtaStructure model. This operation is a forced update. All the drawn items are 

forced to be regenerated.  

• Update Modified Members Only  –  Checks and summarizes all the members modified in 

ProtaStruture. If you choose to continue, you get only modified members to update. 

• Update All Plan Sections  –  Updates all the sections of the plan view that are manually created. 

• Drawing Summary – Creates a table of drawing file names and their respective detail 

components.  

• Model Info – Inserts a table showing project information summary such as materials & 

parameters. 

• Concrete Rebar Schedule  –  Inserts the concrete rebar schedule of a particular storey. 

• Column Link Details  –  Draws the link details for columns & the Quantity Table. 

• Column Rebar Details  –  Draws the main reinforcement column details & the Quantity Table. 

Dimension Styles Interface 

Dimension styles can be edited using this interface and can be saved along with the project 

➢ You can find it under Formats (top menu) → Dimension Styles  
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➢ All the necessary dimension styles for detail generation will come predefined 

➢ Use “+” and “x” buttons to add/remove dimension styles 

➢ Edit them as you wish. When you click the “OK” button, they will be saved in the project data. 

There is no need to save the project or drawing explicitly. 

 

Multiple Selection of Tables for Report Generation 

Any table drawn in ProtaDetails can be converted to a report and generated via the Report Manager. 

How To Use: 

➢ Select a table or multiple select tables (hold down CTRL) 

➢ Right-click → Add to Report 

➢ Give it a title →  OK 

➢ The report will be created 

 

This report will also be added in Design Report Manager under Quantity Take-Off Reports. 
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Engineering Design Libraries 

Structural components design & detailing are available via Design Libraries (top menu): 

• Cantilever Retaining Wall 

• Pile Cap 

• Pile Design 

• Engineering Utilities 

• Stairs 

• Corbel 

• Pool  

• Engineering Utilities for quick engineering design & calculation 

These powerful engineering modules provide a full calculation report, detail drawings, and quantities.  

After running the design libraries, close the module and click anywhere in the empty drawing to insert 

the detail & the quantity table (if applicable). The macros will then be added in the Macros tab. 

 

If you right-click on a macro, additional options are to Edit, Delete, Goto Detail & Open Drawing directly.   

Save the drawing to ensure the engineering macros are retained when the drawing is closed.  

 

These engineering libraries will be expanded continually to cater to your engineering needs. Kindly 

feedback to us if you have any ideas for engineering libraries. 



Page - 33 

 

Cantilever Retaining Wall 

 

 

Input and Options 

This tab control can select geometry, soil parameters, analysis options, and loadings. The whole design 

process will progress by setting fields and options in the tabs. 

Dynamic Model View 

A dynamic view of the retaining wall section is displayed in this field. Any changes in input will 

immediately update this image 

Analysis Result Summary 

Summary of overturning safety, sliding safety, total failure, and soil bearing capacity checks are 

displayed for seismic (EQ) and non-seismic (non-EQ) scenarios. They update automatically along with 

any changes in the input. 
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Pile Cap 

The pile cap design library in ProtaDetails is similar to the pile cap design module in ProtaStructure. 
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Pile Design 

 

• In the Pile Geometry tab, input all the parameters such as Circular/ Square/  Rectangular, size, 

length, etc. 

 

• You can specify concrete grade, rebar, and link grades & diameters in the Design tab. 

• The Main Reinforcement & Stirrup (links) can be defined.  

• Click OK (on the right bottom of the Pile Design dialog) > Pick and insertion point on the 

drawing to insert the pile details.  

 

The defined material and rebars will be used for generation of pile details, calculations of pile 

allowable structural capacity, and lateral analysis. 
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Stairs Design

 

 

• Input stair parameters in the input fields and click Redesign to view the stair design results. 

• Users can generate a Design Report for more detailed analysis results, such as bending moment 

values, deflection check, section forces, etc. 
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Pool Design 

The Pool Design can be used to analyze, design, and detail pools or tanks of various shapes and sizes. 

You define different soil profiles surrounding the pool walls and apply various surcharge loads on the 

soil.   

 

➢ Select from Gallery 

• Select the type of pool for the choices provided.  

➢ Points: Defines the characteristic & shape of the walls of the tank 

• Enter bottom & top elevation of the tank. The difference is the tank depth.  

• Points table: Define the bottom joint coordinates of each tank wall—also, the 

curvature. 

➢ Slabs: Defines the characteristic & shape of the bottom slab(s) of the tank 

• Points table: Define the bottom joint coordinates of each slab—also, the edge 

curvature. 

• For the pool slab, clicking Use Wall Geometry would automatically set the slab’s 

geometry the same as wall geometry. 
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➢ Properties: Define material, code, soil model & surcharge loads.  

• Material: Choose Concrete grade, rebar grade & diameter for design 

• Settings: Choose the design code & parameters 

• Soil Model: Choose active or passive load side, long or short-term load, water table 

level, etc 

• Soil Profile: Define the soil profile & layers 

• Surcharge: Input surcharge loads (point, line, strip & surface load) 

• Results & Report: Print & review the analysis results of the walls, e.g., active pressure 

& forces  

➢ Design: Design the wall tank (base slab is not designed, rebars is user-defined) : 

• Change the wall & slab thickness & click Renew Rebar Design (if the first round of 

design fails) 

• Pick load cases to consider, e.g., post-construction, operations, maintenance & 

earthquake 

➢ Draw Details: Draw the reinforcement details in including plan and cut sections.  

➢ Print Report:  Print the entire pool reporting, including geometer, analysis, and design. 

➢ Transparency: Shows the reinforcement in 3D.  

➢ Zoom Extent: Zoom to the extent of the diagram 

➢  OK: Click OK to exit and place the detail drawing into the currently opened drawing. 

 

Engineering Utilities for quick engineering design & calculation 

The handy Engineering Utilities can be used for a quick engineering design. This tool includes a calculator 

for concrete cover, rebar anchorage & lap lengths; a simple beam analysis tool to calculate maximum 

shear, moment, and deflections; a hydraulics calculator for uniform flow depth & gradually varied flow, 

etc. 

How to Use: 

➢ Go to Design Library (top drop-down menu) → Engineering Utilities 

Before performing pool design, soil model must be assigned to the walls in Properties tab.  

Base slab design is out of the scope of program; the rebars are user-defined.  
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The following is the complete list of the modules and their functions: 

➢ Cover and Anchorage Calculator   

• Calculates concrete cover, anchorage, and lap lengths. 

➢ Hook Length Calculator 

• Calculates rebar bending, extension & total hook length. 

➢ Rebar Area Calculator 

• Calculates provided steel area per meter (e.g., 10H16 @ 100mm spacing) based on 

required steel area. 

➢ Unit Conversion 

• Converts common engineering units, e.g., Pascal (Pa) → Kilo pound Per Square Inch 

(KSI). 

➢ Simple Beam Analysis 

• Calculates maximum shear, moment & deflection for a single-span beam with various 

support conditions such as simple, cantilever & fixed end. 

➢ Uniform Flow Depth (Hydraulics) 

• Solves for discharge, flow depth, channel width, or channel slope for rectangular, 

trapezoidal, or circular channels under ‘uniform flow depth’ condition. 

➢ Gradually Varied Flow (Hydraulics) 

• Solves for discharge, flow depth, channel width, or channel slope for rectangular, 

trapezoidal, or circular channels. 
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Closing Summary 

 

Congratulations! You have completed your first automated detailing & general arrangement drawings 

production & management project in ProtaDetails.  

In this Quick Start Guide, you had first-hand experience of how easy it is to create all the detail 

reinforcement & layout drawings of the project model you first started in ProtaStructure. You also 

discovered how the engineering component design libraries (such as the retaining wall) enable you to 

efficiently produce comprehensive analysis & design reports and detail reinforcement drawings with 

quantity take-off.  

We recommend you go through the What’s New document on the new and enhanced features of 

ProtaDetails.  

ProtaDetails includes many more powerful detailing features, such as intelligent rebar objects. For more 

help and guidance, please refer to the help reference accessible from the Help menu.  

Alternatively, you can attend our training courses to obtain a more in-depth knowledge of the software 

usage. Please visit our website www.protasoftware.com for more information. 

  

http://www.protasoftware.com/
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Thank You 

Thank you for choosing the ProtaStructure Suite product family. 

Our top priority is to make your experience excellent with our software technology solutions.  

Should you have any technical support requests or questions, please do not hesitate to contact us at all 

times through globalsupport@protasoftware.com and asiasupport@protasoftware.com  

Together with our responsive technical support team, our dedicated online support center is available 

to help you get the most out of Prota’s technology solutions.  

 

The Prota Team 
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