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Limitation of 

Responsibilities 

 Prota shall not be held responsible for any losses caused by 

documentation, software, or usage errors. 

In addition to Prota License Agreement Terms, it is the responsibility of 

the user 

• to check of results generated by documentation and software, 

• make sure that the users of the software and their supervisors 
have adequate technical capabilities, 

• make sure that the software is used correctly per the reference 
manual and documentation, 

 

Intellectual 

Property 

 ProtaStructure is a registered trademark of Prota Software Inc., and all 
intellectual property rights belong to Prota Software Inc. 
Documentation, training, and reference manuals. Any program 
component can not be copied, distributed, and used in violation of the 
license agreement. 

 

 

Trademarks  ProtaStructure®, ProtaDetails®, ProtaSteel® ve ProtaBIM® are registered 

trademarks of Prota Software Inc. Prota logo is a trademark of Prota 

Software Inc.  
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Introduction 

Thank you for choosing ProtaSteel – Steel detailing & connection creation module of the 

ProtaStructure suite. The primary steel model must be created in ProtaStructure. The model can be 

exported & opened in ProtaSteel seamlessly. In ProtaSteel, you can :  

• Model ancillary/secondary steel members such as roof purlins, girts, sag rods, staircase, etc. 

• Adjust members to final positions for accurate detailing  

• Create and design steel connections 

• Create any steel connections manually, save them macro library and reuse them at similar 

nodes. 

• Produce engineering drawings of the steel structure and connections 

• Sharing the 3D model created with other BIM platforms such as Tekla Structures.  

 

Before you proceed, it is highly recommended you go through ProtaStructure User Guide as 

knowledge of the fundamentals of ProtaStructure is required. 

This Quick Start Guide aims to get you up and running quickly. You should be able to learn the 

fundamentals of ProtaSteel in approximately 2 hours by following this simple guide.  

Exporting Model to ProtaSteel 

A sample steel model is already created & installed in the default installation folder of ProtaStructure. 

We will now open the model, run analysis & export it to ProtaSteel :  

• Start ProtaStructure and the Open Project dialog will appear.  

• Select & open project “Quick_Start Steel_Complete” 

• Go to Analysis → Building Analysis 

• Go to Analysis tab →  Tick Building Analysis → Start  

• Close the Building Analysis menu 
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• Go to Drawings & Reports → Load ProtaSteel 

ProtaSteel will start and load the project model. ProtaSteel model is created in the subfolder 

“ProtaSteel” in the project folder.  

User Interface 

The various components of the ProtaSteel user interface are as shown below:  

 

Model Explorer  

Default views are created under the “Views” folder in the model explorer pane. By default, the views 

created are the 3D views & plan views of each story.  

Double-click on the desired view in the left-hand Explorer pane to open it. You can open as many 

views as you like. 

The graphical editor supports multiple windows; you can open as many windows as you desire. 

Modeling can be done both on the plan view and the 3D view.  

Steel Elements and Detailing 

 

“Visibility” filters are very frequently used commands and are fixed in the top left corners of all menus 

in the top menu. By using visibility filters, elements that are not wanted to appear on the model can 

be removed from view. 
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In ProtaSteel, you can only create joist, purlin, girt, sag rod, and stair member (stringer). Primary 

members such as beam, column & brace must be inserted in ProtaStructure.   

Stair members can create both ProtaSteel and ProtaStructure. But, in the Protasteel, loads can not 

assign to the stair beams and can not design the sections.  

Detailing tools include the manual connection members such as plate, sectional plate, chamfer, bolt, 

weld, connection detailing item manager, etc.  

Intelliconnect Tools 

 
 

Intelliconnect is an intelligent connection tool that can be applied for different element types. In this 

menu, quick access to commands separated according to the member type can be provided. These 

commands can also be accessed from the right-click menu. 

More detailed information about IntelliConnect can be found later in the document. 

“IntelliConnect Tools” are used to clean the information on nodes previously connected by 

IntelliConnect. For example, you have modeled connections with IntelliConnect on truss elements. But 

you changed your mind and deleted these macros. Afterward, you should also apply “Clear Node” at 

these points. Otherwise, you cannot model connected with IntelliConnect again. 

Edit 

 
 

Copy, move, mirror, rotate, cutting objects located in this menu. These commands are also available in 

the right-click menu.  

We can use reference objects such as points, lines, circles while detailing in ProtaSteel. These 

commands are only used during modeling in the interface, and they are not transferred to the 

drawings. 

With selection modes, desired elements can be displayed or removed from view in ProtaSteel. 

Many parameters such as profile sections, materials, macro types, or element section types can be 

filtered with the selection filters. At the same time, any assembly or part number in the model can be 

found quickly with the help of filtering.  

Divide and join commands can be applied only to added elements in ProtaSteel. 
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View  

 
 

In the ProtaSteel interface, we can create a two-dimensional cross-section by showing the two or 

three points we want on the model. 

 

We can use “with 3 points” to create a plane on the roof. We often use “with 2 points”, especially 

when making manual connections.  

 

We can set the drawing mode and perspective view of the objects from this menu. 

 

With the color coding tools, we can show the connection status, material sections, or materials with 

the color. 

Zoom and Pan Methods 

The view manipulation is similar to ProtaStructure. You will find it easiest to use the mouse wheel to: 

Zoom in  – scroll your mouse wheel up 

Zoom out  – scroll mouse wheel down 

Pan (move)  – hold down the middle mouse wheel and drag  

Rotate     – Right-click & drag  

The following keyboard shortcut keys are helpful: 

Zoom All    – Home key → Zoom so that all content is visible in the viewport 

Origin of Interest  – F9 key → Set the center of rotation by clicking on any node or object (such as 

bolt or plate). The model will then rotate around the selected point.  

Selection Methods 

Click on an entity to select it. 

Hold down the CTRL key and click on the macro to access macro properties. 

To select multiple entities, hold down the CTRL key while picking them. 

You can drag with the mouse to access further selection options: 

Drag from left to right to create a rectangular box. When you release the mouse button, all entities 

wholly contained within the box will be selected 

Drawing a box from right to left will select all entities within the box and cross its boundaries. 
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To deselect all entities, click on a space anywhere in the viewport.  

Set Workplane  

The working plane is essential for using some commands and for the movement of objects, such as 

copying and moving in the direction we want. By adjusting the working plane to any plane, location, 

point, or surface we want, we can provide object movement in that plane. 

The working plane is indicated in the interface by red and green arrows. 

By 3 Points                       –  Creates a new workplane by selecting 3 points 

To View Plane   –  Moves the workplane to the active view plane 

To Global               –  Moves the workplane to the global plane 

To Object                         –  Moves the workplane to the local coordinate plane of a point 

To Surface                        –  Moves the workplane to the surface of an object 

To Point             –  Moves the workplane to a point 

Rotate and Move  –  Rotate and move the work plane 

User Interface 

The model can be displayed as a full screen in the interface. The side menus with the “Model Explorer” 

and “Macro Gallery” can be closed and opened. All views created by clicking the “Maximum Model 

View” button can be viewed and closed collectively. 

Drawings and Reports 

 

Drawings 

“Drawing Module” is opened with the “drawings” command on the top menu or double click on the 

“Model Explorer > Drawings”. Also, the CTRL+D shortcut can use to open it. 

Numbering 

ProtaSteel performs the numbering process according to the similarities of all assemblies and parts in 

the model whose detailing has been completed and whose drawings will be prepared. 

Drawings cannot be created without numbering on models with finished detailing. The issue of 

numbering is explained in detail in the following sections.  
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Material Lists 

Protasteel can prepare material lists for all members or selected members on the structural model. In 

addition to the assembly and part lists, sub-part lists that make up each assembly are also prepared. 

The lists are prepared in detail according to the features such as thickness, length, surface area, 

section type, number of bolts, material quality. 

Connection Design Checks  

The structural model, whose analysis is completed in ProtaStructure, is transferred to ProtaSteel with 

internal forces. ProtaSteel uses these internal forces in connection designs. The design code can be 

selected from the “Project Preferences” section in the “File” menu. 

Calculation reports of a connection can be accessed via the connection’s context menu. The summary 

table for all connections can be accessed with the “Design Summary” command. Design reports for 

different design codes of the same connection can also be created. 

More detailed information on this issue is given in the following sections. 

Tools 

 

Database  

Profile sections used in the building model are defined in ProtaStructure and transferred to ProtaSteel. 

Additionally, the profile catalog in ProtaSteel can be used for sections such as purlin, girdle, beam to 

be defined in ProtaSteel.  

If you cannot find the profile in the ProtaSteel profile catalog, you can use it by defining the desired 

section type in the database. The same method can use for bolt catalog. 

Diagnostic Tools  

After the connection detailing processes are completed in ProtaSteel, clash checks should be done 

before drawings are prepared. If there are collision problems between the members, the model 

should be reviewed.  

Detailed information on this issue is explained in the following sections. 
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BIM 

 

Import DXF  

Plans and sections in architectural projects can be exported to ProtaSteel with DXF 2000 file. In 

particular,  this feature allows the control of the architectural project and the manufacturing project 

by superposing.   

Import from ProtaStructure 

As known, ProtaStructure exports the structural model to ProtaSteel. Similarly, data can also be 

imported from ProtaStructure into a ProtaSteel file. 

Export IFC File 

The structural model prepared in ProtaSteel can save as an.IFC file. So, the structural 3D model can 

also open in the other software. 

Export NC Files 

CNC machines are generally used to create structural parts. Parts create the assemblies. ProtaSteel 

produces “.NC” files and quickly transfers the part drawings to CNC machines. 

Export to TEKLA  

The structural model prepared in ProtaSteel with all its details can be transferred to Tekla Structures 

software.  

The transfer process is done with a plug-in called TEKLA IO. This plug-in is located on the “Downloads” 

page of the ProtaStructure website. (https://www.protayazilim.com/downloads). 

You can watch the video about using the plug-in on the ProtaStructure Youtube channel. 
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Help 

 

ProtaSteel Help 

When guides and reference manuals are needed, users can always click on this option to directly lead 

them to our Prota Help Center. 

Basic Training Guide 

Basic Training Guide can be very helpful before starting a project or when working on a project. The 

training guide can always be referred using this link. 

Shortcuts 

Shortcut keys which can be handy when dealing with repetitive commands. A list of shortcut hotkeys 

can be found in this link. 

About 

The company license information and ProtaSteel version and module can be found here. Other than 

that, Protasoftware support contact (e.g. email) can be found here. 
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Automatic Connection Tools (Macro Gallery) 

The macro gallery is located in the right side menu in 

ProtaSteel.  

Macros are smart connection tools that allow us to 

model steel connections quickly—for example, fin 

plate, gusset plate, haunch connection, splice, etc. 

All macro types are classified according to the member 

types they are connecting. 

Recent macros can be selected quickly at the top of the 

macro gallery. 

The manual macro command is also at the bottom of 

the list. The user-defined macro library can be created 

here. 

Detailed information about macros is given in the 

following sections 

 

 

If you hover the mouse cursor over any icons, a tooltip 

will appear with a detailed explanation of how to use it. 

You can set the default parameters for each run by 

right-clicking on the macro icon. 

 

Macros 

• A macro is generally defined as a shortcut tool that specifies how a particular input sequence 

will result in the desired output according to a defined procedure. 

 

• Before creating the macro elements, you can set the macro settings, e.g., member profile, 

plate offsets, bolts, etc., by right-clicking on the macro icon, which will bring up the Macro 

dialog.  

 

• Once a macro is clicked, the mouse cursor will change to the hand icon , implying that it is 

waiting for object(s) selection. A crosshair + icon means that it is waiting for point selection. 

The tooltip states that perform the required action(s) to get the desired result.  

 

• The macro will remain activated; you can continue using the macro without clicking on the 

macro icon again.  
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• Once you have finished, you must press ESC to cancel & stop the macro. The mouse cursor 

will change back to default arrow   (selection mode).  

 

• After creating the elements in a group, such as the purlins, each element will have its 

individual properties, which can be changed by double-clicking on it → this will bring up the 

Element dialog. 

 

• However, all the elements are still associated with the macro & can be changed in a group.  

 

• This can be done by selecting the macro sign  & then pressing ENTER will bring up the 

macro dialog. After making the changes, clicking Apply will apply to all the elements 

associated with the macro. Clicking Get will set it to default for this macro for future projects. 

 

• Suppose you have problems selecting the macro sign. In that case, you can choose any 

element or component of the macro (e.g., a plate of a connection) then press “M” → this will 

select the macro → hitting the ENTER key will expose the Macro dialog.  

 

• You can select all the elements associated with the macro by selecting the macro sign or an 

element of the macro → press “CTRL + M”.  

 

• You can also delete all the elements & components of a macro by selecting the macro sign & 

then hitting DELETE. 

 

• It is highly recommended you review the macro settings before executing them.  

 

• You can reload/clear the changes in the macro default setting by going to Tools (tab) → Macro 

Defaults → Select macro → Reload/Clear Selected Macro Defaults 
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Selecting the Macro Associated with Objects 

You can click the Macro icon  on the screen to select the macro associated with any object. 

However, as the number of objects in the model increases, it may become challenging to distinguish 

macro symbols. To quickly select the macro associated with any object: 

• Select the object. (For example, a plate, a bolt group, or a weld)  

• Press M on the keyboard. The macro symbol will be selected. 

• Press ENTER on the keyboard. So, you can open the macro properties window. Press the 

DELETE key to delete/remove the macro or associated objects.  

Selecting All Objects Associated with a Macro 

In some cases, you may want all objects related to a macro to be selected. For this: 

• Select the macro symbol.  

• Or select an object created with macro.  

• Press CTRL+M on the keyboard to select the associated entities.  

 

Views and View Settings 

The 3-D view is created by default and displayed on the screen when you open 

the project. However, plan views at each floor level are also automatically 

generated.  

Views are displayed under the ‘Views’ folder in the left project panel. 

• Double-click on the desired view in the left project panel will open that 

view. You can open as many views as you want. 

 

 

You can open the View Manager by double-clicking the 

Views heading in the build tree.  

In the view manager:  

• View can open 

• View can close 

• View can delete 

• You can change the view properties 
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If the multiple views open, you can fit them to the screen by using the Views > View list> Tile 

Horizontal / Tile Vertical / Cascade. 

 

You can change the object draw mode using “View > Object Draw Mode.”  

 

You can cycle through the drawing modes by pressing the Alt + D key combination repeatedly 

You can specify the 3D view is perspective or orthogonal by using  Views > Projection Modes. 
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Creating new Views 

 

In addition to the 3D view and plan views automatically created in ProtaSteel, a new 3D view can be 

created with the Views > 3D View. 

To create a quick view at a certain depth by specifying the X, Y, or Z directions of the 3D view, a view 

can be created according to a particular plane with the Views > Plan View option. 

For example, selecting “XY Plane View” opens a text box for entering a depth value in the plane 

direction. Let’s write a depth value of 5000mm in this text box. In this case, the resulting view is added 

to the building tree by giving the name “5000 mm elevation plan”. 

 

Section views can also be created from the desired region of the building model by selecting 2 points 

and 3 points. 

 

Let us create a new sectional view along grid 3 :  

• Go to Views (tab) → select “View by 2 Points.” 

• Click two points to define a plane →  the view will be created as shown below 

A white line arrow will appear once the mouse cursor hovers on 2nd point. This white line indicates the 

direction of viewing. In this case, the above view is looking into the building. 

The coordinate system will be changed according to the current work plane.  
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The sectional view is created from the same 3D model but viewed from a different camera angle or 

orientation. Changes made to the active view are automatically reflected in all other views. The 

extent, boundary, and objects to display can be set via View Properties. 

To access the View Properties: 

• Double-click anywhere on the new view → The View Properties will appear. 

 

• Give the view a new name, “Axis A.” 

• Change the Up(+) and Down (-) to 1000mm and -1000mm respectively.  

This means that the view will only show elements 1m into & out of the plane. This will make 

the view less cluttered as elements along other grids will be hidden. If zero values are entered, 

then it will be unlimited.  

• Up-Down Method : 

- Partial: Any element that exists partially within the set extents will be shown 

- Full: Only elements that exist entirely within the set extents will be shown 
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• Click OK to close the dialog & the view will be updated.  

Any sectional view is inherently a 3D view. Hence you can still rotate the view. 

• Right-click and drag to rotate the Axis 3 view. (Notice that only members within the 1 m 

extent are shown.) 

• Go to View Properties again. 

• Change the Up-Down method in View properties to FULL → Apply (Notice all the beams out of 

the plane of Axis A will be hidden.) 

• Press F4 to restore lookup (i.e., convert to original viewing direction) 

You must give the view a new name and check/tick “Save” to ensure the view is saved. Only saved 

views can be used to generate drawings in the drawing module.  

 

Automatic View Creation 

ProtaSteel can automatically create a 2D section and plan views from 

all structure axes. 

• Select “Grids”  

• Right-click.  

• Select “Grids > Create Views 

on Grid.”  

 

Section and plan views are created 

automatically from all grid and floor 

levels. The ProtaSteel automatically 

labels all sections.  

 

Thus, you can effortlessly create all sections to be added to the 

general layout drawings.  

With the “Grids > Delete Created Views” command, you can delete 

the created views in bulk.  
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Visibility & Selectability 

You can control what objects are visible and selectable by assessing the Drawing Settings dialog: 

• Double click on the view and pick Drawing Settings in the View Properties dialog   

• Alternatively, click on the Visibility icon in the View tab    

• Turn off the Grids & Points  

• Apply and see the effect 

• Go back and turn them on  

You can Save As these different settings as another name to quickly reuse them. 

 

 

 

 

 

 

“Visibility” shortcut buttons are also available in the “View” ribbon tab. 

 
 

“Selectability” shortcuts are located at the bottom left of the screen in the interface. 
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Adjustment of Members by Creating Points  

In ProtaSteel, you might also want to adjust the position of members that are not precisely at the 

correct position, i.e., fine-tuning of final member positions for detailing purposes.  

In ProtaStructure, all the braces inserted will join at the top of beams instead of at the middle 

(centroid) of the beam. This is because the analytical position of any beam in elevation is at the top of 

the beam.  

The following example is provided for educational purposes. In the models defined in ProtaStructure, 

truss members such as top chord, bottom chord, diagonal and vertical members, purlins, and braces 

are defined in their correct positions and transferred to ProtaSteel ready for detailing. 

In ProtaSteel, detailed tools are available to adjust the positions and fine-tune the members that are 

not in the correct position. For this; 

• Double-click on the previously created Axis 3 view in the Model Explorer 

• Zoom in to the location of the diagonal braces between Grid C and D 

 

As you can see, the diagonal bracings are 

connected to the top of the beam. It is more 

accurate for the bracings to join at the middle of 

the beam.   

To do that, we must create a point (or node) in 

the middle of the beam. 

With the point created, we can then move the 

ends of the bracing to this point.  

Note: Alt + D key combination can switch drawing 

modes. 

 

 

The “Adjust Frame Manually” command is located in the “Edit” menu. 
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• Click Adjust Profile Manually in Edit 

(tab) → Edit Frame 

• 1 – Select the diagonal top bracing  

• 2 - Click on existing end point 

• 3 - Click on the new point 

• The brace end will be shifted to the 

new point. 

 

• Press Alt + D until you see the outline 

of members only (wireframe mode) 

• Click “Create Dividing Points” icon  

in Edit (tab)→  Point 

• 1 – Click top point of the beam   

• 2 - Click bottom point of the beam  

• A new point “+” is created as shown 

in the left figure.   

• Press ESC to stop the function 

 

• Repeat the above Step 1 to 3 for the 

other bottom diagonal brace. 

• The final positions of the diagonal 

braces are as shown in the left figure. 

• Double-click on 3D View in the 

Explorer pane to go to the 3D view. 

• Zoom in the same location & check 

the diagonal braces final positions to 

ensure they are correct. 
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Adjustment of Members Orientation and Coordinates 

All member positions and orientation can also be changed without creating new points. We will make 

such minor adjustments to some of the floor braces:  

• Double-click on Storey 1 view to open that view 

• Right-click and drag to rotate it a 3D view 

• Zoom to the joint where the secondary, main beam and two horizontal “L” braces meet  

• Press F9 & click on the joint to set it as a point of interest so that rotation is about this 

point 

 

Notice L braces orientation is not symmetrical with the other. We will rotate the brace, so that flange 

of the brace is aligned with the flange of 

the beam. 

 

  

• Select the brace  

• Press Ctrl + Q to rotate it until the correct 

orientation is achieved as shown in the left 

figure 

• Repeat for the other brace 

• The braces are coming in too close to the 

secondary beam. We can shift it slightly away. 

• Press Ctrl + W to offset the brace horizontally 

until it is farthest away from the secondary 

beam 

• Repeat for the other brace  

Shift 

away 

F9 & click here 

Shift 

away 
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Double-click on the right L brace  

Profile Properties dialog allows you to change :  

• Profile /Section type by picking “…” 

• Alignment (Out of Plane, In-plane, Rotation) 

• Offsets Start & End  

• Draw Frame Coordinate System 

• Change Frame Coordinate System to For 
Analysis & design → Apply 

Notice 3 arrows showing local axis appear at the 
frame end. Red arrow = x-axis; Green arrow is y-axis; 
Blue arrow is z-axis. 

• If the axes are not visible, please ALT+D to 
change to Wireframe 

• Enter z Start & End Offset to 100 mm → 
Apply 

• Check the 3D view to ensure brace is moved 
down 

• Repeat for the other brace (-100mm) → OK 
to exit 

 

In ProtaSteel, in-Plane and Out-of-Plane holding points of the members and their offset from these 

points can be adjusted in detail. Members can be defined in-plane and out-of-plane by holding one of 

the Back, Front, or Middle points.  

For example, the truss top chord out of plane alignment is set to top. Since U-shaped sections such as 

UPN profiles are generally used at the edges of floor openings, In-Plane Alignments are determined as 

Right or Left. The Out of Plane alignment can be adjusted using the object properties window or 

pressing CTRL+W from the keyboard. Similarly, In-Plane alignment can be adjusted using the CTRL+E 

shortcut keys. 

There is still a problem with the vertical position of the brace as it is too close to the top of the beams. 

Braces usually should connect to the middle of the beams. This practice ensures force transfer along 

member centers. In addition, fewer clashes will occur in the connection. 

 

A minor shift in the vertical alignment can 

be done by pressing Ctrl + W. However, if 

you try this, you will find that the offsets 

are too small. Further detail adjustment 

can be done by exposing the Profile 

properties.  
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In-plane and out-of-plane alignment and offset values shift both ends of the members in a parallel 

plane. In cases where the two ends will move differently, you can use the x, y, z “Start” and “End” 

offset values at the bottom of the window. These values work in the direction of the members’ local 

axes. You usually will not need to use these offset values. Necessary adjustments in these fields are 

made automatically by macros.  

While working in ProtaSteel, the In-Plane and Out-Plane will be enough for the position changes you 

will make on the members. 

 

Preserve constructive changes during model re-import 

There is a one-way data transfer from ProtaStructure to ProtaSteel. Adding and removing a new 

member to the project must be done in ProtaStructure. In this case,  the project must be saved and 

closed in ProtaSteel, and necessary changes must be made in ProtaStructure. 

If it is desired to keep the changes made before in ProtaSteel (e.g., member position & orientation), 

the “Preserve constructive changes during model re-import” option must be marked. 

In the General Definitions tab, the option “Preserve constructive changes during model re-import” is 

by default checked. 

 

  

During the next import, the import log file 

will show a warning : 

“Imported Frame's ID in *.cdf file[xxx]: 

Frame is locked. Therefore, in plane, out 

of plane and start/end offsets were not 

applied.” 

Ignore the above warning (log file) if you 

want the member offsets to be retained in 

ProtaSteel.  

If this option is unticked (disabled), offsets 

done in ProtaSteel will be discarded during 

the next re-import from ProtaStructure.  
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Steel Connections 

Once we have finalized the position of the steel members, we can start “connecting” the steel 

members, i.e., create connections. Connections can be created in two ways: 

1. Automatically using the connection macros from Macro Gallery or IntelliConnect 

2. Manually by using the Plates, Bolts, Welds & Cuts commands 

The automatic connection macros will automatically create the appropriate connection. If internal 

forces are transferred from ProtaStructure, they will be automatically considered in the connection 

design.  

Detail design check is performed for the following connections per Eurocode 3, AISC (LRFD), AISC 

(ASD), BS5950. 

• Beam to Beam Connections:  End Plate, Stiffened End Plate, Fin Plate 

• Beam to Column Connections:  End Plate, Stiffened End Plate, Fin Plate  

• Beam to Beam End Plate Connection 

• *Haunch Connection 

• *Direct Welding Connection 

• *Base Plate Connection 

• Simple Base Plate Connection 

• Flange Plate Moment Connection  

• Extended End Plate Connection 

• Bolted Gusset Plate Connection  



Page - 28 

 

• Corner Bolted Gusset Plate Connection  

• Welded Gusset Plate Connection  

• Corner Welded Gusset Plate Connection 

A detailed design report can be produced for the connections mentioned above, including geometric 

and capacity checks. In addition, intermediate calculations, references to the appropriate clauses of 

the design code, and corresponding equations are shown for easy checking.   

* Denotes : Check is provided, but will not automatically design the number of bolts and size of the 

plates. It will be provided with a default connection size and will require user to manually adjust the 

connection in the connection macro setting if the design has failed. 

For the above connections, the following basic material strength checks are performed: 

• Plate bearing check  

• Bolt shear & Bolt tension check  

• Weld stress check   

• Plate tension & plate bending check  

The checks above are the basic material checks, not clause-by-clause code-specific checks. No design 

report can be produced. You are advised to perform your additional calculation checks if required.   

The force used in the automatic connections are obtained from the higher of the two values : 

1. The critical design forces of the connected members imported from ProtaStructure 

2. User-defined Capacity Ratio in the Profile Properties > Detailing Definitions.  

Capacity Ratio = Design Force / Maximum Member Capacity (equal less than 1) 

This approach prevents unrealistic design when the design forces are very small or negligible.  

For example, in the determination of the number of the bolts for a simple beam to beam fin plate :  

• The critical design shear imported from ProtaStructure is 30 kN. This requires 1 number of 

bolts.  

• The Shear Capacity Ratio of the beam is set to 0.3. This works out to be 100 kN which requires 

two bolts. 

• The final design shear force used is 100kN; Two bolts are chosen.  

There is no check or design at all for the following connections: Haunch Connection, Apex Haunch 

Connection, Direct Welding Connection, Base Plate Without Design, Eaves Beam Connection, Profile 

Fit Connection, Sag Rod Connection & Sag Rod Holes, Welded Pipe Connection, Beam to Wall 

Connection, Apex Truss Gusset Connection & Truss End Plate With Gusset Plate Connection. 
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Before performing connection design, we should customize the default design parameter :  

• Go to File → Settings → Project Preferences  

• Ensure that Design Standards for Connections is set to EC3 

• General Overdesign Factor for Connections = 1  

The connections will generally design for 100% of the member capacity. This setting works in 

combination with capacity ratios of the connecting members (changed via Profile dialog → Detailing 

Definitions). The Capacity Ratio is automatically calculated = Design force divided by the actual 

capacity of the member. Hence, Capacity Ratio x Overdesign Factor = Final Factor.  

• For example, under Steel Detailing, ensure the following 

• Plates : Preferred Plate Material = S355 

• Bolts: Preferred Bolt Material = Class 8.8 

• General Weld: Preferred Weld Material = Class 42 

• Apply → OK  

Base Plate Connection 

To create a base plate connection to columns, we can use the base plate macros from Macro Gallery. 

There are four base plate macros in ProtaSteel for creating the base plate connection. This macro can 

design and create calculation reports.  

• Base Plate Connection (with design) 

• Simple Base Plate Connection (with design) 

• Hollow Section Base Plate (without design) 

• Shear Key  

 

In ProtaSteel, restraints are indicated with the ball and cubic objects in green. If the connection is 

defined as a moment connection in ProtaStructure, it is shown with a ball+cubic object. If the 

connection is designed as a pinned connection, it is illustrated with only a ball object.  

Using “Base Plate Macro”, all fixed and pinned connections are created. 
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Simple Base Plate Connection (Designed) 

The “Simple Base Plate Macro can create pinned connections”. This macro can design and create 

calculation reports. All parameters can be changed in macro properties.   

 

• Select the “Base Plate Connection Macro” 

• Select the column. 

• The connection is created under of column. 

 

 

• Select the “Simple Base Plate Connection 

Macro” 

• Select the column.   

• The connection is created under of column.  
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Fin Plate  

We will create a fin plate connection between the main and the secondary beam. 

• Right-left-click on the Fin Connection Macro under Beam to Beam Connections 

from Macro Gallery 

• The Fin Plate Macro dialog will appear, which allows you to customize the connections. 

• Go to the Design Tab and ensure the following :  

• Design Standard = EC3 

• Pick Get to make it default settings for this 

connection type for all projects from now on.  

• Zoom in where the two braces and one 

secondary beam connect to the main beam. 

 

• Double-click on the secondary beam  

• In Profile Properties, go to the Detailing 

Definitions tab.    

 

• The Capacity Ratio is 0.3 for this beam, by default. 

• This will be used to calculate the minimum design shear used for the 

connection.  

• The Analysis tab shows the geometric properties of the member.  

• Apply → OK  

 

  

The capacity ratio works in combination with General Overdesign factor for Connections (in 

Project Preference).  

Hence, Capacity Ratio x Overdesign Factor = Final Factor. 

Slip Coefficient is blank and hence will follow the 

Project Preferences → Bolts settings 
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• Select “Fin Plate Connection Macro” 

1 – Select main beam  

2 – Select secondary beam.  

• Right-click 3 times (to pass other parameters of the 

macro without entering values) 

• The Fin Plate Connection will be created automatically. 

 

Corner Bolted Gusset Plate Connection (Horizontal Brace) 

We will insert a corner bolted gusset plate for the L brace that uses the beam fin plate as 

the boundary.  

 

 

  

• The connection consists of plates, bolts & welds. Each members has its individual properties 

and can be selected, deleted, or changed. Double-clicking it will reveal the member properties.  

• The entire connection is represented by the macro sign . Double-clicking on it will bring out 

the Macro dialog box where the entire connection can be changed.  

• It is highly recommended you review settings of the connection macro before executing it.  

• Pick Corner Bolted Gusset Plate Connection 

under Bracing Connections from Macro 

Gallery  

1 – Pick the main beam 

2 – Pick the brace  

3 – Pick the blue fin plate  

The connection is created. Repeat the same for 

the other brace. 

 

2

1 

1

1 

1

1 

2

1 

3

1 

Macro Sign 
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Beam to Beam End Plate Connection  

We will create Beam Beam End Plate Connection between the primary and secondary 

beam. 

Zoom to the adjacent joint where the secondary & primary beam meet.  

 

Haunch Connection  

We will create a haunch connection between the column and beam.  

Let’s change macro default values before creating the connection. We can also change 

the properties after making the connection. 

 

• Pick Stiffened End Plate Connection under Beam to Beam 

Connections from Macro Gallery   

1 – Pick the main beam 

2 – Pick the secondary beam  

The connection is created. This maybe a more preferable in 

terms of load transfer & ease of assembly & construction.  

 

• Right click on the Haunch 

Connection  under Beam to 

Column Connections from 

Macro Gallery   

• Go to Figure 2 tab 

• Ensure that all the end plates 

A,B,C & D is checked 

• Apply → OK to exit 
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Stiffened End Plate Connection  

We will create a stiffened end plate connection at the column beam joint at grid C/3.    

 

 

 

 

  

We will now insert the haunch connection. 

• Pick Haunch Connection 

1 – Pick the column 

2 – Pick the beam 

• The connection is created. The blue 

transparent box is the cut object. This can be 

turn on/off in Visibility dialog. 

Repeat the same for the other end of beam to 

column joint 

 

• Double-click on Axis 3 view to open view 

• Zoom in the joint where the column, beam 

and 2 diagonal braces meet at grid C/3  

• Press F9 on this joint to set the point of 

interest 

• Rotate the view slightly about this joint 

• Pick Stiffened end plate connection from 

Macro Gallery     

1 – Pick the column 

2 – Pick the beam  

• Right-click → Connection is created 

 

 

1

1 

2 

2

1 
1 
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Corner Bolted Gusset Plate Connection (Vertical Brace)  

We will connect the diagonal brace at the same joint. There is a problem because the 

existing connection is getting in the way, i.e., we cannot connect the diagonal brace 

directly to the column due to the top stiffener plate. This can be solved by using the 

Corner Bolted Gusset Plate Connection. 

 

Bolted Gusset Plate Connection   

It is slightly different for the bottom brace as it should directly connect to the beam 

flange’s bottom.  

Hence, we should use the Bolted Gusset Plate Connection.  

 

For constructability, let’s push back & shorten 

the green gusset plate to terminate precisely at 

• Rotate the view around so the connection is not 

obstructed by the girt 

• Pick Corner Bolted Gusset Plate Connection 

under Bracing Connections from Macro Gallery  

1 – Pick the column  

2 – Pick the top brace  

3 – Pick top orange plate  

• A logical & constructible gusset plate 

connection will be created joining the top plate 

of the previous connection.  

 

• Rotate the view around the connection so 

you are viewing the bottom of the brace 

• Pick Bolted Gusset Plate Connection under 

Bracing Connections from Macro Gallery  

1 – Pick the beam 

2 – Pick the bottom brace  

• Right-click 

• A logical & constructible gusset plate 

connection will be created joining the 

bottom flange of the beam.  

• Press ESC to cancel the macro 

2 
1 

3 

1 

2 
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the beam end.  

• Select connection macro by selecting the macro sign  → Press Enter  

• Alternatively, select the gusset plate > press “M” > Press Enter (wait for the macro dialog) 

 

Enter 25mm in the above plate set-back value →  Apply 

The plate is shortened, and the stiffener plate is added.  

 

Splice Connection 

A splice connection must first be inserted in a column or beam in ProtaStructure. A splice 

connection has been inserted to all columns 1200mm above the 1st storey for this model.  

• This is more constructible because the 

gusset plate & stiffenner can be 

assembled off-site as part of the beam 

assembly.  

• The previous stiffened end plates will be 

part of the column assembly.  

• Hence, when the column & beam are 

brought to site, it’s easy & quick to install 

& “connect” them together.    
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• The green color bolts are called Workshop Bolt. These bolts are pre-installed in the workshop 

before being brought to the site.   

• The orange bolts represent the bolts to be assembled on site.   

The above setting and other bolt parameters can be viewed and changed in the Bolt Group property :  

• Double-click on any of the bolts →  Bolt Group property will appear 

• Go to Settings 2 tab →  Assembly Location →  two choices are in the dropdown menu  

• Workshop 

• Site 

 

• Zoom a column , slightly above Storey 1 

• Notice the column is broken into 2 separate elements 

as a column splice was created in ProtaStructure. 

• Pick Splice Connection under Splice Connections from 

Macro Gallery  

1 – Pick the top column 

2 – Pick the bottom column 

• The column splice connection is added.   

• Press ESC to cancel the macro 

• Repeat the same for the other columns 
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Apex Truss Gusset Connection  

We can connect the truss members at the ridge point with the Apex Truss Gusset 

Connection Macro. This macro adds a plate between the members, allowing the 

members to be welded to the plate. The basic principle when creating a macro is to 

select the primary members first. 

 

To increase the width of the gusset plate, let’s open the macro properties and change the plate 50 

mm right and left. 

• Double-click the macro icon to open the properties of the connection macro. 

• Alternatively, select the gusset plate and press the “M” key on the keyboard. Then press the Enter 

key to open the macro properties window. 

• In the field shown in the picture, enter the distance of the plate edge as 50 mm and press the Apply 

button. 

• To change the connection design depending on the macro, you can make the necessary changes in 

the properties window. 

• This macro can be created as both welded and bolted. 

 

Approach the truss ridge point. 

• Click on the “Apex Truss Gusset Connection 

Macro” 

• Select the top chord members (1 and 2) of truss.  

• Select the vertical members (3) connected to the 

ridge. 

• Right click on an empty place on the screen as 

there is no other members to connect. 

• Press the ESC key to exit the macro. 
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Truss End Plate With Gusset Plate 

Truss End Plate with Gusset Plate connection macro connects column and secondary 

trusses with gusset and endplates. This macro provides a bolted connection to the 

column flange with an endplate.  

 

 

Welded Pipe Connection  

Welded pipe connection macro can be used to connect tube profiles.  

Pick Truss End Plate with Gusset Plate under 

Truss Connections from Macro Gallery  

1 – Pick the main column 

2 – Pick the top chord 

3 – Pick the diagonal 

Right-click to end and create the connection 

4 – Pick the main column 

5 – Pick the bottom chord 

Right-click to end & create the connection 

The two connections are created as shown. 

• Click on Welded Pipe Profile macro under Truss 

Connections from Macro Gallery    

1 – Select the main top member   

2 + 3 – Select the secondary profile, e.g. diagonal 

and vertical element.  

• Right-click to end and create the connection 

Profiles are automatically cut and trimmed around the 

joint.  
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When the connection is created, cutting objects will form around the pipe profiles. Secondary profiles 

should be selected according to cutting priority. 

The diagonal and verticals are cut around the primary pipe profile. 

Beam to RC Wall/Column Connection  

This connection macro creates and designs an embedded steel connection between a 

steel beam and a concrete wall or column. The steel member must be perpendicular to 

the reinforced concrete surface. It is essential to have enough space on the concrete 

surface; else, the macro will not work. 

 

Stiffener  

In ProtaSteel, macros automatically add required stiffeners. If it is desired to add the 

stiffener to any of the members independently of the macros, or if it is needed while 

creating a manual connection, the stiffener macro can be used. This macro creates stiffeners at the 

specified point on the specified profile. 

There must be a catchable point in the region where stiffener will be created. If there is no point on 

the object, we can create a catchable point with point objects or construction line object 

 

• Click on Beam to Wall Connection under 

Beam to Column Connection from Macro 

Gallery    

1 – Select the concrete wall or column   

2 – Select the steel beam 

• Right-click to end and create the connection 
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We can also use the “dx..”, “dy..”, “dz..” 

command to distance.  

To create a stiffener at any point on the 

profile, press the CTRL key and left-click on 

any snapped point on the profile. 

 

  

Stiffeners can be placed on both sides of the 

profile or one side. You can change these 

options on the macro properties.  

 The out-of-plane movement of the 

stiffeners can be changed with the front-

middle-back commands. CTRL+W key 

combination can use to change the out-of-

the-plane direction. You can select all 

members of the macro connection with the 

CTRL+M key combination. 

  

• Click on Stiffener under Detailing from Macro 

Gallery    

1 – Select a profile which want to add a 

stiffener   

2 – Go to a point on the profile.   

3 – Press ENTER and write “dz-100”  

4 – Press ENTER  

• The stiffener is created as shown below. 

 

 

 

  

 

 

• Click on Stiffener under Detailing from Macro 

Gallery    

1 – Select a member which want to add a 

stiffener   

2 – Select the point on the member 
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Insert Sag Rods  

In ProtaStructure, the main steel members are modeled and designed, usually omitting 

the minor or non-structural members to keep the model size manageable and efficient. 

After the model is transferred to ProtaSteel, you might want to add ancillary steel 

members such as sag rods.  

We will insert some sag rods between the girts along axis 3 : 

• Double-click on 3D view in the Explorer pane to go to the default 3D view 

• Right-click on Create Sag Rod icon under Purlin and Girt Connection from Macro Gallery → This 

will expose the Sag Rod Macro Dialog.  

• Key-in the offsets 50 mm and Number of Intervals = 3 (as shown below) 

• Untick the diagonal so that it will not be included 

• Choose the section profile by clicking on “…” (as shown above) → Pick Round Bar D10 → Select 

• Pick Get to make these input the default from now on → OK 
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Each sag rod has its individual properties and can be selected, deleted, or changed.  

Double-clicking it will reveal its properties.  

All the sag rods are represented by the macro sign  They can be changed in a group by selecting this 

macro sign → press “Enter” as stated previously.  

You can use Sag Rod Connection or Sag Rod Holes macros to connect to sag rods and girts/purlins. 

Sag Rod Holes 

In ProtaSteel, “Sagrod Hole Macro” is used to drill holes on the members to connect the 

sag rod. This macro is located in the “Purlin and Girt Connections” menu in the macro 

library. 

Macro default settings can change before adding the macros. Left-click on the “Sag Rod Hole” icon to 

change the macro presets.  

• Left-click on the Sag Rod icon  

• Notice the cursor turn to a hand icon  

meaning that it is waiting for required 

element selection action(s).  

1 – Left-click on bottommost girt 

2 – Left-click on topmost girt 

• Right-click → Sag Rods will be inserted  

Insert sag rods for another panel between 

grid B, C & D using the same steps above, 

i.e. start by picking the bottommost girt 

(no need to pick the sag rod icon again) 

Once complete, press ESC to cancel the 

Sag Rod macro action.  

Notice the cursor changes back to default 

arrow .   

 

 

1 – Left-click on the “Sag Rod Hole” icon  

2 – Select purlin or girt member  

Holes will be opened on the member at the points where the 

sagrod connected.  
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Select the hole and hit M+ENTER keys on the keyboard to open macro properties. Macro default 

settings are set to “by working points”. This setting represents the points where the sag-rod 

connected.  

 

Sag rod holes can be created on members other than purlins and girts. In the macro library, right-

clicking on the sag rod hole macro opens the macro properties window to create sag rod holes in 

different members. “According to the existing sag rods” option is enabled, and the profile type is 

selected. 

For example, let’s select “beam.” 

• On the hole orientation layout, select the hole diameter is 14mm, the hole tolerance is 2mm (total 

hole diameter 16 mm is drawn). 

• Set the hole’s distance to the profile center line as 50 mm and the horizontal distance between the 

holes as 200 mm. 

• Then check the “Get” option. Thus, we have changed the default settings of the macro. 
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To create more than one hole group, the operation can be done by entering the distance or the 

number of groups. 

For example, 

• After the hole settings are made for a group on a beam, select the “by segmenting” option. 

• Write “10” in “#of the segment”.  

Thus, ten holes are drilled at equal intervals. 

 

Sag Rod Connection  

In ProtaSteel, “sag rod connection macro” can also be used to drill holes for the 

connections of the sag rods connected to purlins and girts. 

This macro can be used for the connections of the sag rod members connected 

vertically and diagonal to purlins and girts.  

Different connection types can be applied by changing the macro properties. 

Different types of connections are shown below. 
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IntelliConnect For Fully Automated Steel Connection Design  

IntelliConnect automatically assesses joints to your preferences and creates and designs steel 

connections in batches. It covers a wide range of simple, moment, splice, and weld connections. It 

considers constructability by intelligently arranging and configuring all the components of the 

connections without user intervention. This results in a vast improvement in productivity as it 

minimizes the time required to create & correct these connections manually.  

 

Why use IntelliConnect?  

Steel detailing software typically creates connections automatically between two elements by applying 

specific rules, i.e., “Rule-based joints”. These rules usually include names of the profiles, moment 

releases or lack thereof, the loads in the elements, and approach conditions (whether the secondary is 

approaching the main from the flange or the web). 

                          

                        Figure 1            Figure 2 

While “Rule-based joints” are beneficial in simple cases where the main and the secondary (incoming 

profile) are the only two profiles present at a joint (see Figure 1 above), they fail to deliver for complex 

joints when more than two elements meet at the same joint (see Figure 2) :   
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• Applying a blind “Rule-based joint” would create many clashes for complex joints, resulting in 

wasted & unproductive time in manual amendments.  

 

• “Rule-based joints” will not have the intelligence to “auto-shift” the secondary member slightly to 

facilitate a connection. Such requirements are commonplace in steel detailing when incoming 

members need to be shifted slightly to avoid clashes and make erection possible.  

 

• A typical example (see Figure 3) would be the need to shift the horizontal bracing in flooring 

systems away from the beam-beam intersection points to avoid clashes with the connection plate. 

 

• “Rule-based Joints” typically do not combine incoming elements to create a single shared 

connection if the situation demands it.  

 

For example (see Figure 4), two horizontal braces will connect to the same point separately, creating a 

clash between the gusset plates rather than using a single shared gusset plate.  

 

IntelliConnect is an advanced technology that attempts to address issues common in building 

detailing. IntelliConnect automatically determines which connection type is more appropriate for the 

selected profiles by checking their type, location, and orientation. If necessary, it automatically alters 

connection parameters and creates a more feasible & practical connection. 

IntelliConnect Scope 

IntelliConnect can automatically create connections for various types of elements and profiles. 

IntelliConnect can provide a solution for 36 different cases grouped in 9 categories. These categories 

can be listed as follows:  

• Splice connections 

• Batten plate connections 

• Sag rod connections 

• Vertical bracing connections 

Figure 4 
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• Truss connections 

• Purlin and girt connections 

• Floor beam connections (with horizontal bracing 

connections if there are any) 

• Beam-Column connections (with horizontal and 

vertical bracings if there are any) 

• Base plate connections (with vertical bracings if 

there are any) 

These include “simple cases,” e.g., where there are only two primary elements, and “complex cases” 

where more elements meet at the same node.  

 

Cases Covered 

The following “Simple Cases” are covered by IntelliConnect :  

1. Splice connection (Supports whatever profiles are supported by the Splice macro) 

2. Column Base Plate with no incoming vertical bracing. (The column needs to be an I section) 

3. A single beam framing into a main beam. The Beams can be I or channel profiles. The type of 

beam to beam connection can be the following 1) The Stiffened end plate connection. 2) The 

Fin plate connection 3) The beam to beam end plate connection. 

4. A single beam framing into a column. The profiles may be I or channel profiles. The type of 

beam to beam connection can be the following 1) The Stiffened end plate connection. 2) The 

Fin plate connection 3) The beam to beam end plate connection. 

5. A single horizontal brace framing into a beam. The horizontal brace may be any profile 

supported by the Bolted gusset or welded gusset macros) 

6. A single vertical brace framing into a column. The vertical brace may be any profile supported 

by the bolted or welded gusset macros.  

7. A single purlin sitting on a beam or truss element. The type of connection may be any 

connection supported by the Purlin/Girt macro 

8. A single girt framing into a column. The type of connection may be any connection supported 

by the Purlin/Girt macro 

9. Creation of batten plates on twin profiles. 

10. Connection of a single purlin passing continuously over a truss top chord or roof beam. 
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IntelliConnect covers the following complex cases:  

1. Two horizontal braces framing into a beam (from any side – web or flange) 

2. Two vertical braces framing into a column (from any side – web or flange) 

3. Truss connecting with more than one truss secondary framing into the truss top or bottom 

chord.  

4. Two purlins sitting on a truss top chord or a roof beam 

5. Two girts framing into a column (either colinear or one from each orthogonal direction ) 

6. Two floor beams framing into a main beam from opposite sides 

7. Combinations of floor beams and horizontal braces framing into each other at the same point 

from both sides  

8. Up to 4 beams framing into a column (two from the flange side and two from the web side) 

9. Combination of beams and vertical braces framing into a column 

As far as limitations on profile types and connection types are concerned, the same restrictions apply 

in simple cases.  

 

How to use 

The following is the summary of how to use Intelliconnect :  

• The user will first select single or multiple nodes that hold all elements that meet at a single 

point. 

• After that, the user right-clicks and goes into the IntelliConnect context-sensitive menu and 

selects the type of connections to create.  

• For some IntelliConnect connections, however, the user needs to select frames and not nodes 

(e.g., simple cases 9 and 10 stated previously) 

• IntelliConnect will use its “internal classifying algorithm” to connect as many of the nodes 

selected by the user as possible.  

• However, if it encounters an unsupported case, it will either partially connect the node or 

leave it completely unconnected.   

• A detailed report will automatically be displayed listing nodes that are successfully connected 

or failed to connect.  

• IntelliConnect Node Control tool is an interactive navigator to browse & examine points that 

are partially connected or not connected; so the user can connect/correct them manually.  



Page - 52 

 

Truss Example 

• Select the nodes (joints) of the steel structure where you wish to create a connection 

o Joints are shown as blue dots at the end of the member. You can click and drag a box 

to select all members and the nodes for simplicity.  

o We will create the truss connections based on the Quick Start Guide Steel model for 

illustration purposes.  

• Go to the 3D view 

• Select all the truss members by dragging a box around them  

 

 

• Right-click → IntelliConnect → Pick Create Truss Connections 

• Type in the preferred Gusset Plate Thickness in the Truss Wizard or leave it blank if you want 

IntelliConnect to select thickness for you. 
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Purlin Example 

• Select the nodes (joints) of the steel structure where you wish to create a connection 

o Joints are shown as blue dots at the end of the member. You can click and drag a box 

to select all members and select the nodes for simplicity.  

o We will create the purlin connections based on the Quick Start Guide Steel model for 

illustration purposes.  

• Go to the 3D view 

• Select all the truss members and purlins by dragging a box around them  

 
 

• Right-click → IntelliConnect → Pick Create Purlin Connection 

  

• In the Purlin Wizard, choose the preferred type of connection 

• For this example, select “Angle Type” & “Reversed Cleat.”  

• Input further parameters in the following wizard dialog  →  Run 

• Max Angle Leg Length or profile can be specified         
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• AutoConnectLog text file will open → Review its contents as it lists all the connections that are 

successfully / unsuccessfully created 

  
 

Beam-Column–Brace Example 

We will auto-create a beam-column–brace connection for illustration purposes based on the Quick 

Start Guide Steel model. 

• Go to Storey 1 view →  Select all the column and beam joints along axis 2 

 

 
 

 

• Right-click → IntelliConnect → Pick Create Column/Beam Connection 

If there is more than one possible connection configuration, the following dialog allows you to choose 

which connection type to consider and its priority. 
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• Pick the connection types to consider →  Adjust the priority using up/down arrow → Next  

The relevant bracing shifting, bracing connection & haunch connecting settings will appear 

next 

• Make desired adjustment  → Run → Then connections will be created 

 

  
 

Beam – Beam – Brace Example 

We will auto-create a beam-beam-brace connection based on the Quick Start Guide Steel model for 

illustration purposes. 

• Go to Storey 1 view →  Select all the beam and beam joints along axis 2 
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• Right-click → IntelliConnect → Pick Create Floor Beam Connection 

When there is more than one possible connection configuration, the following dialog allows you to 

choose which connection type to consider and its priority. 

 

• Pick the connection types to consider →  Adjust the priority using up/down arrow → Next  

The relevant bracing shifting, bracing connection settings will appear next 

• Make desired adjustment  → Run → Then connections will be created 
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IntelliConnect and Connection Ordering  

Although detailing order often depends on the structure itself, it is usually better to start from large 

connections to small ones. The connection order depends on the size and shape of the structure. For 

example, for the high-rise buildings, beginning the connection process from the bottom is more 

practical. Most structures will have similar, symmetrical, or identical axes. Whether you use 

IntelliConnect, finishing the frame connections first is a good practice. 

In a typical warehouse structure with a truss, the recommended connection order is given below :  

• Splice connections (Columns, Beams and Truss members) 

• Truss connections  

• Apex connections  

• Truss top and bottom chord connections to columns  

• Base plate connections  

• Manual (User-defined) connections (User-defined connections can be saved for later use and 

repeatedly used for similar joints) 

• Connections of the compression members located between the column or truss system. 

• Vertical and roof bracing connections 

• Purlin or girt connections 

• Sag Rod Connections 

• Batten Plate Connections 

  

Floor Beam Connections (IntelliConnect) works when  

beam to beam connection is hinged in ProtaStructure.  

Change to “Line Mode”, Green Dot defined hinged connection. 
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For building type multi-story structures, the recommended order to use IntelliConnect is given below; 

• Splice Connections 

• beam-to-column connections (Moment connections first) 

• Beam-to-Beam connections 

• Horizontal bracing connections 

• Base Plate Connections 

• Vertical bracing connections 

• Purlin, sag rods, and batten plate connections 

When working with IntelliConnect, it may be necessary to change the order for two reasons: 

• The IntelliConnect operates on a joint. All connections on this joint are simultaneously taken 

into account. For instance, in the case of column-beam connection (beams connecting to both 

sides of the column) with vertical bracing, IntelliConnect will create all connections 

simultaneously to prevent clashing by using shared parts. That will change the detailing order. 

• Since IntelliConnect operates on a joint, it is unclear whether the other joints are too close or 

too far away. If the members or joints are close enough to collide with each other, 

IntelliConnect may face conflict problems. In this case, the Clash Check command can detect 

collisions. IntelliConnect can run with the user’s requested order so that it does not use the 

connection information of other joints  

In summary, connection design should be initiated from the primary connections. IntelliConnect can 

be triggered on a grid or storey basis. The girt, purlin, and sag rod connections can follow. Batten plate 

connections should be created finally.  

Manual Connection (Info Only) 

In ProtaSteel, users can create connections manually and save them in the macro library to reuse 

them at similar nodes. A steel beam to RC column manual connection will be demonstrated below. 

Steel Beam to RC Column Manual Connection  

Steel beam to reinforced concrete column connection can be done using manual embedded steel 

plate connection in ProtaSteel. 

The following example illustrates the steps of creating an embedded steel plate connection. 

1. Firstly, we can cut off excessive steel beam using the Object Cut command (in Edit tab) 

I. First, select Member to Cut. 

II. Second, select the Cutting Member.  

III. Select “No” from the pop-out warning to remain the Cutting Member.  
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Remember to turn off the “Cut” in Visibility Filter when necessary. 

2. Create the section view plane with the command By Two Points  by accessed from 

the View tab → View By 2 Points 

 

• Pick a point between the end of the steel beam and the surface of the concrete. 

• Double click on the background to open the View Properties → save View Name: Cut 

Section A or any preferred name. (Refer to chapter 7 – Creating new Views) 

 

 

3. In the Cut Section A View, navigate to the Views tab → select To View Plane. This sets an active 

work plane based on the current view. 
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4. Select the plate command (in the Steel tab) and select the four corners of the steel beam 

clockwise → A plate will be created. Then right-click on the beam and select Hide Selected. 

 

 

5. Use ALT to select each corner and Right-click > Move Special → Linear to move each corner 

accordingly. 

 

• Left Top Corner –  X: -30,  Y:  50 

• Right Top Corner –  X:  30,  Y:  50 

• Right Bottom Corner –  X:  30,  Y: -50 

• Left Bottom Corner –  X: -30,  Y: -50 

Directions x, y, z must always check based on the workplane (axis direction icon ) shown in the 

modeling view. The axis can be based on colour: Red = x, Green = y, Blue = z. 

Then, right-click in the background to Show All.  

 

6. Right-click on the plate, set: 

 

• Position In Depth: “Behind” 

(Alternatively, can be adjusted via hotkey CTRL+W in modeling view) 

• Thickness (t): 10 
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7. Go to 3D views, remove the overlapping concrete using the Object Cut command. 

• First, select the concrete member. 

• Second, select the steel plate.  

• Select “No” from the pop-out warning to remain the Cutting Member.  

 

8. Go to the Section Elevation View and go to Edit tab → Point → hold Shift key + left click on 

“Dividing Points”  command to set to “4” in Number of Points? and press OK. 

 Left-click on the command to start creating reference points. 

• Step 1 - start at the left top corner of the steel plate and end at the left bottom corner of 

the plate. 

• Step 2 - start at the first point created from the top corner of the plate, drag horizontally 

and end at the right side of the steel plate. 

• Step 3 - Repeat step 2 but start at the Fourth node, created at step 1 instead. 

• Delete all points created in Step 1. Delete 2nd and 3rd nodes created in Step 1 and  Step 2 
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9. After finished creating the reference points, we can now create steel studs. Hold Shift + Left 

click on joist (in Steel tab) to access the Default Joist Setting and set:  

• Profile name:  D10 

• Out of plane: Middle 

 

 

10. Left-click on the reference point at the left top corner to start creating the rebar → press Enter 

→ key in “dz-100” and press Enter again. 

 

Then, go to the 3D view with wireframe view mode, move the stud by -10 on axis Z to avoid 

overlapping with the steel plate  

 

(Always remember to check your current workplane before using the linear move command). 

 

11. Go back to Section Elevation View, hold Shift + left, click on joist to access the Default Joist 

Setting, and set Profile name: D20. Then, left-click on the reference point at the left top corner 

to start creating the rebar → press Enter → key in “dz-5” and press Enter again. 
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12. Go to 3D view with wireframe view mode, select and right-click the created circle to move it to 

the end of the stud. 

 

 

 

13. Hold Shift + left click on Weld command (in Steel tab) to access the Default Weld Settings and 

set:  

 

• Weld Type: All-Around,  

• Size: 1  

Click OK after setting. Start creating weld by Left-clicking on the command: 

 

• Create Weld between Steel Plate and the stud: 

i. Click on the weld path that should be welded. 

ii. Click on the steel plate (which is the larger object) 

• Repeat the same steps to create a weld between the stud and the stud end. 
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14. Once the welding is finished, copy the stud, including the welding, and paste the rest of the 

reference points.  

 

15. Repeat the welding steps for the beam to the steel plate. 

You may right-click the RC column → Hide Selected if necessary.  

Right-click on the background → Show All to reveal all the hidden item(s).  

 

 

 

Steel Beam to Steel Column Manual Connection  

A steel beam to steel column connection can be done using a manual steel plate connection in 

ProtaSteel. The steps are somewhat similar to Steel Beam to Reinforced Column Manual Connection. 

1. Using the Boundary Cut command, we can cut off excessive steel beams (in the Edit tab). 

(Object Cut command is unsuitable because the cutting member can only cut the overlapping 

volume.)  
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I. First, select Member to Cut. 

II. Second, select the Cutting Member.  

III. Select “No” from the pop-out warning to remain the 

Cutting Member.  

 

2. Repeat steps 2 to 5 in Steel Beam to Reinforced Column Manual 

Connection. 

3. Hold Shift +left click on the plate, set: 

I. Position In Depth: “Front” 

(Alternatively, it can be adjusted via hotkey CTRL+W in 

modeling view) 

II. Thickness (t): 10 

4. Use the Object Cut command to cut the beam and the plate—select beam → Select the plate 

→ select “No” in the warning. 

 

5. Now, we can create bolt using Bolt command (in Steel tab), hold Shift + left click to preset the 

default setting: 

I. In Settings 1 tab → Diameter: 12 

II. In Positions → Grid:  

➢ X Positions = 30 60 

➢ Y Positions = -30 -140 

 

Click OK once finished.  
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6. Left-click to use the Bolt command. 

I. Select plate and column. Then, right-click once to enter the next stage. 

II. Select the top left corner of the steel plate and then select the top right corner of the 

steel plate. 

 

 

7. Lastly, weld the beam and the plate using the Weld command. 

 

 

  



Page - 67 

 

Connection Design Reports 

ProtaSteel can create design check reports for the following connections in accordance to EuroCode3, 

AISC (LRFD), AISC (ASD), BS5950:  

• Beam to Beam Connections:  End Plate, Stiffened End Plate, Fin Plate  

• Beam to Column Connections:  End Plate, Stiffened End Plate, Fin Plate  

• Beam to Beam End Plate Connection 

• Haunch Connection 

• Direct Welding Connection 

• Simple Base Plate Connection 

• Flange Plate Moment Connection  

• Extended End Plate Connection 

• Bolted Gusset Plate Connection  

• Corner Bolted Gusset Plate Connection  

• Welded Gusset Plate Connection  

• Corner Welded Gusset Plate Connection  

• Apex Haunch Connection  

• Splice Connection  

• Base Plate Connection 

 

ProtaSteel can’t create any calculation check for the below connection types. 

• Eaves Beam Connection 

• Fitting Connection  

• Sag Rod Connection  

• Purlin and Girt Connection  

• Welded Pipe Connection 

• Apex Truss Gusset Connection  

• Truss End Plate with Gusset Plate  
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• Batten Plate Connection 

• Stiffened Web Opening 

• Multiple Stiffened Web Opening  

• Beam to Wall Connection  

• Embedded Plate Connection  

• Manual Connections 

Reports include both geometric checks and capacity checks. In addition, intermediate calculations, 

references to the appropriate clauses of the design code, and corresponding equations are displayed 

for easy checking.   

 

The reports can be created on-demand in rich text format (RTF). Design Status colors can be seen on 

model view before report creation. To show the utilization ratio of the connection visually:  

• Go to view (tab) → Color Coding → Connection Design Ratio Coloring 

The connection will color coded :  Yellow = Not checked/designed; Green = Pass; Red = Fail. 

 

  

To check the connection & generate the report :  

• Select the connection by any of these methods : 

• Select the connection macro sign   

• Select any component of the connection (eg. a plate 

or a bot) → then press “M” 

• Left click and drag a window enclosing the entire 

connection 

• Hold down CTRL to multiple select 

 

 

 



Page - 69 

 

• Right-Click → Connection Design Reports (or Go to Drawings & Report (tab) → Create) → Select 

the desired report :  

• Show Connection Report → Show connection report of selected macro(s)  

• Default Connection Report → Create connection report according to project preference 

• EC3 / BS5950 / AISC_LFRD /AISC_ASD Connection Report → Create connection report for the 

selected code 

 

Connection Design Summary Table 

The connection design summary table presents details about selected connection macros. The 

summary table shows the “Frame Id”, profile types of macro dependents, connection type, the 

capacity ratio of connection, design status according to capacity ratio, and whether a design report is 

created. 

• Select one or more connection macro 

• If no macro is selected, the table will show all supported macros in the model  

• Go to Drawings & Reports (tab)  → Design Summary 
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The top icons from left to right :  

 

• Update →  Refreshes the table 

• Show in Model →  Locate & zoom in the selected macro in the model view.  Double-

clicking on any row will also perform the same function.  

• Create Report → Create the connection design report of the selected macro.  Hold down 

CTRL key to multiple select.  

• Open Report → Open the selected design report 

If the connection fails, change the macro properties. If the connection parameters are sufficient, the 

design status color will be green. 

 

Collision / Clash Checks 

Before creating general arrangement drawings, a clash check must be performed for all elements. The 

clash check will highlight the  elements that are clashing or overlapping :  

• Select all or some elements of the model 

• Go to Tools (tab) → Clash Check 

• Alternatively, right-click on the model screen and pick Clash Check  

As a result, the clashing elements will be left selected (in red). Generally, a collision occurs when two 

or more elements overlap each other. It usually occurs when connections are not made yet. For 

example, before the haunch connection was made, the beam end flange & web plate overlapped into 

the column (as shown below). 

  

If a Clash Check is performed by selecting both the elements, they will remain selected after the 

check.  
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Audit Model  

Before creating the detail drawings, it is crucial to determine errors and inconsistencies in the model. 

This function will perform several model tests, such as duplicate points :  

• Go to Tools (tab) → Audit Model 

• Select the checks desired →  Run Test 

 

You can select the object(s) specified in the result report and automatically navigate it in the model.  

 

Detailing Item Manager     

The Detailing Item Manager creates and manages detail items such as the connections. 

We can use this function to create exploded drawings of the connection with different 

views and detail information such as dimensions, location of bolts, welds, etc.  

   

  

• Zoom into the connection that we have created 

at Grid C 

• Click & drag a window to select all components of 

the connections, including all the plate, bolts & 

welds  

• Pick Detailing Item Manager in Steel (tab) 

The Detail Item Manager dialog will appear.  
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This box controls the various directional views we want to show in the drawings. The view is shown in 

3 colors, red, blue, and green. Each color has a front & back view. Hence there is a total of 6 possible 

views. The view names can be changed – so if the top of the connection is not the actual top, change 

the name manually.   

• For this connection, pick Front & Right only  

• Pick Filter Box to show only the connection elements (Restore Filter will restore all elements) 

• Click on the “+” icon to add a 3D view of the connection (if desired) 

• Close to save & exit the dialog 

• Repeat the same steps for the Splice Connection at the corner column at GL D/3 

For practice purposes, we can similarly insert a connection box on the connections we have previously 

created in Story 1. The summary of steps are : 

In the Detail Item Manager :  

• Type the name “Con1” at the bottom  

• Pick  Add →  Con 1 will be added  

• Pick Select Objects 

• Select the beam, the column & the 2 

braces  

• Right-click  

The moment we do so, a “3D detail box” 

appears around the connection in the 3D 

view (as shown below) 
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• Open the view that is most suitable to insert the connection, try Storey 1 view 

• Zoom into connection 

• Click & drag a window to select all components of the connections, including all the plates & 

bolts 

• Pick Detail Item Manager in Steel (tab) 

• Add the connection name 

• Click Select Objects & pick all the members of the connection 

• Tick the desired view direction box 

• Close the dialog 

We have completed the connections and are now ready to generate the drawings.  

Preparing Engineering Drawings 

ProtaSteel has a powerful tool to prepare engineering drawings – it’s simply called the “Drawing 

module”. The drawings are based on the views prepared in the modeling module. The steps are 

summarized as below : 

• Create the desired Views in the main modeling view.  

• Ensure the orientation of the view you want to use in the drawing is correct, as the drawing 

module will automatically use the latest views.  

• Double-click on Axis 3 view → Press F4 to reset the view to default 

• Double-click on Storey 1 view → Press F4 to reset the view to default 

• Create any detail views such as connection details using Detailing Item Manager 

• Start the Drawing module by double-clicking Drawings in the Explorer pane (Ctrl + D) 

Drawing Module 

In the Drawing Module, the same views that were shown in the primary model will be duplicated 

under the Explorer → Modelling Views  

• 3D view – 3D view of the model 

• Storey F – foundation plan view (ST00 in ProtaStructure) 

• Storey 1 – Storey 1 plan view as defined in ProtaStructure 

• Storey 2 – Storey 2 plan view as defined in ProtaStructure 
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• Axis 3 – New view along Axis 3  

• Axis A – New view along Axis A 

If you do not have the same views, please close the drawing module to return to the main model & 

create the view as outlined in previous sections.  

Creating Drawings via Drawing Manager 

• Double-click on Drawing Manager (or F6)  

The Drawing Manager is where you can start a new drawing.   

The View Manager allows you to manage the drawings:  

• Create a new drawing using Create Drawing →  Create Drawing Dialog will appear. 

• Name the drawing Storey 1, Set Paper Size to A1 → click OK. 

 

• Select Storey 1 → Open Drawing   

 

• Alternatively, simply double-click on Storey 1 to open it. 

• Right-click on Storey 1 located at the explorer panel→ Create Viewport  
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• Close the Drawing Manager and review the drawing. 

 

The outermost brown line is the Drawing Border (A0 size). The size & other settings of the drawing can 

be changed by :  

• Double-click on any space within the drawing border to access the Drawing Properties 

 

The inner dotted blue line is the Viewport border which is directly linked to the view : 

• Place the mouse cursor at the lower-right corner →the cursor will change to resize  

• Click & drag to resize & ensure all the elements are visible 

• Place the mouse cursor at the boundary line → click & drag to move the position of the region 

• Double-click any place within the viewport to access the Viewport Properties 

• The region has been renamed viewport in the current release 

Documents Properties will appear where the 

following can be changed: 

• Drawing Name 

• Print Area & Margin 

• Paper Size & Orientation 

• Created, Approve by, Approved Date 

• Document State : Normal / Freeze / Broken 

 

Drawing Border 

Viewport Border 
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• Go to Label Settings tab 

• The Label Settings dialog allow you to change :  

• Label Position 

• Offsets  

• Name & Scale Text Settings 

• Pick Locate Outside so the label will be place outside 

the region border 

• Tick Write next to Name & Scale Text Settings 

• Pick Change under Name Text Settings 

• Change Name Text Height to 10mm → OK 

• Change Scale Text Height to 10mm → OK → Apply 

Notice that the name and scale appears larger in the 

drawing. 

 

 

 

 

Viewport Proper Editor dialog will appear. In the General 

tab, the following can be changed : 

• Name of the region 

• Scale  

• MovX, Mov Y: Coordinates of view 

• Rotation: States the rotation angle 

• DrawingbMode: Line/All Visible/Hidden Line/Full 

Dashed 

• Change the Name to Storey 1 Plan  

• Change Scale to 25  

• Change Draw Mode to Hidden Line → Apply 

The drawing will be updated to scale & hidden line. 

• Pick Fit to autofit all the elements & the new title  
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Filter Options enable advance filtering :  

• General : Steel, Concrete, Unique ID, etc 

• Object types : Grid, Profile, Joint, Weld, etc 

• Profile : Columns, Beams, Brace, etc 

• Plate : Plate IDs, Types & Usage 

• Solid & Macro  

• Go to Profile tab 

• Tick Column, Beam, H. Brace 

• Pick OK to exit 

This ensures that only column, beam, and 
horizontal elements are shown.  

 

 

• Go to Filtering tab 

• The options here controls what is shown in the 
drawing : 

▪ Up (+) & Down (-) filters objects in & out of the 
paper 

▪ Min X & Max X filters objects in the X  plan 
direction 

▪ Min Y & Max Y filters objects in the Y plan 
direction 

• Up-Down Method : 

▪ Partial : Any element that exists partially within 
the above extents will be shown 

▪ Full : Only elements that exist fully within the 
above extents will be shown 

• Filtering Settings – expose more filter options 

• Change Up(+) to +500 & Down (-) to -500   → Apply 
→ Girts disappears as they are placed slightly above 
the floor level 

• Pick Filter Settings  
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Visibility and Selectability in Drawing Module 

Visibility settings allow the user to show and hide elements that wish to hide/show in the drawings. In 

contrast, Selectability settings allow the user to lock the elements and prevent them from misclick or 

accidentally deleting them.    

You may easily access it by View → Visibility Settings / Selectability Settings. 

 

 

By default, all elements will be ticked. If the selected element is unticked and press “OK”, the effect 

will immediately apply to the selected element in the drawing. 

 

Grid Level Visibility 

Now, we will insert the 3D view into the drawing.  

• Right-click on 3D View → Create Viewport  

 

 

In the 3D view, the grids appear in each storey.  
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To show the grids at the storey 0 only,  

• Double click on the grids → Grid Properties Editor will appear. 

• Untick 1. Level and 2. Level under Grid Level Visibility → Click OK.  

 
 

• The 3D view will now look clean. 
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Profile Annotation 

We now add steel profile annotation, i.e., show the member sizes. Firstly, we should select the 

members we want to annotate. To select the members easily, we can control what elements are 

selectable: 

• Click on the Selectability icon  at the top menu (or View → Selectability Settings) to access 

the Drawing Options dialog 

 

• In the drawing, left-click & drag a box around all the steel members to select them  

• Right-click on the Profile Annotation icon to access the Annotation Settings     

 

 

 

 

The annotations are added next to steel members, 

as shown below.  

The settings here control how steel 

members are annotated (labeled) :  

• The various type of annotations is 

listed in the table 

• Click & drag any annotation name into 

the box which also defines the position 

of the annotation  

• Click and drag Profiles, Material & 

ProtaStructure Label in the box 

• Click Annotation Settings to view or 

change the text settings :  

▪ Font type & size  

▪ Format or style of the annotations  

• Change the Text Height to 7 mm 

• Click Apply & Create Annotations  

 

• Untick Viewport → OK   

This prevents you from selecting the region border. 

The same options are available in Visibility tab which controls 

what is shown in the drawing.    
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• Alternatively, click OK to exit the Frame Annotation dialog → Select elements → Left click on the 

Profile Annotation icon  

• ProtaStructure Label is ProtaStructure member labels such as 1B1, 1C1  

• The annotation position can be moved by left click & drag 

• Annotations can be deleted using the Delete key 

• Annotation text size, font height, etc. can be changed by selecting them → ENTER → Annotation 

Text Property Editor 

Dimension  

Dimension tools   can be used to insert dimensions in the drawing.  

 

 

 

 

Notice the dimension is shown dynamically. 

• Zoom in the top around primary beam 

along axis D 

• Click Horizontal Dimension  

• Left-click on the 1st point & then the 2nd 

point between the points to be 

dimensioned.   

• Move the mouse cursor away to the right 

 

1 2 
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• Left-click on the 3rd point & then the 4th point 

• Move the mouse cursor to the exact position where you want the text to be placed  

• Right-click to confirm & create the dimensions 

The dimensions will be created as shown below.  

 

Creating Connection Detail   

Let us now create a new connection drawing for the connection we created along Grid 3.   

• Double-click on Drawings Manager (or F6)  

• Pick Create Drawing →  Create Drawing Dialog will appear 

  

• Name it “Connection Axis 3.” 

• Change the Paper Size to A1 →  Orientation = Landscape  

• Pick Drawing Type = Steel Connection Detail  

• Pick OK → The drawing will be created & automatically opened 

• Close the Drawing Manager dialog (Pick OK if prompted to save) 

The drawing “Connection Axis 3” will be opened and brought to focus. The drawing is empty & we will 

insert the required view into the drawing.  

• Right-click on Axis 3 View → Create Viewport  

3 4 
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The view region will be inserted, but the region may not be positioned correctly. Let us move it within 

the drawing border. To do this, we need to be able to select the blue region border.  

• Click on the Selectability icon  at the top menu to access the Drawing Options dialog 

 

• Right-click on Connection Detail Drawing macro icon  

• In this dialog, you can set the details of the connection drawing, such as the scale and 

Annotation  

 

• Tick Viewport → OK   

• Click & drag the viewport into the Drawing Sheet 

 

 

 

 

• Double-click on the region to access the 

Viewport Property Editor 

• Scale can be change but let’s leave it as default  

• Go Filtering tab → change Up = 500 & Down = -

500  

• OK to close the dialog  

Notice there is a circle around the connection – this is 

directly linked to the connection box created in the 

main model.  
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• Under Annotation & Display Settings, review Annotation, Field and Text & Display 

• Click on Connection Detail Drawing Macro icon  

The Connection Detail will be inserted into the drawing as shown below. 

 

Further customization of the connection detail can be done. 

 

 

  

• Double-click in the detail region of the 

connection to access the Viewport Property 

Editor  

• Under Detailing tab, you can change :  

▪ Bolt Import Style  

▪ Bolt Drawing Style 

• Try the various options & click Apply 
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Plate, Bolts & Weld Annotation Tools     

The bolts, plates, and welds are automatically annotated in the above example. If you wish, you can 

manually do so by using the plate, bolts & weld annotation tools   

• Hold down CTRL key → select all the annotations of the “Front” detail → delete them 

• Click & drag a window (right to left) to select bolts & plates to be annotated (does not matter 

if other objects are selected) 

 

 

 

 

 

 

• Go to Filtering tab → Pick Filter 

Settings  

• Go to Object Types  

You can choose to turn on/off objects. 

• Untick Weld → OK → Apply  

The welds shown in thicker lines will be 

hidden. 

 

 

• Right-click on Bolt Annotation access the 

Settings 

• Pick Clear to remove existing settings 

• Click & Drag Count, Diameter & Material to 

the bottom Fields  

• Pick Annotation Settings to view/change font 

type, color, etc → OK 

• Pick “Apply & Create Annotations” 

 

 

 

• Right-click on Plate Annotation  access the 

Settings 

• Pick Clear to remove existing settings 

• Click & Drag PL Thickness, & Material to the 

bottom Fields  

• Pick Annotation Settings to view/change font 

type, color, etc → OK 

• Pick “Apply & Create Annotations” 
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You should get details similar to the figure shown below (depending on your preference). 

 

Numbering Objects 

Before parts and assembly views & drawings can be created, the objects must be numbered. By 

default, all objects are included in the same numbering group. To assign objects to different groups: 

• Double-click on the member to open the Profile 

dialog 

• In the Detailing Definitions tab, input Drawing 

Group number  

This feature was developed to number the different parts of 

the structure separately.  

The Prefix & Start Number can be specified for each group 

of objects.   

After the numbering process, the actual part and assembly 

number will be shown under “Actual Number”. 

• In Model View, Go to Drawings & Reports 

(tab)→ Perform numbering 

The Numbering Options dialog will appear.  

  

The drawing can be further improved by : 

• Go to Viewport Properties Editor and change 

the Scale 

• Change Offset (X,Y) to reposition the 

connection 

• Delete any annotations that you think is not 

required 

• Click & drag the annotation to reposition it 
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As the model is continuously revised, the numbering process needs to be repeated. ProtaSteel has 

extensive options for renumbering. Numbering Options can also be configured according to the 

preferences of the manufacturer. For example, there is an option to force the geometrically identical 

part to have the same number.  

Do Numbering  

• Specifies whether to number the selected group 

Unique Number 

• Unique: Can be selected for reinforced concrete elements. Objects are given a different 

number regardless of their geometric properties (beyond the scope of ProtaSteel) 

• Not Unique: Should be used for steel model. Makes numbering by looking at geometry and 

material properties. 

• Spatial Sort: Can be selected for the reinforced concrete model. This option performs 

numbering according to the object’s position. The object’s reference point is sorted first by X 

and then by Y. Different groups should be made for different levels. Consecutive numbered 

column and beam applications can be an example.  

Renumber All 

• Modified: Number only the modified objects. Ignores objects that have not changed. 

• Renumber number all objects.  

Reuse Old Numbers 

• Reuse: Uses old numbers. 

• Do Not Reuse: Don’t use old numbers. After the changes, there may be no elements belonging 

to a number. Specifies whether to use this number for a new element. 

Modified Part 

Suppose that we have three quantities of P5 and two quantities of P7. The three quantities of P5 have 

the same change and become the same as the P7. 

• Keep Number If Possible: Retains the numbers if possible after the change. If this setting is 

used, the result is still three quantities P5, two P7. 

• Compare to Old: Compares and assigns the part-marks from the previous numbering if 

possible. If this option is used, the result is five quantities of P7. 

• Take New Number: Assigns new part-marks. This option will lead to two P7 and three P8. 
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New Part 

Similar to “Modified Settings”. It only applies to newly created objects. Hence, there is no option to 

“Keep the Number If Possible”. 

• Compare to Old: Compares and assigns the part-marks from the previous numbering if 

possible. 

• Take New Number: Assigns new part-marks. 

 

Creation of Parts and Assembly Drawings 

If there are no problems after the Audit Model, Clash check, and numbering, the parts and assembly 

drawing can be produced.  

You can create the part & assembly drawing for the entire model or some objects.  

• Select the entire model or objects  

• Go to Drawings & Reports (tab) → Create Drawings → Create Assembly Drawing / Create Part 

Drawing   

The Drawing Module will be launched, and the drawings created.  

• In the Drawing Manager → Double-click to open & review the drawing 
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Import Titleblock using DXF Import 

In ProtaSteel, users can import title blocks and print drawings directly. 

• Users can import company standard title block as DXF in Drawing Module by going to File → 

Import → Import DXF 

         

• Select the company standard title block DXF directory. 

 

• Paper Anchor and DXF Anchor set to Bottom Right. 

Ensure the imported drawing contains only the title block. Block references can not be recognized. In 

addition to this, drawing units must be set correctly.  

 

• Titleblock annotation can be inserted/modified using the “Text” Function. 

Points, Construction Objects, and Text 
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Points, Construction Objects, and Text allow users to add details to the drawings such as the opening 

dash line, “to be continued” line, revision cloud, description, etc. 

• If you wish to select a point with no object snap, you can hold left ALT to select a free point. 

• Please hold the left CTRL before selecting the start point to draw it horizontally. 

• If you wish to draw it vertically, please hold the left SHIFT before selecting the start point. 

DXF Export  

All the drawings created in ProtaSteel can be exported as DXF format  :  

• Double-click on Drawing Manager (or F6) → File → Export → Export DXF 

• Under DXF Export → Pick Settings  

In the DXF Export Settings, you can choose the layers to be exported, change the Layer Name & Line 

Type. 

 

• Close the DXF Export Settings 

• Pick Export → Choose the destination folder → OK 

The DXF drawing will be created in the folder selected.  
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IFC File Export 

ProtaSteel model can be exported as Industry Foundation Classes (IFC) file. IFC is a Building 

Information Modeling (BIM) data structure created by buildingSmart International and is the ISO 

16739: 2013 standard. Most design software implements the IFC File format, including leading 

Building Information Model (BIM) platforms like Autodesk Revit, Bentley, and Tekla Structures. Wide-

spread usage of the IFC format facilitates sharing of building information models between various BIM 

platforms.  

• Select objects to be exported as IFC file format.   

• If no object is selected, then all objects will be exported.  

• In Model View → BIM (tab) →  Export IFC File 

 
 

• Click ‘…’  to specify the file name and location to export  

• Check the desired export options → Export 

 

Material Takeoff 

ProtaSteel automatically creates material lists of the whole of the steel structure. Material Lists is 

located under the Drawing and Reports tab. 
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There are two methods to prepare for your Material Takeoff and will be presented below: 

Method 1  

To generate quantity takeoff, say, for the steel members sorted by their sections, please refer to the 

following steps: 

1. Go to Drawings & Report tab→ Material Takeoff→ Prepare Material Takeoff 

2. Click OK on the Group Selector Dialog.  

3. Two Quantity Takeoff Tables (with different formats) will automatically export as CSV 

files: the Summary Report and Quantity Takeoff based on the section length. 

4. Repeat steps 1 to 3 for the other Material Lists option to export to the CSV file. 

 

 

 

  



Page - 93 

 

Method 2 

Method 2 generates a more detailed quantity takeoff with choices of categories to be included in the 

table. Please refer to the following steps:  

• Go to Drawings & Reports → Material Takeoff → Gross Profile Material List 

• Select corresponding format and units and click Execute Report. 

• Click Save to export generated report as a CSV file.  

 

 

NC File Export  

ProtaSteel can create the NC files for CNC machines to create the parts.  

 

• Go to the BIM NC file export 

• Select the items which you want to write on the 

steel members.  

• Set the text height and direction parameters.  

• Click “Run”. 

Numbering must be completed before creating the NC files.  
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Unsupported Situations:  

• NC files can not be created for pipe sections. The fish mount command can use for this issue.  

• Plates must be Folded Plates.  

The unsupported members will be added to the “not exported” list when files are exported.  

Prepared NC files are located on the \Exports\NC\Plates or \Exports\NC\Profiles in the project folder. 
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Closing Summary 

Congratulations! You have completed your steel model & generated the engineering drawings in 

ProtaSteel.  

In this Quick Start Guide, we have imported the ProtaStructure model into ProtaSteel. We then 

inserted ancillary steel members such as sag rods, adjusted members to their final positions, created 

some steel connections & generated the engineering drawings. This guide will give you the necessary 

knowledge to proceed to an actual project.  

For more help and guidance, please refer to the ProtaSteel help reference accessible from the Help 

menu.  

Alternatively, you can attend our training courses to obtain more in-depth knowledge of software 

usage. Please visit our website www.protasoftware.com for more information.  

  

http://www.protasoftware.com/
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Thank You 

Thank you for choosing the ProtaStructure Suite product family. 

Our top priority is to make your experience excellent with our software technology solutions.  

Should you have any technical support requests or questions, please do not hesitate to contact us at 

all times through globalsupport@protasoftware.com and asiasupport@protasoftware.com  

Together with our responsive technical support team, our dedicated online support center is available 

to help you get the most out of Prota’s technology solutions.  

The Prota Team 
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