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1. Introduction 

Thank you for choosing ProtaStructure.  This Quick Start Guide aims to get you up and running quickly. 

You should be able to model, analyze and review the results for this simple model in around 1 hour. 

 

2. User Interface 

ProtaStructure 2021 welcomes you with a modern & efficient user interface designed from scratch 

for ease of use. The various components of ProtaStructure user interface are as shown below:  

 

 

 

Ribbon User Interface 
 

 

 

 

 

 

The ribbon consists of several toolbars, placed on various tabs. Each toolbar contains related commands 

organized into logical & functional groups. Placing the mouse cursor over a command will reveal the 

Tooltip explaining how to use the function.  

Structure Tree 

Plan View 3D View 

Layers & 

Display 

Tab Toolbar 

File 

Quick Access 

Views 

Status bar – reveals important information, eg. required action to proceed Command Entry Units Cursor coordinates 

Commands for the 

selected Tab Toolbar 

Refresh, Rotate, Zoom 

Toolbar Tab 

Group Command Tooltip 

Search 
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Generally, you create the model by working from left to right ribbon tab, i.e. start with Building Setout 

→ Modelling → Loading → Review → Analysis → Design → Drawings & Report.  

Views 

 

Create as many views as you need, such as plan, 3D physical Model, Analytical Model &  3D rebars. 

Views can be organized using smart window layout options.   

Customize your work area by docking and floating views. The interface is compatible with multiple 

monitors. If you want to make the most of your screenscape, just move one of the views to another 

screen. 

Structure Tree Search Option 

Looking for a specific member or object? Type in the member label in the structure tree’s search box 

and let ProtaStructure find it for you. 

 

Quick Access Toolbar 

The Quick Access toolbar displays commonly used commands. Any command can be added to the Quick 

Access toolbar by right-clicking on the command → Add to Quick Access Toolbar. 

 

  

Search 
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Display Settings       

 

Active Window Settings & Visual Interrogation    

Visual 
Interrogation  

Color-code members to various criteria such 
as design status, material types, beam with 
wall loads. It is a vital visual tool to check and 
verify the inputs and result of the model.  

Scene Settings  
Control the graphics of the views and allows 
you to switch on/off the guiding Grids & 
Coordinate Axis, etc.  

Visibility 
Filters  

Filter to the specific storey, axis or member 
type.   

Column Plan 
Display  

Allows the column wall axial, moment & 
shear forces to be displayed on the plan view.   

Beam Plan 
Display  

Allows brick / partition wall label, load value 
& height to be color-coded and displayed in 
the plan view. In addition, you can show the 
total user defined load (only after the 
analysis) & display beam elevation marks.  

Slab Plan 
Display  

allows the dead and live load values to be 
shown on the plan view.  

FE Contours 
Shows the FE contours exported from the FE 
Analysis Post-Processing 

Animation Animate by spinning the model in 3D view 

 

 

Colors 
Choose the color of background and various 
active modelling objects 

Grid 
Sets the spacing of the guiding grid system to 
allow ease of modelling as objects can snap 
to intersection of the grids 

Line Type  Sets the Line Type Scale 

Object Snap  
Choose the various snap options such as 
Start/End/Corner, Perpendicular or 
Orthogonal Grid, etc.  

TIP : Each modelling window can have separate view settings. For example, you might want to color the 

slab live loads on the plan view & at the same time color design status in the 3D view. 
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Layer Tool bars (under Display Tab) 

Layer and color settings   
switch on/off layers and modify the name, color, opacity, line 

type, line weight, font type and text height. 

Axis Layer Group  
 

switch on/off the axes layer 

Column Layer Group   switch on/off the column layer  

Wall Layer Group  
 

switch on/off the wall layer  

Partition Wall Layer 
 

switch on/off the partition / brick wall layer 

Beam Layer Group  
 

switch on/off the beam layer 

Slab Layer Group  
 

switch on/off the slab layer  

Ribbed Slab Layer Group 
 

switch on/off the ribbed slab layer 

Slab Load Layer Group 
 

switch on/off the slab load layer 

Slab Strip Layer Group  
 

switch on/off the slab strip layer  

Reinforcement Layer  
 

switch on/off the slab reinforcement layer  

Steel Member  Layer 
 

Switch on/off steel members such as truss, brace, etc 

Ghost Axis Layer Group 
 

switch on/off the ghost axis layer  

Plane Definition Layer 
 

switch on/off the plane definition layer 

TIP: In the Scene Settings tab, Grid allows you to switch on/off the grey rectangular grids in the 

background. Coordinate Axis allows you to switch on/off the coordinate symbol. 
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3. Start Page 

When the ProtaStructure is launched the “Start Page” will appear. 

 

The Start Page contains the following functions: 

❖ Open existing project  

❖ Start a new project 

❖ Read Prota News and watch Prota Videos 

❖ Access Prota resources such as Help Center, What’ New document & Quick Start Guide 

❖ Read important Notification and download new Software Update 

❖ View subscription status 

 

  

Text Layer Group 
 

switch on/off the all the  texts 

Footing Layer Group 
 

switch on/off the footing layer 
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4. Starting a new project 

➢ Click Open Project in the Start Page & the Open Project dialog will appear. 

Here is the explanation of the functions in this dialog : 

 

1. The Project Data Folder is the main folder where the project models are stored. 

The project model consists of several files stored in a single folder called Project folder. This Project 

folder is created as a subfolder in the Project Data Folder. The project folder name will always be 

created exactly the same as project name. 

2. By default, a Data Folder called ProtaData2021 will be installed under My Documents 

3. If required, you can specify a different location by clicking Choose/Create Folder.   

4. Clicking on Explore will open the current Project Data Folder in windows explorer.  

5. You can open existing projects stored in this Data Folder by selecting it the project list  

After selecting the project, a preview of the project will be shown in the right-hand side 

Double-clicking on the project name or click OK will open the project.  

6. Click on the dropdown list just under the above to expose most recent accessed Data Folders.  

7. Tick Most Recently Used Projects to quickly show the list of recent project opened.  

8. You can also read Project Last Saved Date to quickly locate the saved project.  

 

 

 

 

 

 

  

Tip :  Previous versions of ProtaStructure  model can be opened directly in PS 2021: 

➢ Firstly, you must choose the correct Data Folder by clicking Choose/Create Folder.  

➢ Browse to the desired Data Folder (note data folder is the main folder, not the project folder) 

➢ You will then be able to see the project and open it.  

➢ You will be prompted to save the model as another name.  

➢ After converting, the project will open.  

➢ Please note that newer projects can’t be opened in older versions of ProtaStructure (not backward 

compatible).  

 

1 
2 

5 

3 4 
6 

7 

8 
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➢ Click New Project  and type the project name as shown using the ‘_’ character for spaces. 

➢ Select Singapore (EuroCode) template  

 

 
 

Templates are used to rapidly establish default model parameters such as design codes, material 

properties, member design settings etc. Alternatively, you can choose to duplicate settings from an 

existing project by picking “Projects”. 

➢ Click OK. 

The main modelling area will now show a set of rectangular grids in the background.  

 

These girds spacing are by default 1m with major grid colored darker every 5m.  The defaults can be 

changed via Display Setting button  
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5. Settings Center 

The Setting Center can be accessed by clicking on the Settings icon in the Quick Access Toolbar or 

from the Display tab (as shown below).  

 
The Settings Center centralizes all the default settings of the program including analysis, design and 

detailing and Units & format settings.  

 
 

For example, when you initially start a project, it’s advisable to review the Automatic Save Interval in 

the View & Save dialog. By default, “0” means it’s disabled.  

➢ Change the Automatic Save Interval to 10 minutes to ensure the model is auto-saved.  

➢ Untick Prompt for Automatic Saving to set the auto-save to run silently in the background.  

Number of Backups to Save 

The Number of Backups to Save refers to the automatic & silent additional backup created every full 

hour.  Example, the 1st backup file will be created at 9:00 am sharp, 2nd backup at 10:00 & 3rd backup 

at 11:00. At 12:00 pm, the backup will overwrite the 1st backup and the cycle continues.  

c 
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The backup zip files can be found in a folder called “Backup” in the same Project Data Folder.  The 

files name will have the date and time stamp (example shown below) 

  

Project Template 

When you start a new project, the available templates are shown, and you must choose one. You can 

access these templates again via the Building Setout tab.  

 

 

Importing an existing Template  (refer to step 1,2,3 above) 

You can change the Template of a currently opened project by selecting a different template and 

Importing it :  

➢ Pick a Template (1) → Pick Select All (2) →  Import (3) 

All the settings of imported template will apply to the current project.   

Exporting a new Template (refer to step A,B,C,D above) 

You can save the settings of your current project as your own template by Exporting it :  

➢ Pick New Template (A) → Give it a name → OK  → The new template will be created (B) 

➢ Select the new template (B) → Select All (C) → Export (D) 

Template will be successfully exported & can be re-used the next time you start a new project.   

1 

2 

3 

My template 

A 

B 

C 

D 
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6. Selection Methods 

Selection is performed using the selection button   in the Member toolbar.  Although there is no 

entity to select now, the information is important as you work through the model.  

• Left click on the entity to select the entity.  Selected entities are also highlighted in the Structure 

Tree 

• To select multiple entities, hold down CTRL key while you pick them 

• You can select entities directly from the Structure Tree 

You can drag with the mouse to access further selection options: 

• Drag from left to right to create a rectangular box. When you release the mouse button, all 

entities completely contained within the box will be selected 

• Drag from right to left similarly and all the entities that cross its boundaries will be selected 

 

If you right-click the selected entities, you will see a pop-out context menu which allows you to edit 

and perform other task related to that entity, example Properties, Delete etc.  

 

Pressing ESC will deselect all entities.  

 

7. Zoom & Pan Methods 

The useful functions are: 

Zoom Window   CTRL+W  → Zoom into the area defined by dragging a rectangle.  

Zoom Previous   CTRL+O    → Zoom to the previous view. 

Zoom Extents   CTRL+E     →  zooms to the selected entities. If no entities are selected, then it 

will zoom to show all entities. 

Zoom Limits   CTRL+L     → zooms to show the limits of the grids. 

 

You will find it easiest to use the mouse wheel to: 

Zoom in  → scroll your mouse wheel up 

Zoom out  → scroll mouse wheel down 

Pan (move)  → hold down the middle mouse wheel and drag  

 

8. Modelling Axes 

The very first step to build a model is to define axes. Axes intersections then becomes the nodes at 

which members are inserted. Hence, it’s critical that axes are created correctly. There are 3 ways to 

model axes: 

1. Axis toolbar to build axes individually 

2. External Reference Drawing to import all axes from dxf drawing file.  

3. Orthogonal Axis Generator to build a system of axes quickly 
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9. Axis / Grid Tool 

Modelling individual axes is simple using the program’s Dynamic Input System (DIS).  

➢ Click on Grid   in the Modelling tab. 
 

There are several insertion methods for axis:  

 

   Single Segment allows you to create a straight-line axis by 

clicking on the start and end point of the axis. 

 

  Multi-segment axis enables you create a single axis with 

multiple segments of any shape  

 

  Curve Axis can be created by specifying the radius 

 

➢ Ensure Single Segment insertion is selected 

➢ Put the mouse cursor on any of the grey grid intersection & the “Grid Intersection” snap is shown 

 

 
 

➢ Left click (& release) to confirm the start point  

A “rubberband” will appear as you move your mouse cursor to specify the end point 

 

During the rubberband operation, the length (L) and local angle will be displayed. In addition, 
the relative distance ∆x & ∆y with respect to the local UCS will also be shown.  

➢ Press F2 to enable input of  the length (L) of axis via Dynamic Input System (DIS) 

➢ Press TAB to cycle to the next input of angle. 

c 
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• If a value is entered in the textbox, the related 
parameter will be locked. You can unlock by 
pressing ESC or pressing the lock icon at the right of 
the text box. 

• If a textbox is locked and F2 or ENTER is pressed 
then DIS will be deactivated. However, rubberband 
operation now continues with the locked 
parameter for ease of use. 

 

 

The left figure shows the length L is locked, so 
you can freely rotate the axis without 
changing the length. 

 

 

 

 

• If both of the text boxes are locked then pressing ENTER will accept the operation and candidate 
point will automatically be picked. 

• In either of the text boxes, you can use shortcut notation Length<Angle or DeltaX, DeltaY   
(without the need to switch by TAB.) 

 

                 
 

➢ After specifying the length and/or angle, pressing ENTER or left-click will accept the end point 

➢ Try inserting a multi-segment axis  by  defining points continuously   

Length<Angle DeltaX,DeltaY 
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• Use F2, TAB, ENTER to define destination points as mentioned earlier 

• Pressing ESC will cause a smart roll-back. If parameters are locked, then first the DIS is unlocked 
then operation is cancelled. If a pick-continuous command is active, ESC will unpick points. 

➢ Right-click to end the operation and insert the axis 

 

• When the axis property dialog shown, you are in axes creation mode. Close it if you would like to 
end creation of axis.  This applies to all member properties dialog.  

➢ Insert a curve axis by clicking on the curve axis icon  

➢ Click on the 1st point and then the 2nd point 

 

➢ Move the mouse cursor to the 3rd point that will specify the offset length of the curve.  

➢ Left click to confirm the 3rd point > Curve axis will be created 

 

• Alternatively press F2 to specify the offset length manually.   
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10. External Reference Drawing 

Note : This section is for information. A DXF drawing is required if you want to try out this feature.   

ProtaStructure allows you to load external DXF drawings and show them as ghost reference layers 

under your model. External Reference Drawing button can be found under the Quick Start menu. 

 

This tool allows you to assign DXF drawings to different stories. Properties like unit, opacity, scale factor, 

and offset can be set individually for each imported file. The whole state will be saved along with the 

project data and can be restored; the next time project gets opened. 

Important! The referenced DXF files should be intact to restore the external drawing layer next time the 

project gets loaded. 

 

Add 

Click Add to select and load a DXF file. The file will be converted into 2D drawing entities inside 

ProtaStructure directly upon loading. However, it will not be visible until the Active box is checked. 

Active 

This checkbox controls the visibility status of the external drawing.  

Unit 

Please select the correct unit of the DXF file from the unit column of the table right after the loading of 

the file. The drawing will be scaled immediately. 

Storey No 

The imported file will be assigned to the active story initially. You can use the ‘Story No’ column to assign 

it to any other story. Only one drawing can be attached to a specific story. 

Use Colors 

c 
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If this field is checked, colors defined in the file will be used, if unchecked, a grayscale drawing is 

displayed. 

Opacity 

This parameter controls the opacity of the colors. This field applies only if drawing colors are selected to 

be used. 

Scale Factor 

This factor scales the whole drawing. 

Move & Offset 

Click the ‘Move’ button and pick two points on the plan view to move the external drawing. Dynamic 

Input functionality (hit F2) can be used here as well. The offset value between the two picked points will 

be shown at the ‘Offset’ column of the table. 

 

Import 

The selected reference drawing can be imported into the assigned story. ‘Import DXF’ interface will be 

loaded with pre-defined Storey and file unit values in this case. The drawing can be imported on top of 

the existing model in this mode.  

A full model can be developed from scratch in a controlled environment using the ‘External Reference 

Drawing’ interface and Import option.   
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11. Import DXF 

Note : This section is for information. A DXF drawing is required if you want to try out this feature.   

Three options are available for DXF import into ProtaStructure which can be accessed from the 
QuickStart Menu, Import DXF button :  

1. Floor Plan (a pre-defined structural floor-plan for example) 

2. 3D Physical Model 

3. 3D Analytical Model  

 

If you are importing a drawing which you also wish to use overlay against your model for coordination 

purpose, please use the ‘External Reference Drawing’ option. 

Please note that member definitions usually vary significantly from one software to another.  

ProtaStructure uses grid systems to be able to create a high-precision structural model out of physical 

members for analysis, design, and detailing purposes. Since DXF is not a data-rich format, its not always 

possible to capture all the modeling information such as connectivity and grid relations, sections, and 

eccentricities. We generate these from the primitive data read from the file. However, you may have to 

edit and refine information further once you have it in ProtaStructure.  

Importing Floor Plans 

Floor plans can be imported and transformed into 3D modeling elements.  

 
DXF > ProtaStructure 

DXF import module reads primitive CAD objects and converts them to structural members as grids, 

columns, beam, shearwalls, slabs, and piles. The below table shows supported CAD entities for 2D 

drawings.   

c 
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Structural Member Supported CAD Entity Type 

Grid Polyline, line 

Column Polyline, line, circle, block 

Shearwall  Polyline, line 

Beam Polyline, line 

Slab Polyline 

Pile Polyline, circle 

Tip: Grid definitions are not a MUST. If they are not provided, they will be generated automatically, 

considering all the imported structural members. 

Please select the DXF file using the “Load DXF” button. The file will be read immediately.  

 

Layers 

Each member type should be defined on different layers in the DXF file.  

The layers in the file are scanned for keywords to spot possible layers that may be used for entities 

defining structural members in ProtaStructure.  

The layer detection is done automatically upon the DXF file load.  

If layers for a specific member type are not recognized, please use the dropdown list to assign the layers 

manually.  

You can make multiple layer selection for each member type. At least one layer should be selected to 

enable that member type for import. 

You can use the “Assign Layers” button anytime to reset all layers to the ones found by the program. 

Text Layer is only necessary to relate grid labels with grids.  

Add/Replace 

To prevent discrepancies, Add/Replace functionality is disabled for Floor Plan Import. Members will be 

added to the existing model. Existing members in the model (if any) will not be removed. 
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Unit of File 

Please select the unit of the DXF file you load.   

Connectivity Tolerance 

This tolerance helps ProtaStructure to correctly assign grids to shearwalls, beams, and columns, even if 

nodes of the grids are outside the borders of those members’ geometrical definition. 

Connectivity tolerance should be larger than the distance measured from the beam or shearwall 

boundary to the grid intersection. 

 
DXF > ProtaStructure 

Storey Information 

Select the Storey on which the model is to be generated. The current Storey will be selected upon the 

form opening. 

If you are going to create a full model out of 2D floor plans, you’ll need to create the stories first. You 

may also find it easier to use the External Reference Drawing import command for this. It helps to 

manage all drawings from a single interface and links to the DXF import interface. 

Min Beam Length  

The length of a DXF line entity should be higher than this value to be eligible to form a beam. 

Max.Beam Width 

The import module checks all parallel lines against possible beam formation. Distance between two 

parallel lines should be less than this value to form a beam.  

Default Beam Height 

Beam sections will be generated using the measured beam width and this value.  

Default Slab Thickness 

This parameter can be used to assign the default thickness for the imported slabs.  

Default Pile Length 

This parameter can be used to assign default length for the imported piles.  

For 3D Physical Model & 3D Analytical Model import, kindly refer to Prota Help Center.  
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12. Orthogonal Axis Generator 

Let us now start the new model with creation of the required model axes. We will define multiple axes in 
one go using the Orthogonal Axis Generator.  

 

➢ Select all existing axes that you have created → press Delete (or right click → Delete) 

➢ Go to the Modelling tab > Select Orthogonal Axis Generator  

Refer to the bottom status bar; the displayed text tells you how to proceed. 

 

➢ Pick the intersection of the major grid near the origin (as shown below) 

 

 

 The Orthogonal Axis Generator will appear. Direction 1 axes are placed horizontally with 
alphabetic labels (incremented from bottom to top). Direction 2 axes are aligned vertically with 
numeric labels (incremented from left to right).  

➢ Accept all the default values in the inputs and click OK 

 

 

 

 

 

 

 

 

 

 

For horizontal and vertical axes with spacing of 5m will be created. 
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13. Columns Creation 

➢ Pick RC Column icon    

➢ Use the default size b1 & b2 and eccentricity e2 & e2 is as shown below  

 

 

 

 

 

 

 

 

 

 

  Section Manager icon allows you to access other sections types such as circular, “L”, “T”.  

Column End Condition : Columns ends are fixed by default. You can apply hinges to top and/or 
bottom by clicking successively on this icon.   
 

 
 

➢ Insert columns by clicking on the intersection of axes 

➢ Multiple columns can be inserting by drag a box around the intersection of axes 

Using the 2 methods, create 10 nos. of columns at position shown below. 

 

e2 

e1 

e1 & e2 is measure from the centroid of the column 
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➢ Close the column properties.  

TIP : Always close member properties when you finish member creation.  
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14. Walls Creation 

➢ Click on the Wall icon    & the wall properties will appear 

➢ Use the default wall thickness b = 250 mm & e = 0 mm 

The parameters are explained in the diagram below 

 

e is measured from the centerline of the wall to its centroid. e = 0 means that centerline of the wall 
coincides with the centroid of the wall.  
 
➢ Insert the 3 nos. of wall by simply clicking on the start and then end of the wall.  
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15. Beams Creation 

➢  Click on the Beam icon   & the beam properties will appear 

 

 

 

 

 

 

 

  e  is measured from the centerline of the beam to its sectional area centroid. e = 0 means that 

centerline of the beam coincides its area centroid.  
Beam End Condition : Beam ends are fixed by default. You can apply hinges to left and/or right by 
clicking successively on this icon.   

➢ In the beam properties, use the defaults values b = 250 mm & h-Bot = 500 mm (as shown above) 

➢ To create a beam, click on the intersection of axes for the start & then end of the beam 

Notice that you can continue to create the beams from the previous beam continuously. 

 

➢ Right-click to end the beam insertion after inserting the 2 beams as shown above 

Multiple beams can also be inserted by dragging a box enclosing the area you want to insert beams. 
Beams will automatically be created between columns and walls.  
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➢ Click and drag box enclosing the columns & walls shown above. 

   

Seven (7) new beams will be created. 

➢ Insert the rest of the beams by any method as shown below 

 

Check the folder Beams in the Structure Tree to ensure you have inserted a total of 18 beams.  

We will now insert a curve beam in the lower right corner of the model.  

➢ Click on the curve beam insertion icon  in the Beam Properties dialog 

➢ Click on the intersection of axes A/3 and then intersection of axes B/4 (ie. start & end of the beam) 
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You define the radius of the curve by simply moving the mouse cursor and the preview of curve 

beam in grey will show automatically.  

➢ Press F2 to define the radius of the exactly to -1500 mm & press ENTER 

A curve beam will be inserted (segments are automatically created). Check the Structure Tree that 

you have modelled a total of 19 beams. 
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16. Beams Creation using dynamic snap points 

Note : This section is optional and it not part of the final model but you might want to try it anyway. 

Secondary beams can easily be inserted using the dynamic snap points (without having to create axes). 

➢ Click Beam icon & place the cursor on the edge of primary beam (avoid the axis) 

 

Notice that snap points on 0.25L, 0.33L, 0.5L, 0.67L, 0.75L will be shown when the cursor is placed on 

the beam. 

➢ Click on 0.67L as the start point of the secondary beam.  

➢ Place the cursor on the destination beam  

 

Notice that 0.25L, 0.33L, 0.5L, 0.67L, 0.75L & perpendicular point will appear 

➢ Select the desired point as end point of the secondary beam & a new beam will be created 

Pressing F2 while the cursor is at any of the snap points will allow input the exact distance from the start 

of the beam.  

Place cursor on 

edge of beam 
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Pressing CTRL key while the cursor is placed on the primary beam will expose distance of increment 

100mm. Left click to select the desired distance (while still holding down the CTRL key).  

 

 

Handy Tip to adjust the position of columns and beams  

You can adjust the position (eccentricity) of the column and beam by simply selecting it & then pressing 

keyboard arrow keys to move in the direction you want.  

  

The step by which the member is moved can be set in Building Setout → Settings Center → View & 

Save → Member Section Eccentricity Step (by default 25mm).  

 

  

➢ Select column GC1 

➢ Press right arrow key → to move the 

column to the right  
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17. Slab Creation 

➢ Click on the Slab icon   and the slab properties dialog will appear 

 

Label icons activates the slab label plus control the position of the slab label.  

Insertion method : By default, “Beam Region” is selected. This means the slab will be inserted within the 

region bounded by the beams.  

➢ Select Slab Type as 1 
  

For ease in creating this model we will initially leave Slab Type as 1 for all slabs. Once they have been 
created & when we are ready to design the slab, there is a function to automatically set the correct 
type for each slab (covered later). 
 

➢ Enter the slab thickness h = 200 mm and concrete cover = 30 mm 

➢ In the Loads tab, enter Service Dead Load = 1.2 kN/m2 and Imposed Load = 3 kN/m2 

Different types of service dead load can be defined via Building Setout → Slab Additional Loads library. 

➢ To create a slab, position the cursor in the region bounded by beams @GL 3,4,C,D and left-click.  

 

  

➢ Click on the Type box  
 

All the possible Slab Types will appear in pop up menu. 
 
The slab type 1 to 12 relates to table 3.14 in the BS 8110 and 
is used in the design of the slab reinforced based on the 
coefficient method.   
Type 1 to 12 does not affect the slab load calculation on the 
supporting beams.  

 

  One-way slab. The slab load will only to be 

transferred to the 2 supporting beams only in the 

direction of the span.   

The direction of one-way span must be specified in the 

Angle input box :  

 

The first slab will be inserted.  

The yield line shows the tributary area load 

this is automatically calculated onto the 

supporting beams. By default, slab load 

calculation is done automatically onto 

supporting beam using yield line method.  
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➢ Create 7 more slabs to give the layout shown below 
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Polyline Slab/Column Edge   

Note : This section is optional and it not part of the final model.  

The slab edge line can be used to create irregular slab shapes 
 

➢ Click Polyline Slab/Column Edge   under Modelling 
 

➢ Click continuously to define the edge of the cantilever slab.  

 
 

The method to draw the edge lines are similar to multi-segment axis.  
 

➢ At the last point, right click & pick Finish to end the insertion. The slab edge lines will be drawn 
 

 
 

➢ Click on the Slab icon → Ensure Type = 1 is selected 

➢ In the Insertion, ensure that Beam Region is selected.  

➢ Click anywhere within the slab edge line and a new slab will be created. 

 

 
 

Note : For regular cantilever slab, it is recommended to use Type 12 in slab properties (instead of  slab 

edge lines) 

TIP :  The slab/column edge line also includes Circle, Arc & Rectangle and the ability to convert to a 

column or slab hole or slab drop. After drawing a closed shape line → Select it → Right-clck → Convert 

to Column or Slab Hole/drop  
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18. Views Creation 

The graphical editor supports multiple windows; this allows you to create different views in separate 

windows.  The Views tab commands can be used to create new views and to arrange the views.  

 

➢ Go to Views tab  →  Click 3D Physical Model   

This will create a 3D physical model view.  
 

➢ Click Tile Vertically   →  This will tile the plan and 3D view side by side 

 

You can select & modify existing members or model new members in the 3D view in the same way as 

the plan view.  

Note : Alternatively, you can right click on Views in the Structure Tree or header field of the existing view 
tabs to create new views.  

          

➢ Select the curve beam in the 3D view. Notice the same member will be selected in the plan view. 

➢ Right click (to access the context menu) → Properties  

➢ Change the depth of the beam h-bot to 600 mm  

➢ Click Update and Close the beam properties  
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19. Inserting Storeys & Defining Building Parameters 

The final model will be a 4 storey building. We will now insert the other floors.  

➢ Go to Building Setout → Storeys drop down → Insert Storey.  

 

➢ Input Total No. of Storeys = 4 → OK 

 

➢ When prompted to confirm → Pick Yes 

This automatically inserts storey 2, 3 & 4.  We will now edit the information of the storeys. 

➢ Pick Edit Storey from the same Storey  dropdown menu to enter the Edit Storey dialog 

➢ Hold CTRL key and multiple select Storey 1, 2 & 3.  Then click “Define selected storeys as similar” 

 

➢ Alternatively, right-click on Storey and pick Insert Storey 
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This means that storey 1, 2 & 3 will now be identical. Since we have already inserted members in storey 

1, these members will be automatically copied to storey 2 and 3. In addition, changes to a particular similar 

storey will be applied automatically to all similar storeys.  

For storeys to be identical, they must also have same storey height. In a real project, ST01 is the ground 

floor & will have a shorter storey height & hence should not be made similar.  

➢ Under Labels column, change member label to as shown above, eg. “G” for ST01, “R” for ST04. 

This means that ST01 members will be labelled GB1, GC1, etc.  

➢ Click OK to exit and notice that the 3D view now shows storey 1, 2 & 3 with identical members.  

Storey 4 (Roof) has no members so we will generate (copy) members to this storey. 

➢ Pick Generate Storey from the same Storey  dropdown  

 

➢ Under Source Storey, pick Storey 1  & then pick Storey 4 as Target Storey 

➢ Click OK and members will be copied from ground floor to roof 

➢ Click Close and check that members are indeed created in storey 4 

➢ Switch to show storey 4 in the plan view by double-clicking on storey 4 in the structure tree 

➢ Create a new slab over the lift core since this is the roof level 

➢ Press ESC  to deselect all previously selected members 

➢ Right click anywhere on the plan view to expose the context menu  

➢ Select Member Tables → Slab Table  

The slab table allows you to view & change the parameters of the slabs in a group 
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➢ Click on the header q (live load) and the entire columns will be highlighted 

➢ Click Columnwise Edit icon at the top  

➢ Enter 0.75 kN/m2 → press ENTER  (all the slabs live load values will be changed) 

➢ Close the Slab Table 

 

20. Wall Loads Library & Inserting Brickwall Loads 

You can set up pre-defined all loads and then apply them using dropdown list when adding the wall 

loads. 

➢ Go Building Setout → Partition Wall Loads  

 

Defaults wall types are automatically setup but you can add any new user-defined wall type.  

➢ Choose Cancel to exit 

We will now insert brickwall loading on the beams in ST01 

➢ Make the plan view active by clicking on it 

➢ Double click on ST01 in the structure tree to make it active 

➢ Select a perimeter Beam  →  Click Edit Wall Load  in the Beam tab that appears.  
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Alternatively, you can select the beam → Right-click → Edit Wall Load 

 

➢ Choose 200 Brick Wall – Singapore 

➢ Enter Wall Height = 3.00 m  → Click on any other box for the diagram to refresh → OK  

Examine the 3D view and note that the wall load is also copied to ST02 & ST03 as they are similar.  We 

will now copy the brick wall load to all the perimeter beams. 

➢ Ensure the beam with wall load is selected → right-click  → Copy Wall Load 

➢ Multiple select all the perimeter beams by holding down the CTRL while selecting the beams. You can 

also drag a box to select the perimeter beams (it does not matter if columns are selected). 

➢ Right-click  → Paste Copied Beam Loads 

➢ Choose Yes to copy the loads 

 

➢ Examine the 3D view to ensure all wall loads are inserted correctly.  The model is now complete and 
we are ready to run the analysis.   

Tips 

Partial wall can be entered by 

checking “Define Wall Length 

Manually” : 

➢ Enter Wall Length 

➢ Enter “Reference X” for position 
of start of the wall load 

Wall Opening, eg. of windows & 

doors can be inserted by click “Edit 

Openings”. 
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21. Building Analysis 

➢ Go to Analysis tab →click Building Analysis    → Pre-Analysis tab 

 

The Pre-Analysis settings is where main assumptions of the analysis can be defined : 

• Project Parameters : review or modify the analysis parameters such as the design code and 

notional horizontal load  

• Load Combination : generate, add or modify any load case or load combination sets.  

• Wind and Storey Load : automatically generate wind loads, review & input any lateral load. 

Automatically generated lateral loads such as the notional horizontal loads will only be calculated 

and shown after the analysis.  

• Edit Materials : review, add or change the concrete and steel material of the building.   
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22. Materials 

We will now define the materials for this project via Building Analysis > Pre-Analysis dialog. 

➢ Pick Edit Materials 

  

The materials and reinforcement steel grades are shown for all member type. Default Material is used 
for super-structure floors. A separate Foundation Floor category is automatically created for foundation 
members only. 
If there is different material for a particular storey, a separate material settings can be added by picking 

the   icon.  Steel reinforcement grades and diameters are also defined here.  

➢ Pick Column Concrete Grade → select C30/37 → Apply to all member in this Storey → OK 

  

➢ Pick Steel Grade and ensure that Grade 500 (Type 2) is selected and applied to all member types 

➢ Pick Diameter  and select the desired rebar diameter to be used in the member design  

➢ Pick OK to return to the Building Analysis dialog 
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23. Load Combinations 

We will now auto-generate the load cases and load combination.  

➢ Pick Loading Combination to launch the Load Combination Editor 

 

You can add new load cases manually and then load combinations. However, it’s easiest just to use the 

Loading Generator to automatically set up load cases and combinations. 

➢ Pick Loading Generator & use the options as shown below and click OK  

   

You can choose which combination is used for concrete & steel design separately.  

If “Use Cracked Sections” is checked, Section Stiffness Factors will be applied for that load case.  

All the load cases and combinations will automatically be generated as shown below. 
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24. Building Analysis Model Options 

➢ Go to the Model Options → Model →  Material & Section Effective Stiffness Factors and review the 

assumption as shown below 

 

 

 

 

 

 

 

 

 

 

  

Notes:  

• The stiffnesses table will only be applied for load cases with ‘Used Cracked Sections’ checked in the 
respective Load Case Editor, except for seismic load cases where cracked sections are always 
assumed.  

• Each seismic code has its own set of default values. If an entered value is different than the default, 
then editor color will turn to orange to inform the user. 

• Building analysis must be repeated each time the effective stiffness factors are changed. 

• To prevent large torsional forces in primary beams due to secondary beams, the global Torsional 
Stiffness Factor is by default set to 0.10 (10%) in the Stiffnesses settings.  

• Stiffnesses of individual members can be changed  by selecting a member → Right-click → Edit 
Section/Material → Properties tab. 
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25. Running Analysis 

➢ Go to the Analysis tab 

Before running the analysis, it’s always recommended that we check the validity of the model.  

➢ Click Building Model Check & pick All Storeys & click Start 

 

➢ Click Close to exit the check  

The building analysis can now be performed.  

  

  

➢ Click Building Analysis 

Eigenvalues analysis can be done to obtain the natural 

frequencies and mode shapes of the structure. 

The Batch Design Options dialog will appear. It allows you 

to perform the design of column/wall and beams 

automatically after the analysis.  We suggest that this 

should only be done if you are confident that the result is 

correct.  

➢ Check  Column/Wall Reinforcement Design 

➢ Check Beam Reinforcement Design 

➢ Pick Building Analysis to analyze the model 

The analysis will also check for instability and large 

deformations and there will warning messages if any are 

found.  The Analysis Summary Report will appear at end 

of the analysis stating summarizing the important results.  

The building model check will pick up the most obvious 

modelling errors as indicated.  

 

The warnings / errors are mostly self-explanatory. The 

exact member(s) affected will be stated. 

 

You should review any warnings / errors and correct 

the model before proceeding to perform analysis.  

 

Click “Load Log to Editor” to open the list of 

warnings/errors in a separate screen in Notepad for 

ease of reference. 
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26. Axial Load Comparison Report 

An important check on the validity of the analysis is the Axial Load Comparison Report. This report sums 

all of the dead and live load applied at each storey and displays the axial forces in the columns and shear 

walls. These values need to agree with each other within a tolerance limit of 5%. If they do not, the 

reason for the discrepancy should be investigated.  

➢ Select  Axial Load Comparison Report  (in the Analysis tab) 
 

 

Table 1 : TOTAL LOADS (Based on Slab) is sum of dead and live loads of all members with the slab load 

not yet decomposed or calculated on the beam. You can take this as the input weight of the structure. 

Table 2 : TOTAL LOADS (Decomposition to Beams) takes into account the decomposition of the slab 

load onto the beams based on either yield-line or FE Decomposition. The beam load now includes the 

slab loads (and hence zero values are shown under the slab column). 

Table 3 : BUILDING ANALYSIS COLUMNS AND WALL AXIAL LOADS  sums up the actual column and wall 

axial loads after building analysis.  

Firstly, check Table 1 total values are similar to Table 2.  This ensures that all slab loads are accurately 

captured by beams, i.e. no slab loads are lost.  

Then verify Table 2 total values are similar to Table 3. This ensures that all the superstructure weight is 

completely captured by the columns and walls down to the foundation.  
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27. Analysis Model and Results Display 

The Model and Analysis Results Display enable you to review the results of the analysis graphically. By 

default, a view will automatically open once Building Analysis is successfully com 

➢ If not, go to the Post-Analysis tab  
➢ Click Display Analytical Model  → Close the building analysis dialog 

 
A new Analytical Model tab set will appear together with Analytical Model view.  

 

 

The analytical wireframe is shown in blue. Load cases and combinations can be selected on the right-side 
pane.  
If too much information is displayed the screen can appear cluttered. However, by making use of the 

various filter buttons and the view settings, you can create a more meaningful display view.                                  

➢ In the General tab, click on the Filters command (if it’s not activated) 
The filter options will appear in the left-hand side of the view. There are options to filter the display 
by Storeys, Axes and Member Type. 

 

The Find command allows you to find a particular Node, Frame or Shell number. 

Connectivity Issues lists all the frames with unsupported nodes and highlights it when selected.  

➢ Click the Members tab  

Analytical Model 

ribbon tabs 

Filter functions 
Load Cases 

Load 

Combinations 

X to close view 
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This is where you can show node labels, rigid diaphragms, element labels and beam loads. 

 

 
 
➢ Click Frame Loads icons to show loads calculated or decomposed on the beams (& then turn it off). 

This may include all the slab loads, brick wall loads, beam self-weight & other manual input loads.   

➢ Click on the Results tab 

 

➢ Click Displacement → The red lines shows the displacement (deflection) of the structure.  

By default, Auto Scale is activated.  You can deactivate this and then type in your own Scale  

➢ Click on the various directional displacement values by selecting x (horizontal plan), y (vertical plan), z 
(along the storey) & R (Resultant).    Rx,Ry, Rz is the rotation of joints in radians. 

➢ Click Animation to visualise the deformation of the structure 

➢ Switch off Displacements display and click on Diagrams button. 

➢ Click on Axial force N icon to display the Axial Force diagram (for G Load Case). 

 

➢ Experiment with the various effects of the diagrams 

  

Diagrams Legend 

N - Axial forces  

V2 – Major shear force of beams 

and walls.  Shear of column along 

dir 1 

V3 – Minor shear force of beams 

and walls. Shear of column along 

dir 2 

M2 – Minor moment of beams 

and walls. Moment of column 

along dir 1 

M3 – Major moment of beams 

and walls. Moment of column 

along dir 2 

T - Torsion 
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➢ Go to the Solid Model tab   

This allows the various effects such Axial Stress (kN/m2) to be color coded on the physical model 

 

 

➢ Close the Analytical Model view by clicking on the “x” sign next to the view name.  

It is essential that you interrogate the Analytical Model and check the validity of the model as that is the 

true analytical model from which the design forces will be based on.   
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28. Column & Wall Design 

➢ Go to Design tab → Column Section Design  

Since we have selected to run column reinforcement design as part of Building Analysis, all the columns 

and walls are already designed as indicated by green tick.  

 

If they are not designed, you can choose Column Design (Batch Mode) to design all columns at one go.  

➢ Go to the Reports tab → Choose Design Report   

The columns to be included in the report are marked by a tick in the Print column. Columns can be 

added or removed from the report by checking or unchecking the Print checkbox. Further, there are 

icons Mark All Columns and Remove Print Marks that can be applied to all columns.  

  

➢ To draw the column section detail, check “Include Column/Wall Sections in the Report”.  

You can also give the report a title.  
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➢ Pick OK to generate the report 

All reports can be exported as PDF, MS Word, image or webpage (html) format.  

  

➢ Exit & this report will automatically be saved & made available for compilation in Report Manager 

The Interactive Column Design allows you to examine & alter individual column design in more detail. 
 

➢ Double click on 1C1 in the list of columns in the Column Design screen 

 

If there are changes in assumption of this column, you can click Interactive Design button to re-perform 
the reinforcement design. 
 
➢ Click Cancel to exit the Interactive Column Design dialog and Close the Column Design screen   

Section Dimension shows the 

parameters of the column such as size, 

clear height & concrete cover 

Steel Bars shows the number and 

layout of the rebar. These can be 

changed.  

Load Combination table list down all 

the load combination. The most critical 

(governing) is highlighted in red. 

Required & Supplied As are calculated 

from the critical load combination. 

Slenderness tab shows the bracing 

assumption, calculated effective 

lengths & additional moments. 
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29. Beam Design 

➢ Go to Design tab → pick Storey Beams  

Since we have selected to run beam reinforcement design as part of Building Analysis, all the beams are 

already designed as indicated by green ticks.  

 

If they are not designed, you can choose Beam Design (Batch Mode) to design all beams at one go.  

The beams to be included in the report are marked by a tick in the Print column. Beams can be added or 

removed from the report by checking or unchecking the Print checkbox.   

➢ Choose Remove Print Marks to exclude all beams in the report 

➢ Check/tick the checkbox under Print for the first row beam axis A only  

 

➢ Choose Design Report 

 

 

The Beam Design Report is in rich text 

format.  

Choose the preferred Report Options to 

include the various force diagrams.  
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➢ Pick OK to generate the report 

 

➢ Exit & this report will automatically be saved & made available for compilation in Report Manager 

The Interactive Beam Design allows you to examine individual beam design in more detail 

➢ Double click on any of the beam axis in the list of beams in the Beam Design dialog 

 

Any figures in red indicate a failure to meet the design criteria and should be investigated. 

➢ Click on the Diagrams button to see the loading and design forces 

Reinforcement Data window shows the 

details of the beam design. 

Required As is shown in blue as is based on 

design envelope of all load combination.  

Extra As shows the additional or surplus 

area of steel based on selected steel. 

Rebars designed are shown in the various 

rows including shear links. These can be 

manually changed if desired. 

s-Bar-CL (Top)/(Bot) shows the clear 

spacing of the rebars at the outmost layer. 

Deflection Check shows the actual vs 

allowable span/effective depth. The 

modification factor is automatically 

applied. 
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Loads, Diagrams & Deflections 

❖ Display Detailed Values :  

• Checked : A tracing window will appear showing the exact values of the diagrams, eg. shear & 
moment, when the mouse cursor is placed at a particular location along the member.  

❖ Optimize Stations :  

• Unchecked : The diagrams are displayed using default maximum number of stations.  

• Checked : The number of stations will be reduced & optimized to maintain similar accuracy.  

❖ Diagrams :  

• L1/ L2 / L3 : Check to show external slab loads decomposed & user-defined loads on beams 

• N = Axial force ; T = Torsion 

• V2 = major shear ; M33 = major moment ; δ2 = major deflection 

• V3 = minor shear; M22 = minor moment ; δ3 = minor deflection 

❖ Deflection Display Types :  

Deflections are calculated along the member span for each load case and combination. Deflections can 

be displayed in three different ways: 

• Absolute: The absolute rotation and deflection values are used to display the deflected shape. 

• Normalized: The absolute shape is normalized with respect to the value calculated at the first 

point. 

• Relative: The deflected shape is normalized with respect to both start and end points. This is 

particularly useful in determining the deflection relative to both ends in serviceability checks. 

Loads, Diagrams 

& Deflections 

Visualization 

Tools 

Loads Cases & 

Combinations 

Display Detailed 

Values 
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Visualization Tools & Report 

❖ Horizontal Scale     → Increase or decrease horizontal scale of diagrams 

❖ Default Display Scale     → click to reset to default scale 

❖ Increase / decrease font size   

❖ Default Font Size   → Click to rest to default font size 

❖ Report    → Generate a report in tabular format with / without diagrams.   

 
➢ Exit the diagrams & Close the beam design dialog 

 

  Notes :  

The same beam diagrams can be assessed by :  

➢ Select a beam on plan view → Right-click → Analysis Results Diagram  
 

The same diagrams are used for columns & walls :  

➢ Select a column or wall on plan view → Right-click → Analysis Results Diagram  

➢ Alternatively, access the Interactive Column Design → pick ‘Diagrams’   
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30. Slab Analysis & Design 

For beam/slab models, slab reinforcement can be obtained by inserting slab strips in the X direction 

(horizontal plan) & Y direction (vertical plan). This process uses moment coefficient method from the 

tables in BS8110. This is independent of the general building analysis and can therefore be carried out 

before or after the general building analysis.  

To use the moment coefficient method, it is important to set all of the Slab Types correctly in accordance 

with the tables in BS8110. This can be done automatically in a batch mode by right clicking on the slab 

icon in the structure tree and choosing Set Slab Types Automatically.  

➢ From the Structure Tree double click on Storey: St01 to return to the 1st Storey plan view 

➢ Right click on Slab → Set Slab Types Automatically → Choose defaults options →  OK 

  

➢ Click OK to close the Messages dialog.  

➢ Go to Modelling tab & click on the Slab Strip    

The Slab Strip Properties will be displayed: 

• Slab Strip Type : Analytical Strip is used for design based on the Code 
Method. FE Strip is used for design based on FE Floor Analysis results. 
 

• When drawing the strips, it is essential that the correct At Start and At 
End conditions are specified. The three options being: 

 

  Slab - The strip starts or ends inside a slab. The bottom steel for 

the slab in question is not designed, but the span of the slab can be 

defined, and this value is used in determining the support steel. 
 

 Bob - The strip starts or ends beyond an edge beam or wall.  The 

support steel at the edge is bent down into the beam/wall. 
 

 Cantilever - The strip starts or ends beyond a cantilever slab. 
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➢ Set the Dir: to X 

➢ Set the No: to ‘1’ so that the strip label is X1 

➢ Set Type to Analytical Strip 

➢ Set the At Start condition to Bob 

➢ Set also the At End condition to Bob 

Position your cursor between Axis A and B, but to the left of Axis 1 (so that 

it is outside of the plan), then click to confirm the start of the strip 

➢ Hold down on CTRL key and then click the end of strip to the right of Axis 4 

 

➢ Draw another similar slab strip X2 to obtain the design for the slabs between Axis B-C/1-2 

➢ Draw similar slab strip X3 to obtain the design for the slabs between Axis B-C/3-4 

➢ Draw slab strip X4 to obtain the design for the slabs between Axis C-D/1-4 
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Now draw the vertical strips to design Y-direction rebar for the slabs.  

➢ Change the Dir to Y 

➢ Reset the No: to 1 again so that the strip label is Y1 

➢ Keep Type as Analytical Strip 

➢ Keep the At Start condition as Bob 

➢ Also keep the At End condition as Bob 

➢ Draw 4 nos. of vertical strip through all of the slabs 

The final layout of strips & slab reinforcements should be as shown below 

 

We can now re-check the strips as a batch and create a slab analysis & design report 

➢ Go to Design tab → choose Slab Analysis and Design → Design 
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The Slab Reinforcement Design report will be displayed. Options are available to configure and then 

print it. Any failure in the design will be highlighted in the Notifications pane at the left.  

➢ Review the report and then Exit 

 

 

31. Design Status 

The design status can be displayed graphically for in plan and/or 3D window 

➢ Click on the 3D view to make it active 

➢ Go to Review Tab → pick Design Status →  OK 
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32. Quantity Extraction Tables 

The concrete and Formwork quantity reports can be produced.  

➢ Go to Drawings & Reports tab → Pick Quantity Extraction Tables 

➢ Choose Concrete Quantity Extractions Table →  click Calculate 

This produces a concrete quantity report with member type and storey breakdown as shown below. 

  

➢ Click Report to produce a detail report 

33. Project Preferences 

The Project Preferences dialog allows you to enter the details of the project model.  

➢ Click on Settings Center → expand Project Preferences  

  

Header  - Enter the Consultant and Project details to be displayed in the header of all the reports.  

Statistics - Show graphical chart of key model information such as total number of members, members 

types, grids & storeys. In addition, it shows the number and types of foundation, beam & column end 

releases.  A text file can be created.   

Notes - Enter additional information on this model, such as revision changes etc.   

➢ Key in the various information in the Header tab as desired  
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34. Report Manager 

The Report Manager is the central report manager where all analysis and design reports can be 

accessed and managed.  

➢  Go to Drawings & Reports → choose Report Manager 

 

• Report Sets (left) :  This shows the constituent reports which will be complied & combined into a 
single final report 

• Reports Repository (middle) : These are all the individual reports that are generated and available 
to be included as a Report Set.  

• Notifications (right) : Important notes and warnings form the analysis of the model is shown for 
easy reference 

 
You can expand or collapse the main folder by clicking on topic icons.  To create a combine report : 

➢  Select New                 in the Report Sets tab and give the new report set a name 

➢  Select Add All Available  reports in the Reports window in include only reports that are available 
and generated in the report repository 
Alternatively, click and drag a report from the Reports Repository into the Report Sets pane 

➢  Choose to insert Table of Contents  and Summary Report  using icons just below the Report Sets 
tab.  

➢  Select View   to generate and view the report set 

Report Sets Reports Repository 
Notifications 
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Other available functions include loading of company logo (Load Logo ), inserting QR Code  & 

inserting external reports (New Report from File ). 
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35. Steel Model  

We will now start a new steel model. This section will cover steel members, trusses modelling, analysis 

& design. The below is the screenshot of the completed model which can also be found in the default 

Project Data folder. 

 

➢ Click New Project  and type the project name as shown using the ‘_’ character for spaces. 

 

➢ Select Singapore (EuroCode) template and then OK 

➢ Right click on Axes in the Structure Tree to expose the context menu 

➢ Select Orthogonal Axis Generator in the Modelling tab 
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➢ Pick the intersection of the major grid near the origin (5000,5000 coordinates) 

➢ In Orthogonal Axis Generator, change Dir-2 Axis Spacing to 5000*2 & click OK 

 

➢ Right click on Storeys in the Structure Tree and pick Add new Storey 

 

➢ Input Total No. of Storeys = 2 → OK 

➢ When prompted to confirm → Pick Yes → The plan view will now change focus to Storey 2 
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36. Steel Columns Creation 

➢ Click on Steel Column  in the Modelling tab. 

 

 

➢ Enter 8 nos of columns along Axis 1/A-D & 3/A-D 

 

➢ In Column Properties, change Len (Storey) to 2 

This means the column will span 2 storeys with effective length of 
2 storey height. Thus, we do not need to model any column in 
ST01. 

➢ Change the Angle of rotation to 90 degrees 

This will rotate the steel section 90 degrees on plan view.  

➢ Pick Section Manager icon  

This will launch the Section Manager dialog which allows us to 

pick a section profile.  

   Column End Condition : Columns ends are fixed by default. You 
can apply hinges to top and/or bottom by clicking successively on 
this icon.   

 

➢ In Section Manager dialog, pick Singapore   

This will access to Singapore Steel Profiles 
(Continental) 

➢ Pick UB 250x250x67 → Select 

➢ Pick OK to close the dialog 
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➢ Right click on Views in the Structure Tree and pick 3D Physical Model 

 

This will create a separate window showing the 3D view. 

➢ Go to View tab  → Tile Vertical 

This will arrange the 3D view and plan view in 2 windows.  

➢ Click on the Plan view to make it active (the active view border will be darker)  

➢ Double-click on Storey 1 in the Structure Tree to switch focus to Storey 1 

 

➢ Click on Steel Column icon  

➢ Change Len (Storey) to 1 in Column Properties 

This means the column will only span one storey.  
The columns with len = 2 are shown in grey because they were inserted in ST02.  

➢ Ensure the Angle of rotation is 90 degrees 

➢ Pick Section Manager icon  

➢ Ensure that UB 250x250x67 is selected 

➢ Insert 3 nos.  of column along GL2/B to D 

➢ Check the 3D view to ensure the columns were properly  
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37. Steel Columns Creation 

➢ Click on Steel Beam icon   

➢ Click on Section Manager   in Beam Properties  

 
➢ Click on the 3D view to make it active (the active view border will be darker) 

➢ Double-click on Storey 1 in the Structure Tree to switch focus to Storey 1.   

This is because we will now create beams in the 3D view. 

➢ In the 3D view, create 7 nos. of beams in the region bounded by GL B,D,2 & 3 (as shown below) 

 

➢ Go to the plan view of ST01 → Create 4 nos. of UB 200x150x30 secondary beams in the region 
bounded by GL B,D,2 & 3 (as shown below) 

➢ In Section Manager dialog, pick Singapore flag  

This will access to Singapore Steel Profiles 
(Continental) 

➢ Pick UB 250x125x25 → Select 

➢ Pick OK to close the dialog 

1 1 

1 

1 
1 

1 

1 

1 

1 

1 
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38. Steel Truss Creation 
We will now insert roof trusses. Trusses are best inserted using the 3D view.  

➢ Go to the 3D view → Double-click on ST02 in Structure Tree to make it active  

➢ Click on Truss button  

 

Use smart points @ 0.33 & 

0.67 to create these beams 

Tip :  Use smart points to create secondary beam. With beam properties out, place the mouse cursor at 

the edge of the primary beam (not center) & the smart points will appear at 0.25L, 0.33L, 0.5L & 0.75L. 

Use Beams Sections  in the Review tab to show beams of different sizes by color. Assign colors to 

members in Section Manager dialog → Material Color  

 

➢ Pick grid intersections A/1 to define the start 
of the truss 

A dynamic rubberband will appear with the 
default truss type if no truss is defined 
before. 

➢ Pick grid intersections A/3 to define the end 
of the truss  

After you pick the second point, the truss 

generator dialog will appear.  
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➢ In Geometry, pick Duo-Pitched truss → Change Truss Support Placement to Top Chord 

➢ Change Apex height to 1500mm, Left & Right Heel height to 800mm 

➢ Click on the Members tab  

 

➢ Change the truss member sections to the following by click on the section name:  

• Top & bottom chord = RHS 150x75x3   (Singapore) 

• Diagonal & Vertical = SHS 75x75x3    (Singapore)   

00 
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➢ Click OK to exit the Truss Generator dialog.  

The truss will be inserted. We now copy the truss to the rest of the columns.  

 

39. Purlins Creation 
We will now insert purlins on the roof trusses. Purlins are best inserted using the 3D view. 

➢ Click on Purlin toolbar button  

➢ Select the first truss @ GL A → Select the last truss @ GL D (Intermediate trusses will be 
automatically found) 

➢ On Purlin Dialog, you can specify the following: 

• Profile / Section of the for the purlin 

• Section Alignment: On the Section / Under the Section / Center  

• Generation Method : By Truss Joints / By Spacing  

  

➢ Select the truss → Right-click → Pick Copy 

➢ Select the basepoint @ intersection of A/1 

➢ Insert 3 nos. of similar trusses by clicking grid 
intersection B/1, C/1 & D/1 

➢  Press ESC or Right-Click to end the copy 
operation  
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➢ Choose section UPN100  (under Steel → European sections → UPN) 

 

➢ In the Sag Rods dialog → Insertion Method → Choose None to remove all sag rods 

 

➢ In the Loads dialog, you can apply loads to purlins :  

 

1 Select the Load Case to insert the loading 

2 Click Add Load  → Load Label L1 will be created 
        You can continue adding load as required, eg. the last end-span purlin will have lesser load 

3 Input the loads Coordinate System, Direction & Value 

4 Assign the loads by picking on Assigned Loads for All Purlins or invidividual Purlin (P1, P2, etc)  

5 Pick the Load Label to assign → OK 
        You may find it easier to first assign the most common load to all the purlins & then change  

specific purlins later.  

6 Check the diagram to ensure the loads are applied correctly (zoom in using mouse wheel) 

1 

2 

3 

4 
5 

6 
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40. Braces Creation 
We will now insert some bracings between steel columns. 

➢ Click on the Brace toolbar icon  

➢ Pick two adjacent columns at A/1 & B/1  → Brace Dialog will appear 

 

➢ In Brace dialog, you can specify the following: 

• Profile / Section of the for the purlin 

• Brace Type (Diagonal, X Brace, Y Brace or K Brace) 

• Alignment & Top/Bot Offsets 

➢ Accept all defaults & click OK 

➢ Insert the same bracing between columns A/3 & B/3 

➢ Check the braces are correctly inserted as shown below  

 

➢ Following the above steps, add a direction Z 
load of -2.00 kN/m for G Load Case 

➢ Assign it too all purlins  

➢ Check the right diagram to ensure the loads 
are applied correctly (item 6 above) 

➢  OK to close the purlin dialog 

Purlins will be inserted on top of all the trusses. 
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➢ Insert new brace between columns C/3 & D/3 

 
 

➢ Change Brace Type to Diagonal 

➢ Input Bot Let Vertical Offset = 3000 mm 

➢ Tick Apply Bottom To Analysis 

This will ensure the analysis frame will accurately consider this offset.  

➢ Click OK → Diagonal Brace will be inserted 

➢ Insert another new brace between same columns C/3 & D/3  
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➢ Ensure Brace Type = Diagonal 

➢ Tick Invert → this will invert the diagonal 

➢ Input Top Let Vertical Offset = 3000 mm 

➢ Tick Apply Top To Analysis 

This will ensure the analysis frame will accurately consider this offset.  

➢ Set all Bot Offsets to 0 mm 

➢ Click OK → A new diagonal brace will be inserted 

➢ Check the braces are correctly created in the 3D view as below 

 

  

Braces can also be inserted between beams. 
Create 3 nos of horizontal brace connecting 
the beams in ST01 as shown in the left figure: 

➢ Pick 2 adjacent beams 

➢ In the Brace dialog, pick Brace Type = 
Diagonal 

➢ Tick / Untick Invert as required 

➢ Ensure all Top & Bottom Offsets = 0  

➢ Click OK 

➢ Check the brace is correctly created in the 
3D view.   

 

Model 3 braces 
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41. Girts Creation 
We will now insert some girts between steel columns. 

➢ Click on Girt toolbar button  

➢ Select the first column at grid A/1 → Select the last column at grid C/1. 

Intermediate columns will be automatically found. 

➢ In the Geometry dialog, you can specify the following:  

• Profile / Section of the girt 

• Section Alignment : Under The Section / On The Section 

• Spacing, Delete Bottom / Top Member, Left / Right Cantilever, Offsets 

 
➢ Ensure Profile is UPN100 (under Steel → European sections → UPN) 

➢ Ensure Section Alignment is Under The Section  

➢ Tick “Delete Bottom Member” so that bottommost girt is removed.  

In the Sag Rods dialog, you can specify the configuration of the sag rods.  For simplicity, for this 
model we will not insert the sag rods.  

➢ In the Sag Rods dialog → Insertion Method → Choose None to remove all sag rods 

 

➢ Click OK and the girts will be inserted.  

➢ Insert similar girts between columns A/3 & C/3 but Section Alignment = On the Section 
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➢ Check the girts are inserted correctly at both sides of the building as shown below  

 

42. Column Splice Creation 

 

 

  

➢ Select the corner column at GL D/3 

➢ Right-click → Define Splice 

➢ Pick Add New Splice in Splice Location Definitions  

➢ In Member Splice Definition choose :  

• Reference Strorey = 1 

• Splice Distance (from floor level) = 800 mm 

• Splice width = 500mm 

➢ Click OK  

The splice will be created & listed in Splice Location 
Definitions.  

➢ Close Splice dialog 
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43. Building Analysis 

➢ Go to Analysis tab  → Building Analysis → Pre-Analysis tab 

➢ Pick Edit Materials → Change the steel grade of all member to S355 

   
 

❖ The global materials grade of the truss, purlins, girts & brace members are shown & can be changed.   
❖ Individual member material can also be changed in their respective Section Manager dialog by 

selecting the member → Right-click → Edit Section / Material.  

We will now auto-generate the load cases and load combination.  

➢ Pick Loading Combination to access the Load Combination Editor 

 

➢ Pick Loading Generator → Pick the options as shown below → click OK 

  

  

 

 

 

 

 

All the load cases and combination will be generated automatically.  

➢ Go to Analysis tab → Tick Building Analysis → Start 

➢ In Batch Design option, choose not the design any members → click Building Analysis 

Once analysis is completed, the Analytical Model view will open automatically.   

➢ Review the results to your satisfaction as outlined in the previous section 
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44. Steel Design 

Steel member design commands can be accessed via the Design tab  

 

➢ Go to Design tab →  Design All  → Choose Steel Member Design Check → OK   

 

 

 

 

➢ Pick steel  Column Design  

 

➢ Double-click on any column to review the detail design checks 

Notes:  

❖ If the model is large, it is recommended to perform design check by member types separately. 

❖ To check the design of a particular member, select the steel member icons in the steel group.  
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➢ Click on the triangle  next to the title check to drill down to more details 

➢ Check Design → Re-check the design of this column 

➢ Change Section → Allow you to pick another section → New section will be checked automatically for 
pass / fail. 

➢ Design Report → Prepare the design report 

➢ Show Design Stations → List out all the design forces of all load combinations 

➢ Show Diagrams → Show design force diagrams for load cases, load combinations & envelope 

➢ Parameters Tab →  Input Braced length, Buckling Length Coefficient, Lateral Torsional Buckling length 
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45. Design Status & Design  

We can view Steel Design Status and Steel Design Utilization to quickly review pass / failure status & 

design efficiency.  

The design status can be displayed graphically for in plan and/or 3D window 

➢ Click on the 3D view to make it active 

➢ Go to Review Tab → pick Design Status →  OK 

 

➢ Click Visual Interrogation  & choose Steel Design Utilization Ratios →  OK  
 

 

 

You may want to check the design of the rest of the steel members such as steel beams & truss.  The 

design interface is similar to that of the column design.  
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46. Closing Summary 

Congratulations! You have created your first model in ProtaStructure.  

In this Quick Start Guide, we have created, analyzed and designed a simple small model. This will give you 

the necessary knowledge to proceed to a real project.  

For more help and guidance, please refer to ProtaStructure help reference accessible from Help menu. 

We recommend you read the What’s New document for details of new features & enhancements. 

Alternatively, you can attend our training courses to obtain a more in-depth knowledge of the usage of 

the software.  Please visit our website www.protasoftware.com for more information.  

The detail drawings of all the members and the general arrangement drawings can be automatically 

produced and managed in ProtaDetails (concrete) & ProtaSteel (steel).  We recommend you proceed to 

read the ProtaDetails & ProtaSteel Quick Start Guide as the next step.  

http://www.protasoftware.com/

