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1. Introduction 

Thank you for choosing ProtaSteel – Steel detailing & connection creation module of the ProtaStructure 

suite.  The main steel model must be created in ProtaStructure. The model can be exported & opened in 

ProtaSteel seamlessly. In ProtaSteel, you can :  

• Model ancillary/secondary steel members such as roof purlins, girts, sag rods, staircase, etc. 

• Adjust members to final positions for accurate detailing  

• Create and design steel connections 

• Create any steel connections manually, save them macro library and re-use them at similar 

nodes. 

• Produce engineering drawings of the steel structure and connections 

• Sharing the 3D model created with other BIM platform such as Tekla Structures.  

 

 

 

 

 

 

 

 

 

 

Before you proceed, it is highly recommended you go through ProtaStructure Quick Start Guide as 

knowledge of the fundamentals of ProtaStructure is required. 

This Quick Start Guide aims to get you up and running quickly. You should be able to learn the 

fundamentals of ProtaSteel in approximately 2 hours by following this simple guide.  

2. Exporting model to ProtaSteel 

A sample steel model is already created & installed in default installation folder of ProtaStructure. We 

will now open the model, run analysis & export to ProtaSteel :  

➢ Start ProtaStructure and the Open Project dialog will appear.  

➢ Select & open project “Quick_Start Steel_Complete” 

➢ Go to Analysis → Building Analysis 

➢ Go to Analysis tab →  Tick Building Analysis → Start  

➢ Close the Building Analysis menu 

➢ Go to Steel Design (top menu) → Load ProtaSteel 

ProtaSteel will start and load the project model.  ProtaSteel model is created in subfolder “ProtaSteel” in 

the project folder.  
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3. User Interface 

The various components of ProtaSteel user interface are as shown below:  

 

 

 

  

 
 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

Default views are created under the Views folder in the Explorer pane in the left pane. By the default the 
views created are 3D view & plan view of each stories. Double-click on the desired view to access it.  

The graphical editor supports multiple windows; you can open as many windows as you desire. 

Modelling can be done both on the plan view as well as the 3D View.  

Frame Creation Tool    

In ProtaSteel, you can only create joist, purlin, girt, stair member, eaves beam & sag rods.  Main 

members such as beam, column & brace must be created in ProtaStructure.   

Manual Detailing Tool   

These are secondary detailing tools such as weld creation, section plate creation, element cutting & 

trimming & profile adjustments. 

Connections Macros   

These are all the steel connections creation tools, eg. gusset plate, fin plate, haunch, splice etc.  

 

  

Tip : If you hover the mouse cursor over any icons, a tooltip will appear with detail explanation on how 

to use it. By right-clicking on the macro icon, you can set the default parameters that will be used each 

time it is run. 

 

File tools 

Project 

Explore
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Model View 

Frame tools Manual Detailing  Connection Macros Secondary Macros 

Visibility Filters  

Selectability Filters 

Utilities 

View Mode 

View Creation 

Point tools 

Copy, Mirror 

& Rotate 

Reference Object  

Views Tool 
Bar 

Bottom Status Bar Working Units 
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4. Zoom & Pan Methods 

The view manipulation is similar to ProtaStructure.  You will find it easiest to use the mouse wheel to: 

Zoom in  – scroll your mouse wheel up 

Zoom out  – scroll mouse wheel down 

Pan (move)  – hold down the middle mouse wheel and drag  

Rotate   –  Right click & drag  

The following keyboard shortcut keys are useful : 

Zoom All   – Home key    → Zoom so that all content is visible in the viewport 

Origin of Interest   – F9 key           → Select an origin of interest by clicking on any node or any           

object (such as bolt or plate). The model will then rotate around the selected 

point.  

5. Selection Methods 

➢ Left-click on the entity to select the entity.   

➢ To select multiple entities, hold down CTRL key while you pick them 

You can drag with the mouse to access further selection options: 

➢ Drag from left to right to create a rectangular box. When you release the mouse button, all 
entities completely contained within the box will be selected 

➢ Drag from right to left similarly and all the entities that are contained within the box and which 
cross it boundaries will be selected 

➢ To deselect all entities, left-click on any empty space anywhere in the viewport.  

6. Views & View Settings 

By default, the 3D view general is created & shown when you open the project. The plan of each storey 

is also created.  

The views are shown under the View folder in the left Explorer pane. 

➢ Double-click on the desired view in the left-hand Explorer pane to open it. 

You can open as many views as you like.  

 

 
 

➢ Double-click on Views will open the View Manager where you can 

quickly : 

• Open a view 

• Close a view 

• Delete a View 

• Display the View Properties 
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If you have multiple views opened, you can manage them, e.g, fit them into the screen by going to 

Windows (top menu) → Tile Horizontal / Tile Vertical / Cascade. 

You can change the Object Draw Mode by going to Views (top menu) → Object Draw Modes   

The shortcut icon can also be found on the right-

hand most vertical toolbars  

➢ Press Alt + D continuously will cycle through 

the draw modes.  

7. Creating new Views 

New views can be created by going to Views → Create View 

 

Let us create a new sectional view along grid 3 :  

➢ Go to Views → Create Views → By Two Points  

➢ Click two points to define a plane →  the view will be created as shown below 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

2 

1 

Note : The sectional view is actually created from the same 3D model but viewed from a different camera 

angle or orientation.  Changes made to the active view are automatically reflected in all other views.  The 

extent, boundary and objects to display can be set via View Properties. 

Tip: A white line arrow will appear once 

the mouse cursor hovers on 2nd point.  

This white line indicates the direction of 

viewing. In this case, the above view is 

looking into the building. 
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To access the View Properties: 

➢ Double-click anywhere on the new view → The View Properties will appear 

 
➢ Give the view a new name “Axis 3” 

➢ Change the Up(+) & Down (-ve) to 1000mm & -1000mm respectively  

This means that the view will only show elements 1m into & out of the plane. This will make the 

view less cluttered as elements along other grids will be hidden. If zero values are entered, then 

it will be unlimited.  

• Up-Down Method : 

- Partial : Any element that exists partially within the set extents will be shown 
- Full : Only elements that exist fully within the set extents will be shown 

➢ Click OK to close the dialog & view will be updated.  

Any sectional view is inherently a 3D view; hence you can still rotate the view. 

➢ Right-click & drag to rotate the Axis 3 view  

Notice that only members within the 1 m extent is shown. 

➢ Go to View Properties again 

➢ Change the Up-Down method in View properties to FULL → Apply 

Notice all the beams out of the plane of Axis 3 will hidden.  

➢ Press F4 to restore lookup (i.e. restore to original viewing direction) 

 

 

 

8. Visibility & Selectability 

You can control what objects are visible and selectable by assessing the Drawing Settings dialog :   

➢ Pick Drawing Settings in View Properties dialog   

 

Important : You must give the view a new name and check / tick “Save” to ensure the view is saved. 

Only saved views can be used to generate drawings in the drawing module.  
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9. Macros  

Most of the icons in ProtaSteel such as purlins, sag rods, girts & connections are called “macros”. A 

macro is generally defined as a shortcut tool that specifies how a certain input sequence will result in a 

desired output according to a defined procedure. The instruction on how to use each macro is shown in 

the tooltip if you hover the mouse cursor over the icon.  

• Before creating the element using the macro, you can set the macro settings, e.g. member profile, 

plate offsets, bolts, etc. by right-clicking on the macro icon which will bring up the Macro dialog.  

• Once a macro is clicked, the mouse cursor will change to the hand icon  meaning that it is waiting 

for object(s) selection or crosshair + meaning it is waiting for point selection. Perform the required 

action(s) to get the desired result, as stated in the tooltip.  

• The macro will remain activated; you can continue use the macro without having to click on the 

macro icon again.  

• Once you have finished, you must press ESC to cancel & stop the macro.  The mouse cursor will 

change back to default arrow   (selection mode).  

• After creating the elements in a group such as the purlins, each element will have its individual 

properties; which can be changed by double-clicking on it → this will bring up the Element dialog. 

• However, all the elements are still associated with the macro & can be changed in a group.  

This can be done by selecting the macro sign  & then press ENTER will bring up the macro dialog. 

After making the changes, clicking Apply will apply to all the elements associated with the macro. 

Clicking Get will set it default for this macro for this and future projects.    

• If you have problems selecting the macro sign, you can select any element or component of the 

macro (e.g. a plate of a connection) then press “M” → this will select the macro → followed by 

ENTER which will expose the Macro dialog.  

• You can select all the elements associated with the macro by selecting the macro sign or an element 

of the macro → press “CTRL + M”.  

• You can also delete all the elements & components of a macro by selecting the macro sign & then 

press DELETE. 

• It is highly recommended you review settings of the macro before executing it.  

➢ Alternatively, click on the 
Visibility/Selectability icon “…”           
in the middle toolbar   

➢ Turn off the Grids & Points  

➢ Apply & see effect 

➢ Go back & turn them back on  

You can Save these different settings as 
different name to quickly re-use them. 

The shortcuts to visibility / selectability 
objects are in the middle toolbar. 
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• You can reload/clear the changes in macro default setting by going to Tools (top menu) → Macro 

Defaults → Select macro → Reload/Clear Selected Macro Defaults 
 

    
 

10. Insert Sag rods  

In ProtaStructure, the main steel members are modelled & designed; usually omitting the minor or non-

structural members to keep the model size manageable & efficient.  After the model is transferred to 

ProtaSteel, you might then want to add ancillary steel members such as sag rods.  

We will insert some sag rods between the girts along axis 3 : 

➢ Double-click on 3D View in the Explorer pane to go to the default 3D view 

➢ Right-click on Sag Rod icon  → This will expose the Sag Rod Macro Dialog.  

➢ Key in the offsets 50mm & Number of Intervals = 3  (as shown below) 
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➢ Untick the diagonal so that it will not be included 

➢ Choose the section profile by clicking on “…” (as shown above) → Pick Round Bar D10 → Select 

➢ Pick Get to make these input the default from now on → OK 

 

Each sag rod has its individual properties & can be selected, deleted or changed.  

➢ Double-clicking it will reveal its properties.  

All the sag rods are represented by the macro sign  They can be changed in a group by selecting this 
macro sign → press “Enter” as stated previously.  

➢ Left-click on the Sag Rod icon  

Notice the cursor turn to a hand icon  meaning that it 
is waiting for required element selection action(s).  

➢ 1 – Left-click on bottommost girt 

➢ 2 – Left-click on topmost girt 

➢ Right-click → Sag Rods will be inserted  

➢ Insert sag rods for another panel between grid B, C & D 
using the same steps above, i.e. start by picking the 
bottommost girt (no need to pick the sag rod icon 
again) 

➢ Once complete, press ESC to cancel the Sag Rod macro 
action.  

Notice the cursor changes back to default arrow .   

 

 

1 

2 

Macro Sign 
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You can use Sag Rod Connection or Sag Rod Holes macros to create connections to sag rods and 

girts/purlins.  

11. Adjustment of members by creating points  

In ProtaSteel, you might also want to adjust the position of members that are not exactly at the correct 

position, i.e. fine-tuning of final member positions for detailing purposes.  

In ProtaStructure, all the braces inserted will join at the top of beams instead at the middle (centroid) of 

the beam. This is because the analytical position of any beam in elevation is at the top of the beam.  

➢ Double-click on previously created Axis 3 view in the Explorer pane  

➢ Zoom in to the location of the diagonal braces between grid C & D 

 

 

1 

2 

New Point 

➢ Press Alt + D until you see the outline of 
members only (wireframe mode) 

➢ Click “Create Dividing Points” icon  at 
the right-hand tool bar 

➢ 1 – Click top point of the beam   

➢ 2 - Click bottom point of the beam  

A new point “+” is created as shown in the 
left figure.   

➢ Press ESC to stop the function 
 

As you can see, the diagonal bracings are connected to the 

top of the beam. It is more accurate for the bracings to join 

at the middle of the beam.   

To do that, we must create a point (or node) in the middle 

of the beam. 

With the point created, we can then move the ends of the 

bracing to this point.  

TIP : Press Alt + D continuously will cycle through the 

draw modes. 
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12. Adjustment of members orientation & coordinates 

All member position & orientation can also be changed without creating new points. We will make such 

minor adjustments to some of the floor braces:  

➢ Double-click on Storey 1 view to open that view 

➢ Right-click & drag to rotate it a 3D view 

➢ Zoom to the joint GL 2/B-C where the secondary, main beam & 2 horizontal “L” brace meet  

➢ Press F9 & click on the joint to set it as point of interest so that rotation is about this point 

 

2 

3 

1 

Before 

After 

➢ Click Adjust Profile Manually icon  in 
the top menu toolbars 

➢ 1 – Select the diagonal top bracing  

➢ 2 - Click on existing end point 

➢ 3 - Click on the new point 

The brace end will be shifted to the new 

point. 

 

➢ Repeat the above Step 1 to 3 for the other 
bottom diagonal brace. 

The final positions of the diagonal braces are 
as shown in the left figure. 

➢ Double-click on PS View 1 in the Explorer 
pane to go to the 3D view. 

➢ Zoom in the same location & check the 
diagonal braces final positions to ensure 
they are correct. 
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Notice L braces orientation is not symmetrical with the other. We will rotate the brace so that flange of 

the brace is aligned with the flange of the beam. 

 

There is still a problem in the vertical position of the brace as it is too close to the top of the beams. 

Usually, braces are connected to the middle of the beam so transfer of force is to the centroid of the 

members and there will less clashes in the connection. 

   

➢ Select the brace  

➢ Press Ctrl + Q to rotate it until the correct 
orientation is achieved as shown in the left figure 

➢ Repeat for the other brace 

The braces are coming in too close to the secondary 

beam. We can shift it slightly away. 

➢ Press Ctrl + W to offset the brace horizontally until it 
is farthest away from the secondary beam 

➢ Repeat for the other brace  

➢ Double-click on the right L brace  

Profile Properties dialog allows you to change :  

• Profile /Section type by picking “…” 

• Alignment (Out of Plane, In-plane, Rotation) 

• Offsets Start & End  

• Draw Frame Coordinate System 

➢ Change Frame Coordinate System to For Analysis & design → 
Apply 

Notice 3 arrows showing local axis appear at the frame end. Red 

arrow = x-axis; Green arrow is y-axis; Blue arrow is z-axis. 

If the axes is not visible, please ALT+D to change to Wireframe 

➢ Enter z Start & End Offset to 100 mm → Apply 

➢ Check the 3D view to ensure brace is moved down 

➢ Repeat for the other brace (-100mm) → OK to exit 

 

Shift away 

F9 & click here 

Shift away 
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Minor shift in the vertical alignment can be done by pressing Ctrl + W. However, if you try this you will 

find that the offsets are too small. Further detail adjustment can be done by exposing the Profile 

properties.  

Preserve constructive changes during model re-import 

In the General Definitions tab, the option “Preserve constructive changes during model re-import” is 

by default checked.  

 

13. Steel Connections 

Once we have finalized position of the steel members, we can start “connecting” the steel members, i.e. 

create connections.  Connections can be created in two ways: 

1. Automatically using the connection macros 

2. Manually by using the Plates, Bolts, Welds & Cuts commands 

The automatic connection macros will automatically create the appropriate connection. If there are 

internal forces transferred from ProtaStructure, they will be automatically taken in the connection design.  

Detail design check is performed for the following connections in accordance to EuroCode 3, AISC (LRFD), 

AISC (ASD), BS5950  :  

• Beam to Beam Connections:  End Plate, Stiffened End Plate, Fin Plate 

• Beam to Column Connections:  End Plate, Stiffened End Plate, Fin Plate  

• Beam to Beam End Plate Connection 

• Haunch Connection 

• Direct Welding Connection 

• Simple Base Plate Connection 

• Flange Plate Moment Connection  

• Extended End Plate Connection 

• Bolted Gusset Plate Connection  

• Corner Bolted Gusset Plate Connection  

• Welded Gusset Plate Connection  

This will preserve the member offset adjustents (e.g. 

member position & orietation)  made in ProtaSteel during 

subsequent re-import from ProtaStructure. During the 

next import, the import log file will show a warning : 

Imported Frame's ID in *.cdf file[xxx]: Frame is locked. Therefore, 

in plane, out of plane and start/end offsets were not applied. 

Ignore the above warning if you want the member offsets 

to be retained in ProtaSteel.  

If this option is unticked (disabled), offsets done in 

ProtaSteel will be discarded during the next re-import 

from ProtaStructure.  
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• Corner Welded Gusset Plate Connection 

• Truss Seating Connection 

For the above connections, detail design report can be produced which includes both geometric checks 

and capacity checks. In addition, intermediate calculations, references to the appropriate clauses of the 

design code, and corresponding equation are shown for easy checking.   

Basic material capacity checks are performed for the following for the standard connections: 

• All Bolted & welded gusset plate 

• Purlin & Girt  

• Splice connections 

• Flange Plate Moment connections 

For the above connections, the following basic material strength checks are performed: 

• Plate bearing check  

• Bolt shear & Bolt tension check  

• Weld stress check   

• Plate tension & plate bending check  

The above are basic checks and not clause by clause code specific checks. No design report can be 

produced.   You are advised to perform your own additional calculation checks if required.   

The force used in the automatic connections are obtained from the higher of the two values: 

1. The critical design forces of the connected members imported from ProtaStructure 

2. User-defined Capacity Ratio in the Profile Properties > Detailing Definitions.  

Capacity Ratio = Design Force / Maximum Member Capacity (equal less than 1) 

This is to prevent unrealistic design when the design forces are very small or negligible.  

For example, in determination of the number of bolts for a simple beam to beam fin plate:  

• The critical design shear imported from ProtaStructure is 30 kN.  This requires 1 number of bolts.  

• The Shear Capacity Ratio of the beam is set to 0.3.  This works out to be 100 kN which requires 2 

number of bolts. 

• The final design shear force used is 100kN and hence 2 number of bolts is chosen.  

There is no check or design at all for the following connections: Apex Haunch Connection, Direct Welding 

Connection, Base Plate (Except Simple Base Plate), Eaves Beam Connection, Profile Fit Connection, Sag 

Rod Connection & Sag Rod Holes, Welded Pipe Connection, Beam to Wall Connection, Apex Truss Gusset 

Connection & Truss End Plate With Gusset Plate Connection. 

Before performing connection design, we should customize the default design parameter:  

➢ Go to File → Settings → Project Preferences  

➢ Ensure that Design Standards for Connections is set to EC3 

➢ General Overdesign Factor for Connections = 1  

This means that the connections will generally design for 100% of the member capacity. This setting 
works in combination with capacity ratios of the connecting members (changed via Profile dialog → 
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Detailing Definitions). The Capacity Ratio is automatically calculated = Design force divided by the 
actual capacity of the member. Hence, Capacity Ratio x Overdesign Factor = Final Factor.  

➢ For example, under Steel Detailing ensure the following 

• Plates : Preferred Plate Material = S355 

• Bolts : Preferred Bolt Material = Class 8.8 

• General Weld : Preferred Weld Material = Class 42 

➢ Apply → OK  

14. Base Plate Connection                                         

In order to create a base plate connection to columns, we can use the base plate macros. There are two 

base plate macros in ProtaSteel for creating the base plate connection.  

• Base Plate Connection (without design) 

• Simple Base Plate Connection (with design) 

In ProtaSteel, restraints are indicated with the ball and cubic objects in green. If the connection is 

defined as moment connection in ProtaStructure, it is shown with ball+cubic object. If the connection is 

designed as a pinned connection, it is shown with only a ball object.

 

Using with “Base Plate (without design) Macro”, all types are created.   

 

 

 

     

 

 

 

 

 

➢ Select the “Base Plate Connection Macro” 

➢ Select the column.   

➢ The connection is created under of column.  
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Pinned connections can be created by the “Simple Base Plate Macro”. This macro can design and create 

calculation report. All parameters can be changed in macro properties.   

 

    

 

 

 

 

 

 

 

15. Fin Plate Connection    

We will create a fin plate connection between the adjacent main & primary beam joint.  

➢ Right-click of the Fin Connection macro   

The Fin Plate Macro dialog will appear which allows you to customize the connections. 

➢ Go to the Design Tab & ensure the following:  

• Design Standard = EC3 

Note : Slip Coefficient is blank & hence will follow the Project Preferences → Bolts settings 

➢ Pick Get to make it default settings for this connection type for all projects from now on.  

➢ Zoom GL 2/B-C to the previous joint where the secondary, main beam & 2 “L” brace meet.  

 
 
Important Note : The capacity ratio works in combination with General Overdesign factor for 
Connections (in Project Preference). Hence, Capacity Ratio x Overdesign Factor = Final Factor. 

 

➢ Double-click on the secondary beam  

➢ In Profile Properties, go to Detailing 
Definitions tab 

The Capacity Ratio defaults to 0.3 for this beam.  

This will be used to calculate the minimum 
design shear used for the connection.  

The Analysis tab shows the geometric properties 
of the member.  

➢ Apply → OK  

1 

➢ Select the “Simple Base Plate Connection Macro” 

➢ Select the column.   

➢ The connection is created under of column.  
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We will now insert a fin plate connection at the primary & 
secondary beam joint. 

➢ Pick Fin Plate Connection   

➢ 1 – Pick the main beam 

➢ 2 – Pick the secondary beam  

➢ Right-click 3 times  

A fin plate connection will be created. 
 

1 

2 

We will now insert corner bolted gusset plate for the L 
brace that uses the beam fin plate as boundary.  

➢ Pick Corner Bolted Gusset Plate Connection  

➢ 1 – Pick the main beam 

➢ 2 – Pick the brace  

➢ 3 – Pick the blue fin plate  

The connection is created. Repeat the same for the other 
brace. 
 

1 

2 

3 

Macro Sign 

Tip :  

❖ The connection consists of plates, bolts & welds. Each element has its individual properties & 
can be selected, deleted or changed. Double-clicking it will reveal the element properties.  

❖ The entire connection is represented by the macro sign . Double-clicking on it will bring out 
the Macro dialog box where the entire connection can be changed.  

❖ It is highly recommended you review settings of the connection macro before executing it.  
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16. Beam to Beam End Plate Connection   

We will create Beam to Beam End Plate Connection between the main & secondary beam. 

➢ Zoom to the adjacent joint GL 2/B-C where the secondary & main beam meet  

 

17. Haunch Connection   

We will create a haunch connection between the column and beam at GL B/2. 
 

 

 

 

 

  

We will now insert the haunch connection. 

➢ Pick Haunch Connection   

➢ 1 – Pick the column 

➢ 2 – Pick the beam 

The connection is created. The blue transparent box is the 
cut object. This can be turn on/off in Visibility dialog.  

➢ Repeat the same for the other end of beam to column 
joint 

 

1 

2 

➢ Pick Stiffened End Plate Connection  

➢ 1 – Pick the main beam 

➢ 2 – Pick the secondary beam  

The connection is created. This maybe a more 
preferable in terms of load transfer & ease of 
assembly & construction.  
 

➢ Right click on the Haunch Connection 

icon  

➢ In Haunch Macro, go to Figure 2 tab 

➢ Ensure that all the end plates A,B,C & D is 
checked 

➢ Apply → OK to exit 
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18. Stiffened End Plate Connection  

We will create a stiffened end plate connection at the column beam joint at grid C/3. 

 

 

19. Corner Bolted Gusset Plate Connection   

We will connect the diagonal brace at the same joint. There is problem because the existing connection 

is getting in the way, i.e. we cannot connect the diagonal brace directly to the column due to the top 

stiffener plate.  This can be solved by using the Corner Bolted Gusset Plate Connection. 

 

  

➢ Double-click on Axis 3 view to open view 

➢ Zoom in the joint where the column, beam & 2 
diagonal braces meet at grid C/3  

➢ Press F9 on this joint to set the point of interest 

➢ Rotate the view slightly about this joint 

➢ Pick Stiffened end plate connection icon  

➢ 1 – Pick the column 

➢ 2 – Pick the beam  

➢ Right-click → Connection is created 

 

 

1 

2 

➢ Rotate the view around so the connection is not 
obstructed by the girt 

➢ Pick Corner Bolted Gusset Plate Connection  

➢ 1 – Pick the column  

➢ 2 – Pick the top brace  

➢ 3 – Pick top orange plate  

A logical & constructible gusset plate connection will 
be created joining the top plate of the previous 
connection.  
 

1 
2 

3 
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20. Bolted Gusset Plate Connection   

For the bottom brace, it is a slightly different situation as the brace should connect to the bottom of the 

beam flange directly. Hence, we should use the Bolted Gusset Plate Connection.  

 

Let’s push back & shorten the green gusset plate so that it ends exactly at the beam end for 

constructability.  

➢ Select connection macro by selecting the macro sign  → Press Enter  

➢ Alternatively select the gusset plate > press “M” > Press Enter (wait for the macro dialog) 

 

➢ Enter 25mm in the above plate set-back value →  Apply 

You can see the plate is shortened and the stiffener plate is added.  

➢ Rotate the view around the connection so you are 
viewing the bottom of the brace 

➢ Pick Bolted Gusset Plate Connection  

➢ 1 – Pick the beam 

➢ 2 – Pick the bottom brace  

➢ Right-click 

A logical & constructible gusset plate connection will be 
created joining the bottom flange of the beam.  

➢ Press ESC to cancel the macro 

1 

2 
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21. Splice Connection   

Splice connection must first be inserted in a column or beam in ProtaStructure.  For this model a splice 

connection has been inserted at the corner column at GL D/3 at 800mm above the 1st Storey.  

 

• The green color bolts are called Workshop Bolt. These bolts are pre-installed in workshop before 

being brought to site.   

• The orange bolts represent the bolts to be assemble on site.   

The above setting & other bolt parameters can be viewed & changed in the Bolt Group property :  

➢ Double-click on any of the bolt →  Bolt Group property will appear 

➢ Go to Settings 2 tab →  Assembly Location →  two choices are in the dropdown menu : 

• Workshop 

• Site 
 

  

• This is more constructible because the 
gusset plate & stiffenner can be assembled 
off-site as part of the beam assembly.  

• The previous stiffened end plates will be 
part of the column assembly.  

• Hence, when the column & beam are 
brought to site, it’s easy & quick to install & 
“connect” them together.    

 

➢ Zoom the corner column at GL D/3, slightly above 
Storey 1 

Notice the column is broken into 2 separate elements as a 
column splice was created in ProtaStructure. 

➢ Pick Splice Connection   

➢ 1 – Pick the top column 

➢ 2 – Pick the bottom column 

The column splice connection is added.   

➢ Press ESC to cancel the macro 

1 

2 
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22. Truss End Plate With Gusset Plate 

Truss End Plate with Gusset Plate connection macro creates a connection between a column and 

secondary trusses with gusset & end plates.  Let us focus on the truss by creating a new view along axis A. 

➢ Go to Views → Create Views → By Two Points  

➢ Click two points along Axis A →  the view will be created as shown below 

 
 

➢ Double-click anywhere on the new view → The View Properties will appear 

 

  
 

➢ Give the view a new name “Axis A” 

➢ Change the Up-Down method in View properties to FULL → Apply 

➢ Zoom to the left side of the truss (Axis A/1) 

➢ Press F9 & click on the top of the column node to set it as point of interest & rotation 

 

 

1 

2 
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23. Welded Pipe Connection (info only) 

Welded pipe connection macro can be used to connect tube profiles.  

 

24. Beam to (RC) Wall/Column Connection 

This connection macro creates & designs an embedded steel connection between a steel beam and a 

concrete wall or column. The steel member must be perpendicular to the reinforced concrete surface. It 

is important to have enough space on the concrete surface, else the macro will not work.    

 

➢ Pick Truss End Plate with Gusset Plate     

➢ 1 – Pick the main column 

➢ 2 – Pick the top chord 

➢ 3 – Pick the diagonal 

➢ Right-click to end & create the connection 

➢ 4 – Pick the main column 

➢ 5 – Pick the bottom chord 

➢ Right-click to end & create the connection 

The two connections are created as shown. 

1 
2 

3 

4 
5 

➢ Click on Welded Pipe Profile macro    

➢ 1 – Select the main top member   

➢ 2 + 3 – Select the secondary profile, e.g. diagonal 

and vertical element.  

➢ Right-click to end & create the connection 

Profiles are automatically cut & trimmed around the 
joint.  

 

2 

1 

3 

2 
1 

➢ Click on Beam to Wall Connection macro    

➢ 1 – Select the concrete wall or column   

➢ 2 Select the steel beam 

➢ Right-click to end & create the connection 
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25. Intelliconnect For Fully Automated Steel Connection Design  

IntelliConnect automatically assesses joints to your preferences, batch creates and designs steel 

connections. It covers a wide range of simple, moment, splice and weld connections. It considers 

constructability by intelligently arranging and configuring all the components of the connections without 

user intervention. This results in huge improvement in productivity as it minimizes time required to 

manually create & correct these connections.  

 

Why use IntelliConnect?  

Advanced steel detailing software typically create connections automatically between two elements by 

applying certain rules, i.e. “Rule based joints”. These rules normally include items such as names of the 

profiles, the existence of moment releases or lack thereof, the loads in the elements and approach 

conditions (whether the secondary is approaching the main from the flange side or the web side) etc.  

                          

                        Figure 1            Figure 2 

While this feature of “Rule based joints” is beneficial in simple cases where the main and the secondary 

(incoming profile) are the only two profiles present at a joint (see Figure 1 above), it fails to deliver for 

complex joints when more than two elements meet at the same joint (see Figure 2) :   

❖ For complex joints, applying a blind “Rule based joint” would create a huge number of clashes, 
resulting in wasted & unproductive time in manual amendments.  
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❖ “Rule based joints” will not have the intelligence to 
“auto-shift” the secondary member slightly to facilitate a 
connection. Such requirements are commonplace in steel 
detailing when incoming members need to be shifted 
slightly to avoid clashes and make erection possible.  
 

❖ A typical example (see Figure 3) would be the need to 
shift the horizontal bracing in flooring systems away from 
the beam-beam intersection points to avoid clashes with 
connection plate. 
 

 

❖ “Rule based Joints” typically do not combine incoming 
elements to create a single common connection if the 
situation demands it.  
 

❖ For example (see Figure 4), two horizontal braces will 
connect to the same point separately, creating a clash 
between the gusset plates, rather than using a single 
common gusset plate.  
 

  

IntelliConnect is an advanced technology which attempts to address these issues which are common in 
building detailing.  IntelliConnect automatically determines which connection type is more appropriate 
for the  selected profiles by checking their type, location and orientation. It automatically alters 
connection parameters if necessary, and creates a feasible & practicle connection.  

IntelliConnect Scope 

IntelliConnect can automatically create connections for various types of elements and profiles. 
IntelliConnect can provide solution for 36 different 
cases grouped in 9 categories. These categories can 
be listed as follows:  

• Splice connections 

• Batten plate connections 

• Sag rod connections 

• Vertical bracing connections 

Figure 4 
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• Truss connections 

• Purlin and girt connections 

• Floor beam connections (with horizontal bracing 
connections if there are any) 

• Beam – Column connections (with horizontal and 
vertical bracings if there are any) 

• Base plate connections (with vertical bracings if 
there are any) 

These includes “simple cases”, e.g. where there are only 2 primary elements and “complex cases” where 

more elements meet at the same node.  

Cases covered 

The following “Simple Cases” are covered by IntelliConnect :  

1. Splice connection (Supports whatever profiles are supported by the Splice macro) 

2. Column Base plate with no incoming vertical bracing. (The column needs to be an I section) 

3. A single beam framing into a main beam. The Beams can be I or channel profiles. The type of 

beam to beam connection can be any one of the following 1) The Stiffened end plate 

connection. 2) The Fin plate connection 3) The beam to beam end plate connection. 

4. A single beam framing into a column. The profiles maybe I or channel profiles. The type of beam 

to beam connection can be any one of the following 1) The Stiffened end plate connection. 2) 

The Fin plate connection 3) The beam to beam end plate connection. 

5. A single horizontal brace framing into a beam. The horizontal brace may be any profile 

supported by the Bolted gusset or welded gusset macros) 

6. A single vertical brace framing into a column. The vertical brace may be any profile supported by 

the bolted gusset or welded gusset macros.  

7. A single purlin sitting on a beam or truss element. The type of connection may be any 

connection supported by the Purlin/Girt macro 

8. A single girt framing into a column. The type of connection may be any connection supported by 

the Purlin/Girt macro 

9. Creation of batten plates on twin profiles. 

10. Connection of a single purlin passing continuously over a truss top chord or roof beam 

The following complex cases are covered by IntelliConnect :  

1. Two horizontal braces framing into a beam (from any side – web or flange) 

2. Two vertical braces framing into a column (from any side – web or flange) 

3. Truss connecting with more than one truss secondary framing into the truss top or bottom 

chord.  

4. Two purlins sitting on a truss top chord or a roof beam 

5. Two girts framing into a column (either colinear or one from each orthogonal direction ) 

6. Two floor beams framing into a main beam from opposite sides 

7. Combinations of floor beams and horizontal braces framing into each other at the same point 

from both sides  
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8. Up to 4 beams framing into a column (two from flange side and two from the web side) 

9. Combination of beams and vertical braces framing into a column 

As far as limitations on profile types and connection types are concerned, the same limitations given in 

the simple cases apply.  

How to use 

The following is the summary of how to use Intelliconnect :  

❖ The user will first select a single or multiple nodes which holds the information of all elements 
meeting at a single point.  

❖ After which the user simply right clicks and goes into the IntelliConnect context sensitive menu and 
select the type of connections to create.  

❖ For some IntelliConnect connections however the user needs to select frames and not nodes (e.g. 
simple cases 9 and 10 stated previously) 

❖ Intelliconnect will use its “internal classifying algorithm” to connect as many of the nodes selected 
by the user as possible.  

❖ However, if it encounters a case which is not supported, it will either partially connect the node or 
leave it completely unconnected.   

❖ A detail report will automatically be displayed listing nodes that are successfully connected or failed 
to connect.  

❖ Intelliconnect Node Control tool is an interactive navigator to browse & examine points that  
partially connected or not connected; so the user can connect / correct them manually.  

Truss Example 

➢ Select the nodes (joints) of the steel structure where you wish to create connection 

Joints are shown as blue dots at the end of the member. For simplicity, you can click and drag a box to 

select all members which will then also select the nodes.  

For illustration purpose, we will create the truss connections based on the Quick Start Guide Steel 

model.  

➢ Go to the 3D View 

➢ Select all the truss members by left-click a drag a box around them  
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➢ Right-click → IntelliConnect → Pick Create Truss Connections 

 

➢ In the Truss Wizard, input the preferred Gusset Plate Thickness or left it blank to automatically 
select thickness for your truss →  Run 

 

Purlin Example 

For illustration purpose, we will create the purlin connections based on the Quick Start Guide Steel 

model.  

➢ Go to the 3D View 

➢ Select all the truss top chords members and purlins by left-click a drag a box around them  
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➢ Right-click → IntelliConnect → Pick Create Purlin Connections 

  

➢ In the Purlin Wizard, choose the preferred type of connection 

➢ For this example, choose “Angle Type” & “Reversed Cleat”  

➢ Input further parameters in the next wizard dialog  →  Run 

• Max Angle Leg Length or profile can be specified 

➢ AutoConnectLog text file will open → Review its contents as it lists all the connections that are 
successfully / unsuccessfully created 

  

 

Beam – Column – Brace Example 

For illustration purpose, we will auto create a beam – column – brace connection based on the Quick 

Start Guide Steel model. 

➢ Go to Storey 1 view →  Select the all the column and beam joints along axis 2 
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➢ Right-click → IntelliConnect → Pick Create Column/Beam Connection 

Where there is multiple possible connection configuration, the subsequent dialog allows you to choose 

which connection type to consider and its priority. 

 

➢ Pick the connection types to consider →  Adjust the priority using up/down arrow → Next  

The relevant bracing shifting, bracing connection & haunch connecting settings will appear next 

➢ Make desired adjustment  → Run → Then connections will be created 
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Beam – Beam – Brace Example 

For illustration purpose, we will auto create a beam – beam – brace connection based on the Quick Start 

Guide Steel model. 

➢ Go to Storey 1 view →  Select the all the beam and beam joints along axis 2 

 

➢ Right-click → IntelliConnect → Pick Create Floor Beam Connection 

Where there is multiple possible connection configuration, the subsequent dialog allows you to choose 

which connection type to consider and its priority. 

 

Note : Beam - Column Connections (IntelliConnect) does not work for connection between beam and 
middle of 2 separate columns (upper and lower). To perform this connection, you can either: 

• Create as single column with LEN in ProtaStructure, then import to ProtaSteel, 

• or Create only using connection macro 
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➢ Pick the connection types to consider →  Adjust the priority using up/down arrow → Next  

The relevant bracing shifting, bracing connection settings will appear next 

➢ Make desired adjustment  → Run → Then connections will be created 

 

 

 

 

 

 

IntelliConnect and Connection Ordering  

Although detailing order often depends on the structure itself, it is usually better to start from large 
connections to small ones. The connection order depends on the size and shape of the structure. For 
example, for the high-rise buildings, starting the connection process from the bottom is more useful. 
Most structures will have similar, symmetrical, or identical axes. Whether you use IntelliConnect or not, 
it is a good practice to finish the frame connections first. 

Note : Floor Beam Connections (IntelliConnect) works when  
beam to beam connection is hinged in ProtaStructure.  
Change to “Line Mode”, Green Dot defined hinged connection. 
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In a typical warehouse structure with truss, the recommended connection order is given below :  

❖ Splice connections (Columns, Beams and Truss members) 

❖ Truss connections  

❖ Apex connections  

❖ Truss top and bottom chord connections to columns  

❖ Base plate connections  

❖ Manual (User defined) connections (User defined connections can be saved for later use and 
repeatedly used for similar joints) 

❖ Connections of the compression members located between the column or truss system. 

❖ Vertical and roof bracing connections 

❖ Purlin or girt connections 

❖ Sag Rod Connections 

❖ Batten Plate Connections 

 

For building type multi-story structures, the recommended order to use IntelliConnect is given below; 

❖ Splice Connections 

❖ Beam-to-column connections (Moment connections first) 

❖ Beam-to-Beam connections 

❖ Horizontal bracing connections 

❖ Base Plate Connections 

❖ Vertical bracing connections 

❖ Purlin, sag rods and batten plate connections 

When working with IntelliConnect, it may be necessary to change the order for two reasons: 

❖ The IntelliConnect operates on a joint. All connections on this joint are simultaneously taken 
into account. For instance, in the case of column-beam connection (beams connecting to both 
sides of the column) with vertical bracing, Intelliconnect will try to create all connections at the 
same time to prevent clashing by making use of common parts. That will change the detailing 
order.   

❖ Since IntelliConnect operates on a joint, it is unclear whether the other joints are too close or 
too far away. If the members or joints are close enough to collide with each other, 
IntelliConnect may face conflict problems. In this case, the Clash Check command can be used to 
detect collisions. IntelliConnect can run with the user's requested order so that it does not use 
the connection information of other joints.  

In summary, connection design should be initiated from the main connections. IntelliConnect can be 
triggered on grid and storey basis. The girt, purlin and sag rod connections can follow. Batten plate 
connections should be created finally.  
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26. Manual Connection  

In ProtaSteel, user can also create connection manually and save them into macro library to re-use them 

at similar nodes. Example of steel beam to RC column manual connection will be demonstrated below. 

Steel Beam to RC Column Manual Connection  

Steel beam to reinforced concrete column connection can be done using manual embedded steel plate 

connection in ProtaSteel. 

The following example illustrates the steps of creating embedded steel plate connection. 

1. Firstly, we can cut of excessive steel beam using the Cut This With That command . 

I. First, select Member to Cut. 

II. Second, select the Cutting Member.  

III. Select “No” from the pop out warning to remain the Cutting Member.  

 
 

 

2. Create the section view plane with the command By Two Points by accessed 

from View tab → Create View → By Two Points 

• Select point between end of the steel beam and the surface of concrete. 

• Double click on the background to open the View Properties → save View Name: Cut 

Section A or any preferred name. (Refer to chapter 7 – Creating new Views) 

 

Note : Remember to turn off the “Cut” in Visibility Filter when necessary. 
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3. In the Cut Section A View, go to Views → Set Work Plane → To View Plane. This sets active 

work plane based on current view. 

 

4. Select plate command  and select the 4 corners of the steel beam clockwise → A plate will 

be created. Then right click on the beam and select Hide Selected. 

 

5. Use ALT to select each corner and right click to use Move Special → Linear to move each corner 

accordingly. 

•  Left Top Corner –  X: -30,  Y:  50 

• Right Top Corner –  X:  30,  Y:  50 

• Right Bottom Corner –  X:  30,  Y: -50 

• Left Bottom Corner –  X: -30,  Y: -50 

 

 

Then, right click at the background to Show All.  

 

Note : Direction x, y, z must always check based on the workplane (axis direction icon ) 
showed in the modelling view. The axis can be based on colour: Red = x, Green = y, Blue = z. 
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6. Right click on the plate, set: 

• Position In Depth: “Behind” 

(Alternatively, can be adjust via hotkey CTRL+W in modelling view) 

• Thickness (t): 10 

7. Go to 3D views, remove the overlapping concrete using the Object Cut command. 

• First, select concrete member. 

• Second, select the steel plate.  

• Select “No” from the pop out warning to remain the Cutting Member.  

 

8. Go to the Section Elevation View, right click on command “Create Dividing Points”  to set to 

“4” in Number of Points? and press OK. Left click on the command to start creating reference 

points. 

• Step 1 - start at left top corner of the steel plate and end at left bottom corner of plate. 

• Step 2 - start at the first point created from the top corner of plate, drag horizontally and 

end at the right side of the steel plate. 

• Step 3 - repeat step 2 but start at the Fourth node which created at the step 1 instead. 

• Delete all points created in Step 1. Delete 2nd and 3rd node created in Step 1 and Step 2 

 



  
  

ProtaSteel 2021 - Quick Start Guide  39 

9. After finished creating the reference points, now we can create steel stud. Right click on Joist

to access the Default Joist Setting and set:  

• Profile name:  D10 

• Out of plane:  Middle 

 

10. Left click on the reference point at left top corner to start creating the rebar → press Enter → 

key in “dz-100” and press Enter again. 

Then, go to 3D view with wireframe view mode, move the stud by -10 on axis Z to avoid 

overlapping with steel plate  

(Important to always check your workplane to move linear). 

 

11. Go back to Section Elevation View, right click on Joist to access the Default Joist Setting and set 

Profile name: D20. Then, left click on the reference point at left top corner to start creating the 

rebar → press Enter → key in “dz-5” and press Enter again. 
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12. Go to 3D view with wireframe view mode, select and right click the created circle to move it to 

end of the stud. 

 

13. Right click Weld command  to access the Default Weld Settings and set:  

• Weld Type: All Around,  

• Size: 1  

Click OK after setting. Start creating weld by Left clicking on the command: 

• Create Weld between Steel Plate and the stud: 

i. Click on the weld path that should be welded. 

ii. Click on the steel plate (which is the larger object) 

• Repeat the same steps to create weld between stud and the stud end. 
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14. Once the welding is finished, highlight and copy the stud including with the welding and paste to 

the rest of the reference points.  

15. Repeat the welding steps for the beam to the steel plate. 

 

 

 

Steel Beam to Steel Column Manual Connection  

Steel beam to steel column connection can be done using manual steel plate connection in ProtaSteel 

too. The steps is rather similar to Steel Beam to Reinforced Column Manual Connection. 

1. We can cut of excessive steel beam using the Cut This With That Boundary command . 

 

 

I. First, select Member to Cut. 

II. Second, select the Cutting Member.  

III. Select “No” from the pop out warning to remain the Cutting Member.  

 

2. Repeat steps 2 to 5 in Steel Beam to Reinforced Column Manual Connection. 

3. Right click on the plate, set: 

I. Position In Depth: “Front” 

(Alternatively, can be adjust via hotkey CTRL+W in modelling view) 

Note :  You may right click the RC column → Hide Selected if necessary.  
Right click on the background → Show All to reveal all the hidden item(s).  

Note :  (Cut this With That command is not suitable due to the cutting member shape is only able to 

cut the overlapping volume.)  

 



  
  

ProtaSteel 2021 - Quick Start Guide  42 

II. Thickness (t): 10 

4. Use Cut This With That command to cut the beam and the plate. Select beam → Select the plate 

→ select “No” in the warning. 

 

5. Now, we can create bolt using Bolt Group command , right click to preset the default setting: 

I. In Settings 1 tab → Diameter: 12 

II. In Positions → Grid:  

➢ X Positions = 30 60 

➢ Y Positions = -30 -140 

 
Click OK once finished. 

6. Left click to use the Bolt Group. 

I. Select plate and column. Then, right click once to enter next stage. 

II. Select top left corner of steel plate and then select top right corner of the steel plate. 
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7. Lastly, weld the beam and the plate using Weld command. 

 

27. Connection Design Reports 

ProtaSteel can create design check reports for the following connections in accordance to EuroCode3, 
AISC (LRFD), AISC (ASD), BS5950:  

• Beam to Beam Connections:  End Plate, Stiffened End Plate, Fin Plate  

• Beam to Column Connections:  End Plate, Stiffened End Plate, Fin Plate  

• Beam to Beam End Plate Connection 

• Haunch Connection 

• Direct Welding Connection 

• Simple Base Plate Connection 

• Flange Plate Moment Connection  

• Extended End Plate Connection 

• Bolted Gusset Plate Connection  

• Corner Bolted Gusset Plate Connection  
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• Welded Gusset Plate Connection  

• Corner Welded Gusset Plate Connection  
 
ProtaSteel can’t create any calculation check for the below connection types. 

• Base Plate Connection 

• Eaves Beam Connection 

• Fitting Connection  

• Sag Rod Connection  

• Purlin and Girt Connection  

• Splice Connection  

• Welded Pipe Connection 

• Apex Haunch Connection  

• Apex Truss Gusset Connection  

• Truss End Plate with Gusset Plate  

• Batten Plate Connection 

• Stiffened Web Opening 

• Multiple Stiffened Web Opening  

• Beam to Wall Connection  

• Embedded Plate Connection  

• Manual Connections 
 
Reports include both geometric checks and capacity checks. In addition, intermediate calculations, 

references to the appropriate clauses of the design code, and corresponding equation are displayed for 

easy checking.   

 

The reports can be created on demand in rich text format (RTF). Design Status colors can be seen on model 

view before report creation. To show the utilization ratio of the connection visually:  

➢ Go to View (top menu)  → Connection Design Ratio Coloring 

The connection will color coded :  Yellow = Not checked/designed; Green = Pass; Red = Fail. 
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➢ Right-Click → Connection Design Reports (or Go to Drawings & Report (top menu) → Connection 
Reports) → Select the desired report :  

• Show Connection Report → Show connection report of selected macro (s) 

• Default Connection Report → Create connection report according to project preference 

• EC3 / BS5950 / AISC_LFRD /AISC_ASD Connection Report → Create connection report for the 
selected code 

28. Connection Design Summary Table 

Connection design summary table presents details about selected connection macros.  The summary 

table shows the “Frame Id”, profile types of macro dependents, connection type, capacity ratio of 

connection, design status according to capacity ratio and whether design report of connection is 

created. 

➢ Select one or more connection macro 

If no macro is selected, the table will show all supported macros in the model  

➢ Go to Drawings & Reports (top menu)  → Connection Reports → Connection Design Summary 
Table 

To check the connection & generate the report :  

➢ Select the connection by any of these methods : 

• Select the connection macro sign   

• Select any  component of the connection (eg. a 
plate or a bot) → then press “M” 

• Left click and drag a window enclosing the entire 
connection 

TIP : Hold down CTRL to multiple select 
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The top icons from left to right :  

❖ Update →  Refreshes the table 

❖ Show in Model →  Locate & zoom in the selected macro in the model view.  Double-clicking on 
any row will also perform the same function.  

❖ Create Report → Create the connection design report of the selected macro.  Hold down CTRL 
key to multiple select.  

❖ Open Report → Open the selected design report 

If the connection fails, change the macro properties. When the connection parameters are enough, the 

connection check again and color will be in green. 

29. Collision / Clash Checks 

Prior to creating detail general arrangement drawings, it is recommended that a collision check be 

performed for all elements.  The collision check shows elements which are clashing or overlapping :  

➢ Select all or some elements of the model 

➢ Go to Tools (top menu) → Diagnostic Tools  → Clash Check 

➢ Alternatively, right click on the model screen and pick Clash Check  

As a result, the clashing elements will be left selected (in red). Generally, collision occurs when two or 

more elements overlap each other. It usually occurs when connections are not made yet. For example, 

before the haunch connection was made, the beam end flange & web plate is overlapping into the 

column (as shown below). 
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If a Clash Check is performed by selecting both the elements, they will remain selected after the check.  

30. Audit Model  

Before creating detail drawings, it is important to determine errors and inconsistencies that may exist in 

the model. This function will perform several model tests, such as duplicate points :  

➢ Go to Tools (top menu) → Diagnostic Tools  → Audit Model 

➢ Select the checks desired →  Run Test 

 

You can select the object(s) specified in the result report and automatically navigate to it in the model.  

31. Detail Item Manager     

The Detail Item Manager creates and manages detail items such as the connections. We can use this 

function to create exploded drawings of the connection with different views & detail information such 

as dimensions, location of bolts, welds, etc.  
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This box controls the various directional views that we want to show in the drawings. The view is shown 
in 3 colors, red, blue and green. Each color has a front & back view. Hence there is a total of 6 possible 

In the Detail Item Manager :  

➢ Type the name “Con1” at the bottom  

➢ Pick  Add →  Con 1 will be added  

➢ Pick Select Objects 

➢ Select the beam, the column & the 2 
braces  

➢ Right-click  

The moment we do so, a “3D detail box” 
appears around the connection in the 3D view 
(as shown below) 
 
 

➢ Zoom into the connection that we have created at 
Grid C 

➢ Click & drag a window to select all components of 
the connections, including all the plate, bolts & 
welds  

➢ Pick Detail Item Manager  

The Detail Item Manager dialog will appear.  

 



  
  

ProtaSteel 2021 - Quick Start Guide  49 

views.  The view names can be changed – so if the top of the connection is not the actual top, change 
the name manully.   

➢ For this connection, pick Front & Right only  

➢ Pick Filter Box to show only the connection elements (Restore Filter will restore all elements) 

➢ Click on “+” icon to add a 3D view of the connection (if desired) 

➢ Close to save & exit the dialog 

➢ Repeat the same steps for the Splice Connection at corner column at GL D/3 

For practice purposes, we can similarly insert connection box on the connections we have previously 
created in Story 1. The summary of steps are : 

➢ Open the view that is most suitable to insert the connection, try Storey 1 view 

➢ Zoom into connection 

➢ Click & drag a window to select all components of the connections, including all the plates & 
bolts 

➢ Pick Detail Item Manager  

➢ Add the connection name 

➢ Click Select Objects & pick all the members of the connection 

➢ Tick the desired view direction box 

➢ Close the dialog 

We have completed the connections and are now ready to generate the drawings.  
 
 



  
  

ProtaSteel 2021 - Quick Start Guide  50 

32.  Preparing Engineering Drawings 

ProtaSteel has a powerful tool to prepare engineering drawings – it’s simply called the “Drawing 

module”. The drawings are based on the views prepared in the modelling module. The steps are 

summarized as below : 

➢ Create the desired Views in main modelling view.  

➢ Ensure the orientation of the view you want to use in the drawing is correct as the drawing 
module will automatically use the latest views.  

• Double-click on Axis 3 view → Press F4 to reset the view to default 

• Double-click on Storey 1 view → Press F4 to reset the view to default 

➢ Create any detail views such as connection details using Detail Item Manager 

➢ Start the Drawing module by double-clicking Drawings in the Explorer pane (Ctrl + D) 

33. Drawing Module 

In the Drawing Module, the same views that was shown in the main model will be duplicated under the 

Explorer → Modelling Views : 

• 3D View – 3D view of the model 

• Storey F – foundation plan view (ST00 in ProtaStructure) 

• Storey 1 – Storey 1 plan view as defined in ProtaStructure 

• Storey 2 – Storey 2 plan view as defined in ProtaStructure 

• Axis 3 – New view along Axis 3  

• Axis A – New view along Axis A 

If you do not have the same views, please close the drawing module to return to the main model & 

create the view as outlined in previous sections.  

34. Creating Drawings via Drawing Manager 

➢ Double-click on Drawing Manager (or F6)  

The Drawing Manager is where you can start a new drawing.   

The View Manager allows you to manage the drawings:  

➢ Create new drawing using Create Drawing →  Create Drawing Dialog will appear. 
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➢ Name the drawing Storey 1, Set Paper Size to A1 → click OK. 

 

➢ Select Storey 1 → Open Drawing   

 

➢ Alternatively, simply double-click on Storey 1 to open it. 

➢ Right click on Storey 1 located at the explorer panel→ Create Viewport  

 

➢ Close the Drawing Manager & review the drawing. 

 

The outermost brown line is the Drawing Border (A0 size). The size & other settings of the drawing can 
be changed by :  

Drawing Border 

Viewport Border 
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➢ Double-click on any empty space within the drawing border to access the Drawing Properties 

  

The inner dotted blue line is the Viewport border which is directly linked to the view : 

➢ Place the mouse cursor at the lower-right corner → cursor will change to resize  

➢ Click & drag to resize & ensure all the elements is visible 

➢ Place the mouse cursor at the boundary line → click & drag to move the position of the region 

➢ Double-click any place within the Viewport to access the Viewport Properties 

Note : Region has been renamed Viewport in current release 

Documents Properties will appear where the 

following can be changed: 

• Drawing Name 

• Print Area & Margin 

• Paper Size & Orientation 

• Created, Approve by, Approved Date 

• Document State : Normal / Freeze / Broken 
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Viewport Proper Editor dialog will appear. In the General tab, 
the following can be changed : 

• Name of the region 

• Scale  

• MovX, Mov Y : Coordinates of view 

• Rotation : States the rotation angle 

• Drawing Mode : Line/All Visible/Hidden Line/Full Dashed 

➢ Change the Name to Storey 1 Plan  

➢ Change Scale to 25  

➢ Change Draw Mode to Hidden Line → Apply 

The drawing will be updated to scale & hidden line. 

➢ Pick Fit to auto fit all the elements & the new title  

 

 

 

 

➢ Go to Label Settings tab 

The Label Settings dialog allow you to change :  

• Label Position 

• Offsets  

• Name & Scale Text Settings 

➢ Pick Locate Outside so the label will be place outside the 
region border 

➢ Tick Write next to Name & Scale Text Settings 

➢ Pick Change under Name Text Settings 

➢ Change Name Text Height to 10mm → OK 

➢ Change Scale Text Height to 10mm → OK → Apply 

Notice that the name & scale appears larger in the drawing. 
 

 

 

 

 

  

 

➢ Go to Filtering tab 

The options here controls what is shown in the drawing : 
• Up (+) & Down (-) filters objects in & out of the paper 

• Min X & Max X filters objects in the X  plan direction 

• Min Y & Max Y filters objects in the Y plan direction 

• Up-Down Method : 
- Partial : Any element that exists partially within the above 

extents will be shown 
- Full : Only elements that exist fully within the above extents 

will be shown 

• Filtering Settings – expose more filter options 

➢ Change Up(+) to +500 & Down (-) to -500   → Apply → 
Girts disappears as they are placed slightly above the 
floor level 

➢ Pick Filter Settings  
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35. Visibility and Selectability in Drawing Module 

Visibility settings allows user to show and hide elements that wish to hide/show in the drawings, while 

Selectability settings allows user to lock the elements and prevent from mis-click or accidentally 

deleting the elements.    

 

By default, all elements will be ticked. If selected element is unticked and press “OK”, the effect will 

immediately apply to the selected element in the drawing. 

 

Grid Level Visibility 

Now, we will insert the 3D view into the drawing.  

➢ Right-click on 3D View → Create Viewport  

 

Filter Options enable advance filtering :  

• General : Steel, Concrete, Unique ID, etc 

• Object types : Grid, Profile, Joint, Weld, etc 

• Profile : Columns, Beams, Brace, etc 

• Plate : Plate IDs, Types & Usage 

• Solid & Macro  

➢ Go to Profile tab 

➢ Tick Column, Beam, H. Brace 

➢ Pick OK to exit 

This ensures that only column, beam and 
horizontal elements are shown.  
 

 

 

 

 

 



  
  

ProtaSteel 2021 - Quick Start Guide  55 

In the 3D view, the grids are appeared in each storey.  

 

To show the grids at the storey 0 only,  

➢ Double click on the grids → Grid Properties Editor will appear. 

➢ Untick 1. Level and 2. Level under Grid Level Visibility → Click OK.  

 
➢ The 3D view will now looks clean. 
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36. Profile Annotation 

We now add steel profile annotation, i.e. show the member sizes.  Firstly, we should select the members 
we want to annotate. To select the members easily, we can control what elements is selectable: 

➢ Click on Selectability icon  at the top menu (or View → Selectability Settings) to access the 
Drawing Options dialog 

 
 

➢ In the drawing, left click & drag a box around all the steel members to select them  

➢ Right-click on Profile Annotation icon  to access the Annotation Settings 

 

 

The annotations are added next to all steel members as shown below.  

The settings here controls how steel members are 
annotated (labelled) :  
• The various type of annotations are listed in the table 

• Click & drag any annotation name into the box which 
also defines the position of the annotation  

➢ Click and drag Profiles, Material & 
ProtaStructure Label in the box 

➢ Click Annotation Settings to view or change the 
text settings :  
• Font type & size  

• Format or style of the annotations  

➢ Change the Text Height to 7 mm 

➢ Click Apply & Create Annotations  

  

c 

 

c 

➢ Untick Viewport → OK   

This prevents you from selecting the region border. 

The same options are available in Visibility tab which controls 
what is shown in the drawing.    

 
 

 

 

 

/ 
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37. Dimension  

Dimension tools   can be used to insert dimensions in the drawing.  

 

Notice the dimension is shown dynamically. 

➢ Left click on the 3rd point & then the 4th point 

➢ Move the mouse cursor to the exact position where you want the text to be placed  

➢ Right-click to confirm & create the dimensions 

The dimensions will be created as shown below.  

 

Notes :  

❖ Alternatively, click OK to exit the Frame 
Annotation dialog → Select elements → Left-

click on the Profile Annotation icon  

❖ ProtaStructure Labels are member labels such 
as 1B1, 1C1  

❖ The annotation position can be moved by left 
click & drag 

❖ Annotations can be deleted using Delete key 

❖ Annotation text size, font height, etc can be 
changed by selecting  them → ENTER → 
Annotation Text Property Editor 

 

➢ Zoom in the top around primary beam along 
axis D 

➢ Click Horizontal Dimension  

➢ Left click on the 1st point & then the 2nd point 
between the points to be dimensioned.   

➢ Move the mouser cursor away to the right 

 

1 2 

3 4 
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38. Creating Connection Detail   

Let us now create a new connection drawing for the connection we created along Grid 3.   

➢ Double-click on Drawings Manager (or F6)  

➢ Pick Create Drawing →  Create Drawing Dialog will appear 

 

➢ Name it “Connection Axis 3” 

➢ Change the Paper Size to A1 →  Orientation = Landscape  

➢ Pick Drawing Type =  Steel Connection Detail  

➢ Pick OK → The drawing will be created & automatically opened 

➢ Close the Drawing Manager dialog (Pick OK if prompted to save) 

The drawing “Connection Axis 3” will be opened and brought to focus.  The drawing is empty & we will 
insert the required view into the drawing.  

➢ Right-click on Axis 3 View → Create Viewport  

 

The view region will be inserted but region may not be positioned correctly. Let us move it within the 
drawing border. In order do this, we need to be able to select the blue region border.  

➢ Click on Selectability icon  at the top menu to access the Drawing Options dialog 

 

➢ Tick Viewport → OK   

➢ Click & drag the viewport into the Drawing 
Sheet 

 
 

 

 

 

 

 

c 
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➢ Right-click on Connection Detail Drawing macro icon  

In this dialog you can set the details of the connection drawing such as the scale and Annotation  

 

➢ Under Annotation & Display Settings, review Annotation, Field and Text & Display 

➢ Click on Connection Detail Drawing Macro icon  

The Connection Detail will be inserted into the drawing as shown below. 

 

➢ Double-click on the region to access the 
Viewport Property Editor 

➢ Scale can be change but let’s leave it as 
default  

➢ Go Filtering tab → change Up = 500 & 
Down = -500  

➢ OK to close the dialog  

Notice there is a circle around the connection 
– this is directly linked to the connection box 
created in the main model.  
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Further customization of the connection detail can be done. 

 

 

 

Plate, Bolts & Weld Annotation Tools     
 
The bolts, plates and welds are automatically annotated in the above example. If you wish, you can 

manually do so by using the plate, bolts & weld annotation tools   

➢ Hold down CTRL key → select all the annotations of the “Front” detail → delete them 

➢ Click & drag a window (right to left) to select bolts & plates to be annotated (does not matter if 
other objects are selected) 

  

➢ Double-click in the detail region of the connection to 
access the Viewport Property Editor  

Under Detailing tab, you can change :  

• Bolt Import Style  

•  Bolt Drawing Style 

➢ Try the various options & click Apply 

 

 

 ➢ Go to Filtering tab → Pick Filter 
Settings  

➢ Go to Object Types  

You can choose to turn on/off objects. 

➢ Untick Weld → OK → Apply  

The welds shown in thicker lines will be 
hidden. 

 

 

 

 

➢ Right-click on Bolt Annotation access the 
Settings 

➢ Pick Clear to remove existing settings 

➢ Click & Drag Count, Diameter & Material to the 
bottom Fields  

➢ Pick Annotation Settings to view/change font type, 
color, etc → OK 

➢ Pick “Apply & Create Annotations” 
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You should get details which are similar to figure shown below (depending on your preference). 

 

39. Numbering Objects 

Before parts and assembly views & drawings can be created, the 

objects must be numbered.  By default, all objects are included in the 

same numbering group. To assign objects to different groups: 

➢ Double-click on object  to open the Profile dialog 

➢ In the Detailing Definitions tab,  input Drawing Group number  

This feature was developed to number the different parts of the 

structure separately.  

For each group of objects, the Prefix & Start Number can be specified.   

After numbering process, the actual part and assembly number will 

be shown under “Actual Number”. 

➢ Go to Drawings & Reports (top menu) → Numbering → Perform Numbering 

The Numbering Options dialog will appear.  

 

 

➢ Right-click on Plate Annotation  access the 
Settings 

➢ Pick Clear to remove existing settings 

➢ Click & Drag PL Thickness, & Material to the 
bottom Fields  

➢ Pick Annotation Settings to view/change font type, 
color, etc → OK 

➢ Pick “Apply & Create Annotations” 

 

 

 The drawing can be further improved by : 

➢ Go to Viewport Properties Editor and change 
the Scale 

➢ Change Offset (X,Y) to reposition the 
connection 

➢ Delete any annotations that you think is not 
required 

➢ Click & drag the annotation to reposition it 
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As the model is continuously being revised, the numbering process need to be repeated. ProtaSteel has 

extensive options for re-numbering. Numbering Options can also be configured according to the 

preferences of the manufacturer. For example, there is option to force geometrically identical part to 

have the same number.  

Do Numbering  

❖ Specifies whether to number the selected group 

Unique Number 

❖ Unique: Can be selected for reinforced concrete elements. Objects are given a different number 
regardless of its geometric properties (beyond the scope of ProtaSteel) 

❖ Not Unique: Should be used for steel model. Makes numbering by looking at geometry and material 
properties. 

❖ Spatial Sort: Can be selected for reinforced concrete model. Performs numbering according to the 
object’s position. The Object's reference point is sorted first by X and then by Y. Different groups 
should be made for different levels. Consecutive numbered column and beam applications can be an 
example.  

Renumber All 

❖ Modified: Number only the modified objects. Ignores objects that have not changed. 

❖ Renumber: Number all objects.  

Reuse Old Numbers 

❖ Reuse: Uses old numbers. 

❖        : Don’t use old numbers. After the changes, there may be no elements belonging to a number. 
Specifies whether to use this number for a new element. 

Modified Part 

As an example, we have 3 nos of P5, 2 nos of P7; then 3 nos of P5 have the same change and have 

become the same as the P7. 

❖ Keep Number If Possible: Retains the numbers if possible after the change. If setting is used, the 
result is still 3 nos of P5, 2 nos of P7. 

❖ Compare to Old : Compares and assigns the part-marks from previous numbering if possible. If this 
option is used, the result is 5 nos of P7. 

❖ Take New Number: Assigns new part-marks. This option will lead to 2 nos of P7 and 3 nos of P8. 

  

- 
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New Part 

Similar to “Modified Settings”. Only applies to newly created objects. Hence, there is no option to “Keep 

the Number If Possible”. 

❖ Compare to Old : Compares and assigns the part-marks from previous numbering if possible. 

❖ Take New Number: Assigns new part-marks. 

40. Creation of Parts and Assembly Drawings 

If there are no problems after Audit Model, Clash check and Numbering, the parts and assembly drawing 

can be produced.  

You can create the part & assembly drawing for the entire model, or only for some objects.  

➢ Select the entire model or objects  

➢ Go to Drawings & Reports → Drawings → Create Assembly Drawing / Create Part Drawing   

The Drawing Module will be launched and the drawings will be created.  

➢ In the Drawing Manager → Double-click to open & review the drawing 
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41. Import Titleblock using DXF Import 

In ProtaSteel, user can import titleblock and print drawings directly. 

➢ User can simply import company standard titleblock as DXF in Drawing Module by going to File 

→ Import → Import DXF 

 

➢ Select the company standard titleblock DXF directory. 

 

 

 

➢ Paper Anchor and DXF Anchor set to Bottom Right. 

 

➢ Titleblock annotation can be insert/modify using "Text" Function. 

Note : Ensure the titleblock drawing should contain only titleblock, not in block format and 
drawing dimension unit is correctly set. 
 



  
  

ProtaSteel 2021 - Quick Start Guide  65 

Points, Construction Objects and Text

 

Points, Construction Objects and Text allow user to add details to the drawings such as the opening 

dash line, "to be continued" line, revision cloud, description and etc. 

➢ If you wish to select a point where has no object snap, you can hold left ALT to select a free 

point. 

➢ If you wish to draw it horizontally, please hold left CTRL before selecting the start point. 

➢ If you wish to draw it vertically, please hold left SHIFT before selecting the start point. 

42. DXF Export  

All the drawings created in ProtaSteel can be exported as DXF format:  

➢ Double-click on Drawing Manager (or F6)  

➢ Under DXF Export → Pick Settings  

In the DXF Export Settings, you can choose the layers to be exported, change the Layer Name & Line 
Type. 
 

 
 

➢ Close the DXF Export Settings 

➢ Pick Export → Choose the destination folder → OK 

The dxf drawing will be created in the folder selected.  
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43. IFC File Export 

ProtaSteel model can be exported as Industry Foundation Classes (IFC) file. IFC is a Building Information 
Modelling (BIM) data structure created by buildingSmart International and is the ISO 16739: 2013 
standard. IFC File format is implemented by most design software on the market including leading Building 
Information Model (BIM) platforms like Autodesk Revit, Bentley and Tekla Structures.  This enables 
sharing of building information models between various BIM platforms.  

➢ Select objects to be exported as IFC file format.   

If no object is selected, then all objects will be exported.  

➢ The File → Export →  IFC Export  

 

➢ Click ‘…’  to specify the file name and location to export  

➢ Check the desired export options → Export 
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44. Material Take off 

ProtaSteel automatically creates material lists of the whole of the steel structure. Material Lists is 

located under the Drawing and Reports tab. 

 

There are two methods to prepare for your Material Takeoff and will be presented below: 

Method 1  

To generate quantity takeoff, for example steel members which will be sorted by sections used in 

project, please refer to following steps: - 

1. Go to Drawings & Report → Material List → Prepare Material Takeoff 

2. Click OK on the Group Selector Dialog.  

 

3. Two Quantity Takeoff Tables (with different format) will automatically export as CSV file. 

• Summary Report and Quantity Takeoff based on the section length 

 

 Note : Repeat step 1 to 3 for the other Material Lists option in order to export to CSV file. 
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Method 2 

Method 2 generates more detail quantity takeoff of steel members with choices of categories to be 

included in the table. Please refer to following steps: -  

• Go to Drawings & Reports → Reports → Steel Detailing → Gross Profile Material List 

• Select corresponding format and units and click Execute Report. 

• Click Save to export generated report as CSV file.  
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45. Closing Summary 

Congratulations! You have completed your steel model & generated the engineering drawings in 

ProtaSteel.  

In this Quick Start Guide, we have imported the ProtaStructure model in ProtaSteel. We then inserted 

ancillary steel members such as sag rods, adjusted members to their final positions, created some steel 

connections & generated the engineering drawings. This will give you the necessary knowledge to proceed 

to a real project.  

For more help and guidance, please refer to ProtaSteel help reference accessible from Help menu.  

Alternatively, you can attend our training courses to obtain a more in-depth knowledge of the usage of 

the software.  Please visit our website www.protasoftware.com for more information.  

 

 

 

http://www.protasoftware.com/

